cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
Walkthrough Wednesdays
1456
Views
0
Helpful
4
Replies
adamtodd16
Participant

FXO Incoming / Outgoing Setup for 911

I have Analog FXO cards in each gateway for incoming / outgoing 911 calls only (all other calls are routed to PRI).

Outbound calls are working for 911, but if the 911 operator has to call the site back; they receive a fast busy when they call the number attached to the FXO port.

I'd like to be able to send these incoming calls to a specific extension. Here is the config:

trunk group  OUTBOUND-SRST

hunt-scheme sequential

!

voice-card 0

!

interface FastEthernet0/0

no ip address

speed 100

full-duplex

!

interface FastEthernet0/0.610

description DATA NETWORK

encapsulation dot1Q 610

ip address 10.10.6.1 255.255.255.0

!

interface FastEthernet0/0.619

description VOICE NETWORK

encapsulation dot1Q 619

ip address 192.168.6.1 255.255.255.0

h323-gateway voip bind srcaddr 192.168.6.1

!

interface FastEthernet0/1

description UPLINK to FBDO

  duplex auto

speed auto

!

ip route 0.0.0.0 0.0.0.0 10.1.1.1

!

!

no ip http server

no ip http secure-server

!

ip access-list standard SNMP

permit 10.1.200.63

!

snmp-server community 3C4a5I6S7p8 RO SNMP

!

!

!

control-plane

!

!

!

voice-port 0/0/0

timing hookflash-out 50

!

voice-port 0/0/1

trunk-group OUTBOUND-SRST 1

timing hookflash-out 50

!

voice-port 0/0/2

!

voice-port 0/0/3

!

ccm-manager fallback-mgcp

ccm-manager redundant-host 192.168.10.20

ccm-manager mgcp

ccm-manager music-on-hold

ccm-manager config server 192.168.111.20 

ccm-manager config

!

mgcp

mgcp call-agent 192.168.111.20 2427 service-type mgcp version 0.1

mgcp dtmf-relay voip codec all mode out-of-band

mgcp rtp unreachable timeout 1000 action notify

mgcp modem passthrough voip mode nse

mgcp package-capability rtp-package

no mgcp package-capability res-package

mgcp package-capability sst-package

no mgcp package-capability fxr-package

mgcp package-capability pre-package

no mgcp timer receive-rtcp

mgcp sdp simple

mgcp rtp payload-type g726r16 static

mgcp bind control source-interface FastEthernet0/0.619

mgcp bind media source-interface FastEthernet0/0.619

!

mgcp profile default

!

dial-peer voice 999000 pots

service mgcpapp

port 0/0/0

!

dial-peer voice 1 pots

trunkgroup OUTBOUND-SRST

destination-pattern 9[2-9]......

forward-digits 7

!

dial-peer voice 911 pots

destination-pattern 9911

port 0/0/0

forward-digits 3

prefix 911

!

dial-peer voice 2 pots

trunkgroup OUTBOUND-SRST

destination-pattern 91[2-9]..[2-9]......

forward-digits 11

!

dial-peer voice 3 pots

trunkgroup OUTBOUND-SRST

destination-pattern 918[8,7,0,6][8,7,0,6].......

forward-digits 11

!

dial-peer voice 4 pots

trunkgroup OUTBOUND-SRST

destination-pattern 9[2-8]11

forward-digits 3

!

dial-peer voice 5 pots

trunkgroup OUTBOUND-SRST

destination-pattern 90[2-9]..[2-9]......

forward-digits 11

!

dial-peer voice 6 pots

trunkgroup OUTBOUND-SRST

destination-pattern 9011T

forward-digits all

prefix 011

!

dial-peer voice 999001 pots

service mgcpapp

port 0/0/1

4 REPLIES 4
adamtodd16
Participant

Anyone?

Have you configured the attendant dn on the gateway config page in CUCM?

So a bit confused on your situation. Do all inbound calls come into the FXO port? If so are any inbound calls working to the number you have on caller-id? Since you are using MGCP looking at the config on the GW will not give us any indication as to what you have configured for this port. It could be as simple as Don suggested that there is no attendent dn on the GW config page. Or you are masking the caller-id with a wrong number for 911 calls.

Could you run make a call to the number which you are sending out to 911 and run 'debug voice cc inout' on the GW?

Might give us a clearer picture what is happening here.

Thanks everyone - for some reason I didn't have a CSS setup on the port in CUCM.

All good now!

Content for Community-Ad

Spotlight Awards 2021