cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
4289
Views
0
Helpful
7
Replies
Highlighted

FXO port line voltage issue with parallel lines

Hi All,

I have a situation where , six analog lines connected to the cme. PSTN lines acts as one main line and rest of the five lines are as parallel lines to the main line.

Now the issue is , i can get the ring vlotage in the main line, output below;

   

#test voice port 0/0/0 si-reg-read 29 1

VOICE_ROUTER_NBN#

May  3 09:42:36.511:

Values read from SiLabs Codec connected to DSP 0, channel 0:

--------------------------------------------------------------

Register 29 = 0x33

When i test the other five lines, those lines don't have any ring voltage at all..

VOICE_ROUTER_NBN#test voice port 0/0/2 si-reg-read 29 1

VOICE_ROUTER_NBN#

May  3 09:41:27.263:

Values read from SiLabs Codec connected to DSP 0, channel 2:

--------------------------------------------------------------

Register 29 = 0x00

I have teseted the all six analog lines from the POTS phone (Analog phone). all are working fine.

Now my question is how to make these other lines work (or get the ring voltage from fxo port) ?? currently i can make outgoing calls only through the main line (First Line).

Expecting a positive responce from someone

Regards

kajen

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted

Router doesn not detect loop current. That cannot be fixed from router side.

Even if you have loop current with regular phone, telco needs to fix it. You can tell them that you need higher current or voltage on the loop.

Please remove duplicate posts.

View solution in original post

7 REPLIES 7
Highlighted
Hall of Fame Master

Which IOS version are you using?

csan you post "debug vpm signal" when calling out ?

Highlighted

Hi Paolo,

IOS version is Version 15.0(1r)M15.......check the out put below,

VOICE_ROUTER_NBN#debug vpm signal

Voice Port Module signaling debugging is enabled

VOICE_ROUTER_NBN#

May  3 10:22:50.619: htsp_process_event: [50/0/21.1, EFXS_ONHOOK, E_DSP_SIG_1100]efxs_onhook_offhook htsp_setup_ind

May  3 10:22:50.619: [50/0/21.1] get_local_station_id calling num=131 calling name=EXT 131 calling time=05/03 13:22  orig called=

May  3 10:22:50.623: htsp_process_event: [50/0/21.1, EFXS_WAIT_SETUP_ACK, E_HTSP_SETUP_ACK]efxs_check_auto_call

May  3 10:22:51.291: htsp_digit_ready(50/0/21.1): digit = 9

May  3 10:22:51.627: htsp_digit_ready(50/0/21.1): digit = 3

May  3 10:22:51.811: htsp_digit_ready(50/0/21.1): digit = 6

May  3 10:22:52.159: htsp_digit_ready(50/0/21.1): digit = 5

May  3 10:22:52.311: htsp_digit_ready(50/0/21.1): digit = 5

May  3 10:22:52.627: htsp_digit_ready(50/0/21.1): digit = 8

May  3 10:22:52.827: htsp_digit_ready(50/0/21.1): digit = 5

May  3 10:22:53.055: htsp_digit_ready(50/0/21.1): digit = 2

May  3 10:22:53.243: htsp_digit_ready(50/0/21.1): digit = 1

May  3 10:22:53.247: htsp_timer_stop3

May  3 10:22:53.247: htsp_process_event: [50/0/21.1, EFXS_OFFHOOK, E_HTSP_PROCEEDING]efxs_offhook_proceeding

May  3 10:22:53.247: [50/0/21.1] set signal state = 0x8 timestamp = 0htsp_setup_req

May  3 10:22:53.247: htsp_process_event: [0/0/1, FXOLS_ONHOOK, E_HTSP_SETUP_REQ]fxols_onhook_setup

May  3 10:22:53.247: [0/0/1] set signal state = 0xC timestamp = 0

May  3 10:22:53.247: htsp_timer - 1300 msec

May  3 10:22:53.503: htsp_process_event: [0/0/1, FXOLS_WAIT_DIAL_TONE, E_DSP_SIG_1100]fxols_power_denial_detected

May  3 10:22:53.503: htsp_timer2 - 1000 msec

May  3 10:22:53.503: htsp_timer_stop

May  3 10:22:54.503: htsp_process_event: [0/0/1, FXOLS_WAIT_DIAL_TONE, E_HTSP_EVENT_TIMER2]fxols_power_den_disc

May  3 10:22:54.503: htsp_timer_stop

May  3 10:22:54.503: htsp_timer_stop2

May  3 10:22:54.503: [0/0/1] set signal state = 0x4 timestamp = 0

May  3 10:22:54.503: htsp_process_event: [0/0/1, FXOLS_ONHOOK, E_HTSP_RELEASE_REQ]fxols_onhook_release

May  3 10:22:54.503: htsp_timer_stop3 htsp_setup_req

May  3 10:22:54.503: htsp_process_event: [0/0/2, FXOLS_ONHOOK, E_HTSP_SETUP_REQ]fxols_onhook_setup

May  3 10:22:54.503: [0/0/2] set signal state = 0xC timestamp = 0

May  3 10:22:54.503: htsp_timer - 1300 msec

May  3 10:22:54.759: htsp_process_event: [0/0/2, FXOLS_WAIT_DIAL_TONE, E_DSP_SIG_1100]fxols_power_denial_detected

May  3 10:22:54.759: htsp_timer2 - 1000 msec

May  3 10:22:54.759: htsp_timer_stop

May  3 10:22:55.759: htsp_process_event: [0/0/2, FXOLS_WAIT_DIAL_TONE, E_HTSP_EVENT_TIMER2]fxols_power_den_disc

May  3 10:22:55.759: htsp_timer_stop

May  3 10:22:55.759: htsp_timer_stop2

May  3 10:22:55.759: [0/0/2] set signal state = 0x4 timestamp = 0

May  3 10:22:55.759: htsp_process_event: [0/0/2, FXOLS_ONHOOK, E_HTSP_RELEASE_REQ]fxols_onhook_release

May  3 10:22:55.759: htsp_timer_stop3 htsp_setup_req

May  3 10:22:55.759: htsp_process_event: [0/0/3, FXOLS_ONHOOK, E_HTSP_SETUP_REQ]fxols_onhook_setup

May  3 10:22:55.759: [0/0/3] set signal state = 0xC timestamp = 0

May  3 10:22:55.759: htsp_timer - 1300 msec

May  3 10:22:56.015: htsp_process_event: [0/0/3, FXOLS_WAIT_DIAL_TONE, E_DSP_SIG_1100]fxols_power_denial_detected

May  3 10:22:56.015: htsp_timer2 - 1000 msec

May  3 10:22:56.015: htsp_timer_stop

May  3 10:22:57.015: htsp_process_event: [0/0/3, FXOLS_WAIT_DIAL_TONE, E_HTSP_EVENT_TIMER2]fxols_power_den_disc

May  3 10:22:57.015: htsp_timer_stop

May  3 10:22:57.015: htsp_timer_stop2

May  3 10:22:57.015: [0/0/3] set signal state = 0x4 timestamp = 0

May  3 10:22:57.015: htsp_process_event: [0/0/3, FXOLS_ONHOOK, E_HTSP_RELEASE_REQ]fxols_onhook_release

May  3 10:22:57.015: htsp_timer_stop3 htsp_setup_req

May  3 10:22:57.015: htsp_process_event: [0/1/0, FXOLS_ONHOOK, E_HTSP_SETUP_REQ]fxols_onhook_setup

May  3 10:22:57.015: [0/1/0] set signal state = 0xC timestamp = 0

May  3 10:22:57.015: htsp_timer - 1300 msec

May  3 10:22:57.271: htsp_process_event: [0/1/0, FXOLS_WAIT_DIAL_TONE, E_DSP_SIG_1100]fxols_power_denial_detected

May  3 10:22:57.271: htsp_timer2 - 1000 msec

May  3 10:22:57.271: htsp_timer_stop

May  3 10:22:58.271: htsp_process_event: [0/1/0, FXOLS_WAIT_DIAL_TONE, E_HTSP_EVENT_TIMER2]fxols_power_den_disc

May  3 10:22:58.271: htsp_timer_stop

May  3 10:22:58.271: htsp_timer_stop2

May  3 10:22:58.271: [0/1/0] set signal state = 0x4 timestamp = 0

May  3 10:22:58.271: htsp_process_event: [0/1/0, FXOLS_ONHOOK, E_HTSP_RELEASE_REQ]fxols_onhook_release

May  3 10:22:58.271: htsp_timer_stop3 htsp_setup_req

May  3 10:22:58.271: htsp_process_event: [0/1/1, FXOLS_ONHOOK, E_HTSP_SETUP_REQ]fxols_onhook_setup

May  3 10:22:58.271: [0/1/1] set signal state = 0xC timestamp = 0

May  3 10:22:58.271: htsp_timer - 1300 msec

May  3 10:22:58.527: htsp_process_event: [0/1/1, FXOLS_WAIT_DIAL_TONE, E_DSP_SIG_1100]fxols_power_denial_detected

May  3 10:22:58.527: htsp_timer2 - 1000 msec

May  3 10:22:58.527: htsp_timer_stop

May  3 10:22:59.527: htsp_process_event: [0/1/1, FXOLS_WAIT_DIAL_TONE, E_HTSP_EVENT_TIMER2]fxols_power_den_disc

May  3 10:22:59.527: htsp_timer_stop

May  3 10:22:59.527: htsp_timer_stop2

May  3 10:22:59.527: [0/1/1] set signal state = 0x4 timestamp = 0

May  3 10:22:59.527: htsp_process_event: [0/1/1, FXOLS_ONHOOK, E_HTSP_RELEASE_REQ]fxols_onhook_release

May  3 10:23:01.699: htsp_process_event: [50/0/21.1, EFXS_OFFHOOK, E_DSP_SIG_0100]efxs_offhook_onhook

May  3 10:23:01.699: htsp_timer - 10 msec

May  3 10:23:01.711: htsp_process_event: [50/0/21.1, EFXS_OFFHOOK, E_HTSP_EVENT_TIMER]efxs_offhook_timer

May  3 10:23:01.711: htsp_process_event: [50/0/21.1, EFXS_ONHOOK, E_HTSP_RELEASE_REQ]efxs_onhook_release

May  3 10:23:01.711: htsp_timer_stop

May  3 10:23:01.711: [50/0/21.1] set signal state = 0x4 timestamp = 0

Regards

kajen

Highlighted

That is ROMMON version, not IOS, check again.

Also please remove duplicate post.

Highlighted

sorry,

c2900-universalk9-mz.SPA.151-4.M3.bin

Highlighted

Router doesn not detect loop current. That cannot be fixed from router side.

Even if you have loop current with regular phone, telco needs to fix it. You can tell them that you need higher current or voltage on the loop.

Please remove duplicate posts.

View solution in original post

Highlighted

Thank you for your reply Paolo.. Finally telco came and fixed it for us.

Highlighted

Thanks for the nice rating and good luck!