Showing results for 
Search instead for 
Did you mean: 

Gateway ---- Gatekeeper registration issue

Tommer Catlin

Anyone had an issue with a 3745 registering to a 3825 gatekeeper? I have other gateways working fine on the gatekeeper, but when I tried to add the next gateway, it does not what to register at all.

Network traffic is wide open. (can ping both ways)

Debug RAS showed it trying, but hard to tell what it was trying to say to the GK:

Nov 25 21:24:17: h323chan_chn_process_read_socket

Nov 25 21:24:17: h323chan_chn_process_read_socket: fd=2 of type ACCEPTED has data

Nov 25 21:24:17: h323chan_chn_process_read_socket: h323chan accepted/connected fd=2

The IOS that is working is on the gateway is:

Version 12.3(14)T7,

System Bootstrap, Version 12.3(11r)T2

The gateway that is not working is:

Version 12.3(11)T7,

System Bootstrap, Version 12.2(8r)T2,

Anyone seen something like this?




I had similar problem with 3745 gateway registering to a 3845 gatekeeper but the debug messages were not the same.

Have you tried doing a shut and no shut of the gateway?

config t#

config t#gateway


(gw)#no shut

Let me know what happens?



Thanks for the quick response!

I was a running a pilot last night so I had to roll it all back.

The current 3745 is connected to a PBX with a digital connection. Then it has dial-peers to other voice routers.

Do you know if I add the following commands:

interface Loopback0

ip address

h323-gateway voip interface

h323-gateway voip id XXX ipaddr 1718

h323-gateway voip h323-id

h323-gateway voip tech-prefix 1#

Will it affect my existing dialing peers and serial interface? I would like to register the gateway and test registration, but affect the existing dial-peers or voice operations of the router.

Thanks much!

It is really hard to say it impacts as I haven't seen any impact in my lab previously. But since your is a production network it is always suggested to take extra precaution.

As far as I remember until you change the "session target" to RAS in your dial-peers (to find the IP address of the session target) it shouldn't affect your existing dial-peers

what does the No Gateway command actually do, is this just for Registration to gatekeeper on the gateway?

Gateway command activate h323 process on the router and you can see it registers with GK. If you want to try, do

no gateway <---- on gateway

and debug h323 messages on GK

Gateway <------------ on gateway again

it should try to register with GK.

on a 3845, I can not do the commands above. I have ot tried with the 3745 yet

Ok, so on the 3745, it was odd, I added back in the H323 commands on the interface, did not register.

I went to config t

did a gateway

then exited

and sho gateway

and it registered.

Like a bug or something?

I had also looked through bug toolkit to find any known issues but couldnot find any. Anyway glad to hear it worked



Just to keep everyone updated, here is what I found.

The "No Gateway" and Gateway does actually work on 12.3 and 12.4.

Before you can register a gateway to a gatekeeper, you must build at least one dial peer. Dont ask me why, but I struggled with it and struggled... I had the correct commands in the interface for h323, but as soon as I built a dial peer, it registered.

I know, sounds goofy, but it worked. My thought process would be, first register, then build the dial peers. makes sense right? But with no dial peers, it would not even try to register. on 12.3 or 12.4.


Is it a dial-peer to the Gatekeeper? Have you tried also with an IP Route?

The simple way to put this is:

If you have a new gateway or an existing gateway you want to register to a gatekeeper, you must first ensure you have a dial peer configured on the gateway.

Dial-Peer voice 800 voip


Now, go into your interface and add in the H323 commands to register to the GK.

interface Loopback0

ip address xx.xx.xx.xx

h323-gateway voip interface

h323-gateway voip id GKa ipaddr 1718

h323-gateway voip h323-id

h323-gateway voip tech-prefix 1#

I have an existing gateway with dial peers pointed to other gateways. When I registered the gateway to my gatekeeper calling using the existing dial-peers broke.

I thought that the call would only be directed to the gatekeeper when a dialpeer was configured with the session target ras statement.

Is this not correct?

Any insight on this one?

If your Dial Peers are RAS dial-peers, then they would be directed to the GK. If they are something like target IP with an ip address, they will go there.

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community: