Showing results for 
Search instead for 
Did you mean: 


Getting below error while plugging in 7945G IP Phone

User has accidently removed the cable while the Cisco IP Phone 7945 is in "Upgrading" state and after that its not coming up.

after connecting it to other port the lights are Blinking but Phone display is Blank and not coming up..

below are the tftpd64 screenshot error and logs attached for your reference after connecting it back the ethernet cable.

Please advice as I want to make that Phone up..


Accepted Solutions

For CUCM, using CUCM is the best option for TFTP. The configuration files get created automatically for the phones. What are you ultimately trying to do?

View solution in original post


I'm a bit confused. Are you using a PC as your TFTP server for testing purposes but normally using CUCM as your TFTP server? If so, based on these errors I'd say your TFTP server is misconfigured in that it might not include the subnet range you are serving.

Thanks Buchanan for your reply I need to know how to configure tftpd64 and how to push firmware to this phone from the port where the port is working.

am installed tftpd on my PC and given and downloaded the firmware from cisco website

I need to know how to configure tftpd for pushing the firmware into the Cisco IP Phone7945G


1)tftp server need to configure? if yes what base directory I should use 

2)Is Tftp Client need to configure? with what Host name and port with what clock size..?

3)Do I need to configure DHCP server if I have already got IP Address from DHCP when I connected the ethernet cable..?

What Pool do I need to put in DHCP configuration in tftpd?

how to configure option 150 from DHCP settings in tftpd..?

For CUCM, using CUCM is the best option for TFTP. The configuration files get created automatically for the phones. What are you ultimately trying to do?

View solution in original post

Hi James,

I am really in trouble now as am having 5 more Phones having the same issue

it was in upgrading but even after keeping it active for 3 days phone was still showing upgrading and once cable is removed Phone got Blank

I know that the is phone is functional but due to firmware its totally dead need to know how to use tftfp to upload the firmware into IP Phone as I really dont know where to configure option 150 in tftfpd ..

What version of CallManager are you running?

I am running 10.5 Version of CUCM

You don't need to use anything except for CUCM to upload firmware to the phone. Now, for a phone that is in this state, you might need to do a factory reset, which can be done by following these steps:

  1. Unplug the power cable from the ip phone and then plug it back in.
  2. While the phone is powering up, and before the Speaker button flashes on and off, press and hold the hash # key.
  3. Continue to hold # until each line button (right of the LCD screen) flashes on and off in sequence in orange colour.
  4. Now release the hash # key and type the following sequence 123456789*0#

Hi James

I tried above steps but of no use Phone is still dead

I also checked we are having other 7945G IP Phones working on the firmware which I tried to push from tftfp to IP Phone and its there in the CUCM as well

Need your assistance as I tried 

m installed tftpd on my PC and given and downloaded the firmware 8.5.3  from cisco website for 7945 IP phone

I have taken a spare switch wherein I configured the default settings as per below

interface Vlan1

ip address

ip dhcp excluded-address


ip dhcp pool 40


   option 150 ip



and checked the IP assigned to the Laptop its getting IP Address as

Now I connected Faulty IP Phone to other port of the switch and tried to open the tftpd64 fro the PC am able to see some file transactions happening on tftpd but Phone reboots after 3 mins and nothing happens after that

need to understand what's the problem attaching logs for your reference.

Need to understand where is the problem is am directing to the correct way or is there any configuration issue in either tftpd/Switch.

Please asist me as am having five 7945G IP Phones which are having this issue and need to push firmware in those IP Phones.

What happens when you change option 150 ip to be the CallManager server IP address?

As am downloaded the firmware in local Laptop am giving IP of my Laptop as option 150 TFTP server in the root directory of tftpd however once I try to run tftpd some file transactions happen and LED of IP phones Blinks for a moment but after exactly 3 minutes port goes down automatically and comes up (i.e Phone restarts)

and again LED blinks for while and same things happens repeatedly

Need to know does Firmware really getting pushed to IP Phone or not.

Please assist as not able to figure out the problem ..

attaching logs for your reference.

Your laptop is not the right TFTP server to use. Why don't you try to use CallManager as your TFTP server?



I will recommend you to contact CISCO support team, As  the Light indication means you have a unread Voice mail ,

The problem with your phone is the old firmware need to be deleted and new firmware needs to be installed.

If path get cleared the phone will get Registered  and works fine.



Recognize Your Peers
Content for Community-Ad