cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
4225
Views
0
Helpful
3
Replies

Getting Cisco IP communicator

TeleCare
Level 1
Level 1

I need to know how to get Cisco IP communicator latest version? I tried to download it from Cisco website but it fails 

Does this software require license or purchase? 

1 Accepted Solution

Accepted Solutions

Hi,

Like i said above "You need and valid CCO to download Cisco IP communicator that's it." Licensing has nothing to do with download. If you are not sure about your CCO ID contact your accounts team and the would be able to help you with that.

Cisco IP Communicator is a basic soft phone and should be supported in all version, just in case you are running a very low version of CME see below link for detail.

https://www.cisco.com/c/en/us/support/unified-communications/unified-communications-manager-express/products-device-support-tables-list.html

(Rate and Mark it as correct it helps)

JB

View solution in original post

3 Replies 3

Jitender Bhandari
Cisco Employee
Cisco Employee
Hi,

You need and valid CCO to download Cisco IP communicator that's it. From licensing perspective if you are running CUCM version 9.x and above you need an Enhance license per Cisco IP communicator intense.

https://www.cisco.com/c/en/us/td/docs/voice_ip_comm/cucm/admin/10_0_1/ccmfeat/CUCM_BK_F3AC1C0F_00_cucm-features-services-guide-100/CUCM_BK_F3AC1C0F_00_cucm-features-services-guide-100_chapter_0100101.html

Enhanced UCL
Cisco Unified IP Phone 3911, 3941, 3951
Cisco Unified IP Phone 6941, 6945, and 6961 models
Cisco Unified IP Phone 7900 Series (7900G, 7911G, 7912G, 7931G, 794xG, 796xG, and 7975G models)
Cisco Unified IP Phone 8900 Series (8941, 8945, and 8961 models)
Cisco Unified IP Phone 9900 Series (9951 and 9971 models) with or without camera
Cisco Unified Wireless IP Phones Series (792xG and 7925G-EX models)
Cisco Unified IP Conference Stations (7936G and 7937G stations)
Cisco Unified Softphones (Cisco Unified Personal Communicator, Cisco UC Integration for Lync, Cisco UC Integration for Connect, and Cisco IP Communicator)
Jabber clients (Jabber for Mac, Jabber for Windows, Jabber for iPhone, Jabber for Android, Jabber for iPad, and Jabber SDK)
Cisco Virtual Experience Clients (VXC) with voice and video firmware
Cisco IP Video Phone E20
Cisco TelePresence System EX Series (EX60 and EX90)
Third-party SIP devices
Cisco Desktop Collaboration Experience DX600 Series

(Rate if it helps)

JB

Thank you for your feedback 

The information you shared about CUCM, 

In my case I have CUCME and I did purchase SW-CCME-UL-ENH= CUCME Phone License - Enhanced

Will I be able to download Ip communicator in this case? 

 

Hi,

Like i said above "You need and valid CCO to download Cisco IP communicator that's it." Licensing has nothing to do with download. If you are not sure about your CCO ID contact your accounts team and the would be able to help you with that.

Cisco IP Communicator is a basic soft phone and should be supported in all version, just in case you are running a very low version of CME see below link for detail.

https://www.cisco.com/c/en/us/support/unified-communications/unified-communications-manager-express/products-device-support-tables-list.html

(Rate and Mark it as correct it helps)

JB