cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
3957
Views
6
Helpful
28
Replies

h323 gateway redundant call manager

dan.letkeman
Level 4
Level 4

Hello,

I am trying to setup a redunant connection from a 2921 voice router to both my publisher and my subscriber call manager.  Everything is working when the publisher is running, but I recently did an upgrade and when the publisher (10.1.1.11) was down, the outside callers could not call in, they just got a busy signal.  All of our phones automatically registered with the subscriber so that part worked fine, but no outside calls made it through the router.

Dial-peer 503, and 504 should be failing over.

Here is the relevant config:

voice service voip

ip address trusted list

  ipv4 10.1.1.11

  ipv4 10.1.1.12

gcid

clid substitute name

allow-connections h323 to h323

allow-connections h323 to sip

allow-connections sip to h323

allow-connections sip to sip

no supplementary-service sip moved-temporarily

no supplementary-service sip refer

fax protocol t38 version 0 ls-redundancy 0 hs-redundancy 0 fallback none

h323

  h225 timeout setup 3

!

voice class h323 1

  h225 timeout tcp establish 3

!

!

!

!

application

global

  service alternate DEFAULT

!

!

redundancy

!

!

controller T1 0/0/0

cablelength long 0db

pri-group timeslots 1-24

!

!

!

!

!

interface Loopback0

ip address 10.1.100.100 255.255.255.255

h323-gateway voip interface

h323-gateway voip bind srcaddr 10.1.100.100

!

interface Embedded-Service-Engine0/0

no ip address

shutdown

!

interface GigabitEthernet0/0

ip address 10.1.1.10 255.255.255.0

duplex auto

speed auto

!

!

interface Serial0/0/0:23

no ip address

encapsulation hdlc

isdn switch-type primary-ni

isdn incoming-voice voice

no cdp enable

!

!

router eigrp 100

network 10.1.1.0 0.0.0.255

network 10.1.100.100 0.0.0.0

!

ip forward-protocol nd

!

ip http server

ip http authentication local

ip http secure-server

ip http timeout-policy idle 60 life 86400 requests 10000

!

!

!

voice-port 0/0/0:23

echo-cancel coverage 64

bearer-cap Speech

!

ccm-manager redundant-host 10.1.1.12

ccm-manager mgcp

no ccm-manager fax protocol cisco

ccm-manager music-on-hold

ccm-manager config server 10.1.1.11

ccm-manager config

!

mgcp call-agent 10.1.1.11 2427 service-type mgcp version 0.1

mgcp rtp unreachable timeout 1000 action notify

mgcp modem passthrough voip mode nse

mgcp package-capability rtp-package

mgcp package-capability sst-package

mgcp package-capability pre-package

no mgcp package-capability res-package

no mgcp timer receive-rtcp

mgcp sdp simple

mgcp fax t38 inhibit

!

mgcp profile default

!

!

dial-peer voice 100 pots

description 7 Digit Dialing

destination-pattern 9[2-9]......

port 0/0/0:23

forward-digits 7

no sip-register

!

dial-peer voice 200 pots

incoming called-number .

direct-inward-dial

port 0/0/0:23

!

!

dial-peer voice 101 pots

description Long Distance 11 Digit Dialing

destination-pattern 91[2-9]..[2-9]......

port 0/0/0:23

forward-digits 11

no sip-register

!

dial-peer voice 105 pots

description 3 Digit Service Codes

destination-pattern 9[2-8]11

port 0/0/0:23

forward-digits 3

no sip-register

!

dial-peer voice 5000 pots

description Calling Card

destination-pattern 9[0][2-9]..[2-9]......

port 0/0/0:23

forward-digits 11

no sip-register

!

!

dial-peer voice 102 pots

description Local 10 Digit Dialing

destination-pattern 9[2-9]..[2-9]......

port 0/0/0:23

forward-digits 10

no sip-register

!

!

dial-peer voice 901 voip

incoming called-number 8.T

dtmf-relay h245-alphanumeric

codec g711ulaw

no vad

!

dial-peer voice 106 pots

description Star 6 Codes

destination-pattern 9*6[1-9][2-9]..[2-9]......

clid restrict

port 0/0/0:23

forward-digits 10

no sip-register

!

dial-peer voice 503 voip

preference 1

destination-pattern 5553......

session target ipv4:10.1.1.11

voice-class h323 1

dtmf-relay h245-alphanumeric

ip qos dscp cs3 signaling

no vad

!

dial-peer voice 504 voip

preference 2

destination-pattern 5553......

session target ipv4:10.1.1.12

voice-class h323 1

dtmf-relay h245-alphanumeric

ip qos dscp cs3 signaling

no vad

!

!

gateway

timer receive-rtp 1200

!

!

!

!

gatekeeper

no shutdown

!

I must be missing something.

Dan.

1 Accepted Solution

Accepted Solutions

Hi,

From the debugs:

-First the call tries to connect to 10.1.1.11; TCP transactions show that the TCP cannot be established:

Dec 28 15:22:42.874: TCP: Random local port generated 41942, network 1

Dec 28 15:22:42.874: TCB2CEF6C08 bound to 10.1.100.100.41942

Dec 28 15:22:42.874: Reserved port 41942 in Transport Port Agent for TCP IP type 1

Dec 28 15:22:42.874: TCP: sending SYN, seq 3207241951, ack 0

Dec 28 15:22:42.874: TCP0: Connection to 10.1.1.11:1720, advertising MSS 1460

Dec 28 15:22:42.874: TCP0: state was CLOSED -> SYNSENT [41942 -> 10.1.1.11(1720)]

Dec 28 15:22:42.874: ISDN Se0/0/0:23 Q931: TX -> CALL_PROC pd = 8 callref = 0xFE0C

Channel ID i = 0xA98381

Exclusive, Channel 1

vr#

Dec 28 15:22:44.866: TCP389: ACK timeout timer expired

Dec 28 15:22:44.874: 10.1.100.100:41942 <---> 10.1.1.11:1720   congestion window changes

Dec 28 15:22:44.874: cwnd from 1460 to 1460, ssthresh from 65535 to 2920

Dec 28 15:22:44.874: TCP0: timeout #1 - timeout is 4000 ms, seq 3207241951

Dec 28 15:22:44.874: TCP: (41942) -> 10.1.1.11(1720)

Cause Value 38 = CC_CAUSE_NETWORK_OUT_OF_ORDER

-Then the call tries to connect to 10.1.1.12; There is H323 signaling but CUCM sends a release complete:

--snip--

Dec 28 15:22:45.878: H225.0 OUTGOING PDU ::=

value H323_UserInformation ::=

{

   h323-uu-pdu

{

     h323-message-body setup :

--snip--

--snip--

Dec 28 15:22:46.242: H225.0 INCOMING PDU ::=

value H323_UserInformation ::=

{

   h323-uu-pdu

   {

     h323-message-body callProceeding :

--snip--

--snip--

Dec 28 15:22:46.246: H225.0 INCOMING PDU ::=

value H323_UserInformation ::=

{

   h323-uu-pdu

   {

     h323-message-body releaseComplete :

--snip--

Cause Value 27 = CC_CAUSE_DESTINATION_OUT_OF_ORDER

-As summary, when matching dial-peer 501 TCP link cannot be established. And when matching dial-peer 502 the CUCM rejects the call

-It would be necessary to check the network or the services on the first CUCM and for the second, well to capture CUCM traces to see why CUCM is rejecting the call

--
Jorge Armijo

Please remember to rate helpful responses and identify helpful or correct answers.

-- Jorge Armijo Please remember to rate helpful responses and identify helpful or correct answers.

View solution in original post

28 Replies 28

Chris Deren
Hall of Fame
Hall of Fame

Does the device pool assigned to the H323 GW in CUCM has CUCM Group assigned that lists both CUCM servers?

Chris

Yes the communications manager group has both the publisher and subscriber in it.

Dan.

Did you collect "debug isdn q931" or "debug voice dialpeer" for that call?

How about outbound calls, did that work?

Chris

Did you verify that the GW is registered with the Subscriber? Do a show ccm-manager on the GW

HTH Regards, Yosh

He is using it as H323 not MGCP GW, so there is no registration. See the controller and serial configuration.

Chris

I don't belive I am using mgcp.  Just h323.

Primary         Down                     10.1.1.11

First Backup    Down                     10.1.1.12

Second Backup   None

Current active Call Manager:    None

Backhaul/Redundant link port:   2428

Failover Interval:              30 seconds

Keepalive Interval:             15 seconds

Last keepalive sent:            15:41:21 CST Nov 17 2012 (elapsed time: 5w4d)

Last MGCP traffic time:         15:41:21 CST Nov 17 2012 (elapsed time: 5w4d)

Last failover time:             None

Last switchback time:           None

Switchback mode:                Graceful

MGCP Fallback mode:             Not Selected

Last MGCP Fallback start time:  None

Last MGCP Fallback end time:    None

MGCP Download Tones:            Disabled

TFTP retry count to shut Ports: 2

Backhaul/Redundant link is down

Configuration Auto-Download Information

=======================================

No configurations downloaded

Current state: Downloading XML file

Configuration Download statistics:

        Download Attempted             : 1

          Download Successful          : 0

          Download Failed              : 0

          TFTP Download Failed         : 28740

        Configuration Attempted        : 0

          Configuration Successful     : 0

          Configuration Failed(Parsing): 0

          Configuration Failed(config) : 0

Last config download command:

FAX mode: disable

Configuration Error History:

Can you ping from 10.1.100.100 to 10.1.1.12 ?

Run an extended ping from the router.

Pierre.

Both the publisher and subscriber have this result with an extended ping:

!!!!!.!!!!!.!!!!!.!!!!!.!!!!!.!!!!!.!!!!!.!!!!!.

The publisher, subscriber and router are all connected to the same switch, with nothing much else on the switch.

Dan,

Are you sure the Publisher was really down (No IP connectivity) ?

You can maybe change the preference so that the Subscriber will be the first one.

Pierre.

Yes the publisher was in the middle of an upgrade.  I am sure of that because I was the one that was doing it.

I did try chaning the preference when it was down and it made no difference. 

It's not because the Pub is in the midle of an upgrade that its IP stack is still not working.

If this is the case, the router can still reach the Pub IP address and send the traffic to a black hole.

My suggestion is to change the preference now on your router so that the Subscriber is the first one.

Then run a few calls.

Sounds like IP routing issue, your GW is on different VLAN from the servers, so ensure you have proper routing between the vlans. The following does not look right:

network 10.1.100.100 0.0.0.0

HTH,

Chris

No its not a routing issue, and they are all on the same subnet.

interface GigabitEthernet0/0

ip address 10.1.1.10 255.255.255.0

duplex auto

speed auto

pub: 10.1.1.11

sub: 10.1.1.12

interface Loopback0

ip address 10.1.100.100 255.255.255.255

h323-gateway voip interface

h323-gateway voip bind srcaddr 10.1.100.100

I am using the loopback for h323 connectivity.

vr#ping

Protocol [ip]:

Target IP address: 10.1.1.12

Repeat count [5]: 100

Datagram size [100]:

Timeout in seconds [2]:

Extended commands [n]: y

Source address or interface: 10.1.100.100

Type of service [0]:

Set DF bit in IP header? [no]:

Validate reply data? [no]:

Data pattern [0xABCD]:

Loose, Strict, Record, Timestamp, Verbose[none]:

Sweep range of sizes [n]:

Type escape sequence to abort.

Sending 100, 100-byte ICMP Echos to 10.1.1.12, timeout is 2 seconds:

Packet sent with a source address of 10.1.100.100

!!!!!.!!!!!.!!!!!.!!!!!

Your H323 protocol is bound to the loopback interface which is different subnet:

interface Loopback0

ip address 10.1.100.100 255.255.255.255

h323-gateway voip interface

h323-gateway voip bind srcaddr 10.1.100.100

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community: