cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
649
Views
0
Helpful
4
Replies
Highlighted
Beginner

help on howe to configure CME phoneload files

Hi guys,

I'm keep having problems with callmanager express, i'm struggling with the skinny firmware.

I configured my 2801 router as a tftp server so that my phones can pick the skinny firmware from the router.

I've downloaded the files from the cisco site (skinny software)

The phones probably not getting the files i think?

My phones on my CME are still registrering.

I've checked several things:

Sh ephone reg=> nothing

Sh ip dhcp binding

10.10.202.51        0100.1818.7c18.44       Nov 23 2012 10:14 PM    Automatic

10.10.202.53        0100.1795.b0d7.ce       Nov 23 2012 10:13 PM    Automatic

This is good

sh telephony tftp binding:

tftp-server system:/its/spain/7960-tones.xml alias Spain/7960-tones.xml

tftp-server system:/its/united_states/7960-font.xml alias English_United_States/7960-font.xml

tftp-server system:/its/united_states/7960-font.xml alias English_United_States/7920-font.xml

tftp-server system:/its/united_states/7960-dictionary.xml alias English_United_States/7960-dictionary.xml

tftp-server system:/its/united_states/7960-kate.xml alias English_United_States/7960-kate.xml

tftp-server system:/its/united_states/7960-kate.xml alias English_United_States/7920-kate.xml

tftp-server system:/its/united_states/SCCP-dictionary.xml alias English_United_States/SCCP-dictionary.xml

tftp-server system:/its/SEPDEFAULT.cnf alias SEPDefault.cnf

tftp-server system:/its/vrf1/XMLDefault.cnf.xml alias XMLDefault.cnf.xml

tftp-server system:/its/vrf1/ATADefault.cnf.xml alias ATADefault.cnf.xml

check my router config i really don't no why the phones keeps saying registrering??

Is there something i am missing??

current configuration : 3184 bytes

!

version 12.4

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname BR2-RTR

!

boot-start-marker

boot-end-marker

!

logging message-counter syslog

!

no aaa new-model

memory-size iomem 20

no network-clock-participate wic 0

dot11 syslog

ip source-route

!

!

ip dhcp excluded-address 10.10.202.1 10.10.202.49

ip dhcp excluded-address 10.10.202.70 10.10.202.254

!

ip dhcp pool CME

   network 10.10.202.0 255.255.255.0

   option 150 ip 10.10.110.3

   default-router 10.10.202.1

!

!

ip cef

no ipv6 cef

!

multilink bundle-name authenticated

!

!

!

!

!

!

!

!

!

!

!

!        

!

!

!

!

!

!

!

!

!

voice-card 0

!

!

!

!

!

archive

log config

  hidekeys

!

!

!

!

!        

controller E1 0/0/0

!

!

!

!

!

interface Loopback0

ip address 10.10.110.3 255.255.255.255

!

interface FastEthernet0/0

ip address 10.10.210.16 255.255.255.0

duplex auto

speed auto

!

interface Service-Engine0/0

no ip address

shutdown

!

interface FastEthernet0/1

no ip address

shutdown

duplex auto

speed auto

!

interface FastEthernet0/1/0

switchport trunk native vlan 200

switchport mode trunk

switchport voice vlan 400

!

interface FastEthernet0/1/1

switchport trunk native vlan 200

switchport mode trunk

switchport voice vlan 400

!

interface FastEthernet0/1/2

switchport trunk native vlan 200

switchport mode trunk

switchport voice vlan 400

!

interface FastEthernet0/1/3

switchport trunk native vlan 200

switchport mode trunk

switchport voice vlan 400

!

interface Serial0/2/0

no ip address

shutdown

no fair-queue

!

interface Serial0/2/1

ip address 10.10.112.2 255.255.255.0

encapsulation ppp

ip ospf mtu-ignore

!

interface Vlan1

no ip address

!

interface Vlan200

ip address 10.10.102.1 255.255.255.0

!

interface Vlan400

ip address 10.10.202.1 255.255.255.0

!

ip forward-protocol nd

no ip http server

no ip http secure-server

!

!

!        

disable-eadi

!

!

!

!

!

!

tftp-server flash:SCCP41.9-3-1SR1-1S.loads

tftp-server flash:apps41.9-3-1ES8.sbn

tftp-server cmterm-7941_7961-sccp.9-3-1SR1-1.cop.sgn

tftp-server cnu41.9-3-1ES8.sbn

tftp-server flash:term61.default.loads

tftp-server flash:term41.default.loads

tftp-server flash:jar41sccp.9-3-1ES8.sbn

tftp-server flash:dsp41.9-3-1ES8.sbn

tftp-server flash:cvm41sccp.9-3-1ES8.sbn

!

control-plane

!

!

!

ccm-manager fax protocol cisco

!        

!

!

!

!

!

!

gatekeeper

shutdown

!

!

telephony-service

max-ephones 2

max-dn 2

ip source-address 10.10.110.3 port 2000

auto assign 1 to 2

network-locale ES

network-locale 1 ES

network-locale 2 ES

network-locale 3 ES

network-locale 4 ES

load 7960-7940 P00

max-conferences 4 gain -6

transfer-system full-consult

server-security-mode non-secure

create cnf-files version-stamp Jan 01 2002 00:00:00

!

!

ephone-dn  1  dual-line

number 3001

!

!

ephone-dn  2  dual-line

number 3002

!

!

line con 0

exec-timeout 0 0

password cisco

line aux 0

line 66

no activation-character

no exec

transport preferred none

transport input all

transport output lat pad telnet rlogin lapb-ta mop udptn v120 ssh

line vty 0 4

privilege level 15

password cisco

login

transport input all

line vty 5 15

password cisco

login

transport input all

!

scheduler allocate 20000 1000

end

Everyone's tags (4)
1 ACCEPTED SOLUTION

Accepted Solutions
Beginner

Re: help on howe to configure CME phoneload files

Hi Monasir,

I believe you would need to add ephone configuration here. Looking at the high level that's only part I see missing here.

!

ephone  11

mac-address xxxx.xxxx.xxxx

ephone-template 1

username "John"

type 7942

button  1:11

!

also configure ephone templates and ephone-dn templates as follows...

ephone-template  1
transfer max-length 11
softkeys hold  Resume Newcall
softkeys idle  Redial Newcall Cfwdall Pickup Dnd
softkeys seized  Redial Endcall Cfwdall Pickup
softkeys alerting  Callback Endcall
softkeys connected  Hold Trnsfer Confrn TrnsfVM Endcall
softkeys ringing  Dnd Answer
!

HTH.

Sky,

Pls rate helpful posts.

View solution in original post

4 REPLIES 4
Beginner

Re: help on howe to configure CME phoneload files

Hi Monasir,

I believe you would need to add ephone configuration here. Looking at the high level that's only part I see missing here.

!

ephone  11

mac-address xxxx.xxxx.xxxx

ephone-template 1

username "John"

type 7942

button  1:11

!

also configure ephone templates and ephone-dn templates as follows...

ephone-template  1
transfer max-length 11
softkeys hold  Resume Newcall
softkeys idle  Redial Newcall Cfwdall Pickup Dnd
softkeys seized  Redial Endcall Cfwdall Pickup
softkeys alerting  Callback Endcall
softkeys connected  Hold Trnsfer Confrn TrnsfVM Endcall
softkeys ringing  Dnd Answer
!

HTH.

Sky,

Pls rate helpful posts.

View solution in original post

Highlighted
Beginner

Re: help on howe to configure CME phoneload files

Ensure button assignment 1:11 means first line of your physical phone is binded with ephone-dn 11.

Here in your case it would

1:1

1:2

Highlighted
Engager

help on howe to configure CME phoneload files

Hi,

Please use the below link for reference.

http://www.cisco.com/image/gif/paws/99946/cme-sip-guide.pdf

Hope this helps.

Anand

Please rate helpful posts !!

Highlighted
Beginner

help on howe to configure CME phoneload files

Hi there everyone

It worked but i had to something else the phones where still keep registering.

So what i did is i've put both phones on the CME in factory reset and they where both rebooting in the good firmware/load files.

I've assigned them both a mac adress and everything went fine.

Also when i say sh telephony service tftp binding you can see both phones have the right XML files.

Any way i would like to thank you guys for your support and help!

Appreciate it...

CreatePlease to create content