cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1228
Views
10
Helpful
4
Replies

Hi, would you help me to upgrade my Router ISR IOS. to V15 for 69XX SRST

Hi, I need your Help

I have a VPN VoIP Roter with cisco IOS version 12.4(13r)T11, RELEASE SOFTWARE (fc1) (c3845-spservicesk9-mz.124-24.T4.bin).

This is the model of the router:

Cisco 3845 (revision 1.0) with 484351K/39936K bytes of memory.
Processor board ID FTX1406AJAN
2 Gigabit Ethernet interfaces
4 Channelized/Clear E1/PRI ports
10 Voice FXO interfaces
DRAM configuration is 64 bits wide with parity enabled.
479K bytes of NVRAM.
126976K bytes of ATA System CompactFlash (Read/Write)

It is a Dedicaded VoIP router, so it has configures SRST for the IP Phones in order to help when they are not conectet de our CM (7,1.3.30 000-1)

The proble here is that the phones 69XX are unable to go de SRST, and I've read  that I need V15 IOS  in order to support that.

I know how to install a IOS and make the router boot with that BIN file, the proble is that I am not sure yet if I after upgrade de IOS, The router will operate without problems, or if the router will need any further configurations.

O have a Valid Support CISCO account, and I downloaded this Image:

c3845-spservicesk9-mz.151-4.M.bin

It has similar name pattern just like the Actual IOS

c3845-spservicesk9-mz.124-24.T4.bin

I've talking with me parthners and they told me that V15 IOS has a Active Firewall by default (unlike V12 IOS), and beacuse of they never done a V.15 Upgrade, we are not sure if it will work well.

Could you give me some advices?

Is that the best V15 IOS Image for my voice router?

Do I need adicional configurations after the upgrade?

Will SRST work well after de Upgrade?

Is that true about the active V15 Firewall?

Will the active V15 Firewall be a huge problem?

Thanks for helping me, if u' need aditional information about configuration, ask me and I will post it.

Regards!

1 Accepted Solution

Accepted Solutions

barry
Rising star
Rising star

Hi

Your router will be fine; just reboot off the new image, assuming you have checked that you have enough DRAM installed.

The 3845 will not magically enable a firewall when you reload it so this is not something you need to worry about.


Any SRST configuration that you currently have on your 12.4 image should still work on version 15.

15.1(4)M SP Services is confirmed as supporting SRST Version 8.0.

Back up your current config file, and copy off the existing IOS. That way you will always be able to revert if there are any issues with the upgrade.

HTH. Barry

View solution in original post

4 Replies 4

barry
Rising star
Rising star

Hi

Your router will be fine; just reboot off the new image, assuming you have checked that you have enough DRAM installed.

The 3845 will not magically enable a firewall when you reload it so this is not something you need to worry about.


Any SRST configuration that you currently have on your 12.4 image should still work on version 15.

15.1(4)M SP Services is confirmed as supporting SRST Version 8.0.

Back up your current config file, and copy off the existing IOS. That way you will always be able to revert if there are any issues with the upgrade.

HTH. Barry

nitsinha
Enthusiast
Enthusiast

I believe by firewall you mean the inbuilt toll fraud enhancement in IOS 15.1(2)T onwards. The following is a link to the doc explaining the feature

https://supportforums.cisco.com/docs/DOC-12228

But with the 15.1.4 M version this should not be a problem.

Hope that helps

Regards

Nitesh

PS:Plase rate helpful posts

Leo Laohoo
Hall of Fame
Hall of Fame

Upgrade the bootsrap too.  This way you can boot from USB flash.

Thanks to all, Helpful answers!

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community: