cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
3197
Views
0
Helpful
11
Replies

HOW does DID number works for SIP Trunks???

adsuther1
Beginner
Beginner

Hi Folks,

I'm new to the Cisco CME; i've gotten the config up to the point where I can terminate calls to my CME via the DID number; and the IP phone rings and I can answer and get talk path.

My basic setup: i have two IP Phones setup on my CME: IP Phone1 ext1000; and IP Phone2 ext2000. I can call Phone1 from Phone2 and I can call Phone2 from Phone1; that works GREAT!!!

 

Here is what I don't understand: when calling my DID number that's assigned to my SIP Trunk for my CME, let say my DID number is 3132221234,

when I call that DID from my house phone, Phone1 always ring and I answer the call and get talkpath, GREAT.  But when I take a trace of the incoming call to my CME, I do not see the DID number listed???? This is the trace i take: DEBUG VOIP DIALPEER ALL. My house phone number is listed; not the DID number. Even the Phone1 ext 1000 is listed. So, what happen to the DID number in the trace?

Furthermore, from my house phone I dial my DID number (lets say 3132221234), and phone1 extension is 1000; so, by dialing my DID number makes Phone1(ext 1000) ring??? Where in the translation, by dialing DID number 3132221234 makes Phone1 ext 1000 rings?

I know when I created ephone1 and ephon2, a default dialpeer was created for ephone1 and ephone2;

Example: ephone ext 1000: dialpeer dest pattern 1000; and ephone2 ext 2000: dialpeer dest pattern 2000.

But I can not understand how dialing DID number(3132221234) to My CME makes Phone1 ext 1000 rings??

 

Thanks for any info....

 

Anthony

ADS
11 Replies 11

michael o'nan
Enthusiast
Enthusiast

try debug ccsip messages

Depending on your translation pattern and where it is applied determines your digit manipulation from 10 digit DID to extension.

Hi 

'Debug ccsip messages' will show what the SIP Service Provider actually sends to you.

The 'TO:' field in that should show the DDI. 

Chances are you then translate that to your phone extension.

It's also possible (though unusual) for your SP to do this for you before sending it.

'debug voip dialpeer' shows matches of numbers to dial-peers, both inbound and outbound - most of this will show the numbers after translation.

Aaron

Aaron Please remember to rate helpful posts to identify useful responses, and mark 'Answered' if appropriate!

thanks Aaron,

 

the debug ccisp message list the CALLING=MYHOUSEPHONE#; CALLED=2000(IPPHONE EXT)

The messages never mention the 10digit DID number; i see the outgoing dial-peer 20002 for ext 2000 being selected.

so, somewhere the SIP trunk provider is translating the DID number to my IPPHONE ext 2000 before get to my CME. just like to see it.

 

by the way, i did not setup any translations to do the conversion from 10digit DID to IPPHONE ext 2000.

 

any ideals????

 

thanks

ADS

Sounds like when it was setup the provider is asked how many digits you wanted to be presented with. Or they just strip to 4 digits by default unless asked for something different.

but the last 4 digits of my DID number is 3380 and my ext is 2000.

so, I'm curious how they make that conversion from DID # to my ext 2000.....

 

 

ADS

Sounds like you have a translation profile then. Will you post the config of your CME?

Here is my running config:

 

 

=~=~=~=~=~=~=~=~=~=~=~= PuTTY log 2014.12.30 11:51:55

 

=~=~=~=~=~=~=~=~=~=~=~=

show running

Building configuration...

Current configuration : 5999 bytes

!

! Last configuration change at 11:51:04 est Tue Dec 30 2014

!

version 15.0

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname LAP_3825_1PORT

!

boot-start-marker

boot-end-marker

!

enable secret 5 $1$X8TI$9GWQ1D3/.FKSn5P4t0JXV0

!

no aaa new-model

!

clock timezone est -5

clock summer-time est recurring

!

dot11 syslog

ip source-route

ip cef

!

!

ip dhcp excluded-address xx.xx.X.X x.x.X.X

ip dhcp excluded-address x.x.X.X x.x.X.X

ip dhcp excluded-address x.x.X.X x.x.X.X

ip dhcp excluded-address x.x.X.X x.x.X.X

!

ip dhcp pool DATA_NET

   network x.x.X.X x.x.x.x

   default-router x.x.X.X

   dns-server 8.8.8.8

   lease 0 8

!

ip dhcp pool VOICE_NET

   network x.x.X.X x.x.x.x

   default-router x.x.X.X

   option 150 ip x.x.X.X

   dns-server 8.8.8.8

 --More--         lease 0 8

!

!

no ipv6 cef

!

multilink bundle-name authenticated

!

voice-card 0

!

voice service voip

 allow-connections sip to sip

 no supplementary-service sip moved-temporarily

 no supplementary-service sip refer

 sip

  registrar server expires max 3600 min 3600

  localhost dns:sip.nextiva.com

!

voice class codec 1

 codec preference 1 g711ulaw

!

crypto pki trustpoint TP-self-signed-1795450327

 enrollment selfsigned

 subject-name cn=IOS-Self-Signed-Certificate-1795450327

 revocation-check none

 rsakeypair TP-self-signed-1795450327

!

crypto pki certificate chain TP-self-signed-1795450327

 certificate self-signed 01

  30820246 308201AF A0030201 02020101 300D0609 2A864886 F70D0101 04050030

  31312F30 2D060355 04031326 494F532D 53656C66 2D536967 6E65642D 43657274

  69666963 6174652D 31373935 34353033 3237301E 170D3134 31323330 31363131

  33365A17 0D323030 31303130 30303030 305A3031 312F302D 06035504 03132649

  4F532D53 656C662D 5369676E 65642D43 65727469 66696361 74652D31 37393534

  35303332 3730819F 300D0609 2A864886 F70D0101 01050003 818D0030 81890281

 --More--           8100E4EF 5E4F6C70 5BBE7294 E380E233 3AA138AD F7FE3F02 620C3647 3F07E2D9

  15BA8FF7 44B3D3DE 2545C73E 4E75459A B009D059 5DA7D046 00E15C0A 809E566B

  2503030F B132061E 91EF4700 C8B37EF8 77A28DBD 4902A31E 89267D34 C8991BAB

  21925BD9 3EB00675 DF575B4A 09798382 BC79727B 0C142BBF 2CD06CF8 12BC3A37

  0A890203 010001A3 6E306C30 0F060355 1D130101 FF040530 030101FF 30190603

  551D1104 12301082 0E4C4150 5F333832 355F3150 4F525430 1F060355 1D230418

  30168014 C841C642 4FD9B2AD 93AC67B5 7E6B8377 684A89DC 301D0603 551D0E04

  160414C8 41C6424F D9B2AD93 AC67B57E 6B837768 4A89DC30 0D06092A 864886F7

  0D010104 05000381 81003AAC 8DD008CD E0C77689 2F439EB2 72A96041 E0B6126B

  1D149065 656A2EA4 BFAE9DCF F435024F DDF954C8 67CFD3A8 C4F2B953 0E73D5FA

  732D1276 3426EA45 607BFD01 BFC49499 1F8B104F D7F6D3EB DCDC91AF 9C6D3DCE

  50664903 2BC8E214 29E506EC 07CC4C8F 4BD636A7 7EB2A82E 4CC2DB49 7AB72F4B

  294A793E 0292C96B C9C7

                quit

!

!

license udi pid CISCO3825 sn FTX1112A2NV

!

redundancy

interface GigabitEthernet0/0

 no ip address

 duplex auto

 speed auto

 media-type rj45

 !

!

interface GigabitEthernet0/0.1

 description OUTSIDE INTERFACE

 encapsulation dot1Q 1 native

 ip address dhcp

 ip nat outside

 ip virtual-reassembly

!

interface GigabitEthernet0/0.2

 description VOICE VLAN INTERFACE

 --More--         encapsulation dot1Q 2

 ip address x.x.X.X x.x.x.x

 ip nat inside

 ip virtual-reassembly

!

interface GigabitEthernet0/0.3

 description DATA VLAN INTERFACE

 encapsulation dot1Q 3

 ip address x.x.X.X x.x.x.x

 ip nat inside

 ip virtual-reassembly

!

interface GigabitEthernet0/1

 no ip address

 ip nat outside

 ip virtual-reassembly

 shutdown

 duplex auto

 speed auto

 media-type rj45

 !

!

ip forward-protocol nd

ip http server

ip http secure-server

!

!

ip nat inside source list 10 interface GigabitEthernet0/0.1 overload

!

access-list 10 permit x.x.X.X 0.0.0.255

!

tftp-server flash:phone/7940-7960/P00308000500.bin alias P00308000500.bin

tftp-server flash:phone/7940-7960/P00308000500.loads alias P00308000500.loads

tftp-server flash:phone/7940-7960/P00308000500.sb2 alias P00308000500.sb2

tftp-server flash:phone/7940-7960/P00308000500.sbn alias P00308000500.sbn

!

control-plane

 !

dial-peer voice 300 voip

 description *** outbound from sip trunk ***

 destination-pattern 1..........

 session protocol sipv2

 session target sip-server

 voice-class codec 1

 dtmf-relay rtp-nte

 no vad

!

dial-peer voice 101 voip

 description ** 10 diget dialing ***

 destination-pattern [2-9].........$

 session protocol sipv2

 session target sip-server

 voice-class codec 1

 dtmf-relay rtp-nte

 no vad

!

!

sip-ua

 authentication username 101146724 password 7 025F5C095E5F5D79151F

 no remote-party-id

 retry invite 2

 retry register 10

 retry options 3

 timers connect 100

 registrar dns:trunking.voipdnsservers.com expires 3600

 sip-server dns:trunking.voipdnsservers.com

 host-registrar

!

telephony-service

 max-ephones 2

 max-dn 2

 ip source-address x.x.X.X port 2000

 voicemail 2000

 max-conferences 12 gain -6

 web admin system name Admin password cisco

 dn-webedit

 time-webedit

 transfer-system full-consult

 create cnf-files version-stamp 7960 Dec 25 2014 15:13:03

!

ephone-dn  1  dual-line

 number 1000

 label "Anthony Sutherland"

 description Anthony's extension

 name Anthony Sutherland

 hold-alert 30 originator

!

!

ephone-dn  2  dual-line

 number 2000

 label "Vickie Sutherland"

 description Vickie's extension

 hold-alert 30 originator

!

!

ephone  1

 device-security-mode none

 description "Anthony Sutherland's 1000 phone"

 mac-address 001D.4596.17F6

 speed-dial 1 2000 label "Vickie"

 type 7960

 button  1:1

!

ephone  2

 device-security-mode none

 description "Vickie Sutherland's 2000 phone"

 mac-address 001F.CA36.11E9

 speed-dial 1 1000 label "Anthony"

 type 7960

 button  1:2

!

line con 0

line aux 0

line vty 0 4

 exec-timeout 0 0

 password ciscopress

 login

!

scheduler allocate 20000 1000

 --More--         ntp server 184.73.235.44

end

 

LAP_3825_1PO

ADS

Hi

It looks like your SP is doing the translation to me. You would need to speak to them if you wanted it to change, or you could translate the called number yourself to be whatever you want.

Some advice: type 7 passwords (i.e. those in the sip-ua section of your config) are easily crackable using public tools and websites. I would change the password on your SIP acccount, as it is now in the public domain.

Aaron

Aaron Please remember to rate helpful posts to identify useful responses, and mark 'Answered' if appropriate!

Hi

debug ccsip messages shows the messages as they are sent, so if you receive an INVITE with  CALLED=2000(IPPHONE EXT), then that's what you are being sent. If you see CALLED=2000(IPPHONE EXT) in a 'SENT' INVITE it may be the INVITE to a SIP handset, which would be after you have translated it.

If you are sure you see it in a RECEIVED INVITE, then unless there is another SIP device/system/proxy in between the Service Provider and your CME, it does appear that the SP is doing the translation for you.

Aaron

Aaron Please remember to rate helpful posts to identify useful responses, and mark 'Answered' if appropriate!

I see where you going..... but what tool can I use to show the INVITE messages?

ADS

Use 'debug ccsip messages' - but make sure you are reading them properly.

Or post it up here for a second opinion.

Also post your config if you want to be sure...

Aaron

Aaron Please remember to rate helpful posts to identify useful responses, and mark 'Answered' if appropriate!
Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Recognize Your Peers