Showing results for 
Search instead for 
Did you mean: 

Import phones and users to CUCM 9.1

Anton Tutunov


I have CUCM 9.1 and I need import some users and phone from bat.xlsm but have problem.

Then I tried on update users tab select and change value "Number of Access Control Group", " Number of Controlled Devices" and other I see message from Excel "Type mismatch", but how I think must add columns " Number of Access Control Group" and other. This first problem.


On Phones tab I tried change value "Maximum number of Phones Lines" for example "1" and get message "Please enter numeric values in the Text boxes". This second problem.


I tried using Office 2013, 2010, 2007, all security parameters in Excel was disabled.


My bat.xlt file attached.


Can you help me please?


4 Replies 4


Hello Anton,


Do you resolve this issue? I have the same problems.


Best regards,


What I see in the original poster's bat.xlt is that he has not yet added "Directory Number" as a field using "Create File Format". After that is done, then the field for "Maximum Number of Lines" works.


Uladzimir - Please post your bat.xlt/xlsm so we can take a look.

Hello Maren,

Thanks a lot for your reply.

I have problems with Users tab.

I received "Type mismatch" error when I'd tried to increase number of controlled devices.


type mismatch error.jpg

I believe this is an Excel/Windows version issue on your local PC. When I opened the bat.xlsm you posted on my PC using Windows 7 64-bit and Excel 2016, it works fine and I am able to modify that field.

I did some poking and found this on Microsoft's site:

Which is not to say that the above is your exact problem, but I bet it's related.

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community: