cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
620
Views
0
Helpful
6
Replies
Beginner

Incorrect destination - correct sip address

This is probably a very easy fix, but this is just my 2nd real day working with VoIP.

 

I have setup a new SIP trunk to a provider and that is finally connected and registered. I also have a cube router connected to CUCM without any issues.

 

Now, when I dial one of the numbers on the trunk, the SIP call setup information comes through correctly with the dialed phone number, but the destination is sending it to my SIP username.

 

If I setup a translation pattern on CUCM for the username (711148xxx) and direct it to my internal extension, it rings as it should, so I know I'm very close to having this solved.


Received:
INVITE sip:711148xxx@10.19.xx.xx:5060 SIP/2.0
Via: SIP/2.0/UDP 208.73.xx.xx:5060;branch=z9hG4bK1vgvev006osfs9fxxxx.1
Accept: application/sdp, application/isup, application/dtmf, application/dtmf-relay,  multipart/mixed
Call-Id: pcst15185792955663296xxxx@192.168.xx.xx
Contact: <sip:269488xxxx@208.73.xx.xx:5060;transport=udp>
Content-Disposition: session; handling=required
Content-Length: 238
Content-Type: application/sdp
CSeq: 1 INVITE
From: "xxx"  <sip:269488xxx@192.168.xxx.xxx:5060;otg=TG_CORE_GSX;pstn-params=80848180xxxx>;tag=gK0d632414
In-Reply-To: 2030913431_43940344@207.155.xxx.xx
Session-Expires: 1800;refresher=uas
Supported: timer
To: <sip:909989xxx@192.168.xx.xx>
Max-Forwards: 70

v=0
o=Sonus_UAC 18499 10801 IN IP4 208.73.xx.xx
s=SIP Media Capabilities
c=IN IP4 208.73.150.xx
t=0 0
m=audio 30644 RTP/AVP 0 101
a=rtpmap:0 PCMU/8000
a=rtpmap:101 telephone-event/8000
a=fmtp:101 0-15
a=sendrecv
a=maxptime:20

001089: Feb 13 22:34:55.590: //-1/DBDBE573805A/CCAPI/cc_api_display_ie_subfields:
   cc_api_call_setup_ind_common:
   cisco-username=269488xxxx
   ----- ccCallInfo IE subfields -----
   cisco-ani=269488xxxx
   cisco-anitype=0
   cisco-aniplan=0
   cisco-anipi=0
   cisco-anisi=0
   dest=711148xxx
   cisco-desttype=0
   cisco-destplan=0
   cisco-rdie=FFFFFFFF
   cisco-rdn=
   cisco-rdntype=0
   cisco-rdnplan=0
   cisco-rdnpi=-1
   cisco-rdnsi=-1
   cisco-redirectreason=-1   fwd_final_type =0
   final_redirectNumber =
   hunt_group_timeout =0

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
Beginner

Re: Incorrect destination - correct sip address

Found it and resolved the issue!

Copy Number from "To" Header in an Incoming Invite to the "REQ-URI" Parameter (with Inbound SIP Profiles)

voice class sip-profiles 1
request INVITE sip-header TO copy "sip:(.*)@" u01
request INVITE sip-header SIP-Req-URI modify ".*@(.*)" "INVITE sip:\u01@\1"

voice service voip 
sip 
sip-profiles inbound 
sip-profiles 1 inbound

 

6 REPLIES 6
VIP Rising star

Re: Incorrect destination - correct sip address

What is the desired behavior on your side? 711148xxx is your DID range. You can map that range to the internal extensions, as you correctly did, using translation patterns.

Georgios
Please rate if you find this helpful.
Beginner

Re: Incorrect destination - correct sip address

No, the 711 number is my username for authentication, not my DID. The correct phone number is the 909 number in the to:sip.
Cisco Employee

Re: Incorrect destination - correct sip address

The destination is "711148xxx" as seen in the Request URI -

INVITE sip:711148xxx@10.19.xx.xx:5060 SIP/2.0

"To" header is not used for routing in SIP.

Nipun Singh Raghav
"We cannot solve our problems with the same thinking we used when we created them"
Beginner

Re: Incorrect destination - correct sip address

Thank you for the education! I’ve learned a lot in two days. 

 

Can i rewrite the invite header using the information that comes in the SIP to: information?

 

I have two numbers on this trunk currently and the information in the SIP to: message is always the phone number dialed but the invite then sends the number over to CUCM as the account number. 

Highlighted
Beginner

Re: Incorrect destination - correct sip address

Found it and resolved the issue!

Copy Number from "To" Header in an Incoming Invite to the "REQ-URI" Parameter (with Inbound SIP Profiles)

voice class sip-profiles 1
request INVITE sip-header TO copy "sip:(.*)@" u01
request INVITE sip-header SIP-Req-URI modify ".*@(.*)" "INVITE sip:\u01@\1"

voice service voip 
sip 
sip-profiles inbound 
sip-profiles 1 inbound

 

Re: Incorrect destination - correct sip address

Hi

 

 

You can configure a sip profile as follows by replacing the invite message using the TO field

 

voice class sip-profiles 101
request INVITE sip-header To copy "sip:(909989.*)@" u01
request INVITE sip-header SIP-Req-URI modify ".*@(.*)" "INVITE sip:\u01@\1"
request CANCEL sip-header To copy "sip:(909989.*)@" u01
request CANCEL sip-header SIP-Req-URI modify ".*@(.*)" "CANCEL sip:\u01@\1"

 

On your incoming dialpeer add the above profile

 

voice-class sip profiles 101 inbound

 

HTH

 

 

Regards

 

Carlo

 

Please rate all helpful posts "The more you help the more you learn"
CreatePlease to create content
Content for Community-Ad
August's Community Spotlight Awards