cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

1658
Views
0
Helpful
13
Replies
danjor
Beginner

Installation UCM in innactiv partition - Upgrade 6.1 to 8.6

I have to upgrade from a UCM6.1.4 to 6.1.5 to move finaly to 8.6

The old server has not enought place on the HD (original cames from 4.3) so the solution is to install 6.1.4 on the new server, move the data from ols server to the new on under 6.1.4 and do the upgrade path trought 6.1.5 on the server between both version

I do have a inactiv partition on the new server with 42GB and an activ one with also 42GB

How can I install the 6.1.4 on this inactiv partition and work in it to do the upgrade from 6.1.4 to 6.1.5 etc...? I did not find any way to activate ond work under this incativ partition... Lots of information about the nomal working way but noyhing for thos I have to do....

Thanks for helping and best regards,

Daniel

13 REPLIES 13
phooghen
Cisco Employee

On your new server, you install 6.1.4, then restore the backup from the old server.

At that stage, you have a server with an active partition running 6.1.4 with all your data.

From there, you upgrade to 6.1.5.

6.1.5 will be automatically installed on the inactive partition.

At the end of the upgrade, after a switch over, you will have 6.1.5 on the active partition with all your data.

You will also have 6.1.4 on the inactive partition.

Next step is to upgrade your 6.1.5 to 8.6.

At the end of the upgrade, you will have 8.6 on the active partition with all your data and 6.1.5 on the inactive partition.

When the upgrade is finished you swap the old server by the new server.

Does that mean I have to over write the actual 8.6 (factory installed) on my new server?

Is there no way to install the 6.1 on the secondary and make the upgrade on an inactiv partition and the import on the 8.6 from secondary?

If this is the way, do I have on my delivered UCM CD also the upgrade SW from 6.1.5 to 8.6 or are in the delived CDs only full installation versions and do I have to download the 8.6 upgrade SW?

What you are describing is not possible.

The good steps are:

1)Install CUCM 6.1,4

2)Restore your backup

3)Upgrade to 6.1.5

4)Upgrade to 8.6

Now, according to the following URL, you can directly upgrade from 6.1.4 to 8.6:

http://www.cisco.com/en/US/docs/voice_ip_comm/cucm/compat/ccmcompmatr1.pdf

1)Install 6.1.4

2)Restore your backup

3)Direct Upgrade to 8.6

Jaime Valencia
Hall of Fame Cisco Employee

There's the active and the inactive partiton, what you're running is on the active, what you previously had (or it might be blank on fresh install) is on inactive.

EVERYTIME you want to upgrade, the system validates what you have in the active partition as the from version and does the install in the inactive.

There's no way to just keep upgrading the inactive over and over without switching partitions.

HTH

java

if this helps, please rate

www.cisco.com/go/pdihelpdesk

HTH

java

if this helps, please rate

In fact, I did try to do it with the CD from 6.1.4 I did generate from iso file I get from TAC. If I do an install/upgrade from CCM Administration it tells me that it is an older version and so no upgrade possible. When I do a boot on the generated DVD it asks me about the driver to use to run on CD and there, I don't know withc one to choice....

The server is a 7816I5 but the driver in the choice are generic ones not related to the instalation documentation....

Any idea?

I gues it comes from the SW age 6.1.4 where this server doesn't exist and therefore the driver are not on the DVD ?

The problem you have is that the 7816-I5 is only supported with CUCM 8.5 or 8.6.

It's not supported on CUCM 6.1.x !

http://www.cisco.com/en/US/prod/collateral/voicesw/ps6790/ps5748/ps378/prod_brochure0900aecd8062a4f9.html

Therefore you cannot apply the procedure I gave you.

There are not a lot of options left !

Do you have another server which supports both 6.1 and 8.6 ?

Another option is to use your new server running 8.6 and reconfigure completely CUCM with the help of BAT.

I have to go this way because the actual running server is on 6.1.4 and it has not enought disk space to do even the upgrade from 6.1.5 nor the upgrade to 8.6... That is the raison why I want to upgrade on the new server.

The actual running server is over 14 remote sites, 3 PSTN gateways, external Open LDAP on a fedora, voice mail on an Asterisk and let say nearly 400 phones Cisco and Tiptel DECT. I would not have to create the server from scratch as there is a lot to configure. So I need to import the data from ols one to the new server.

As the actual installation is more or less 6 years old, there are a lot of specific things and phones by departement or location have some time moved trought the enterprise... Too many exeptions to use BAT I think....

Can't you just install VMWare, install CUCM 6.1.4, perform a restore of the current CUCM, upgrade to CUCM 8.6 and than if you don't want VMWare perform a backup of CUCM 8.6 and format the server and install CUCM 8.6 as a hardened server?

HTH Regards, Yosh

Is it possible to install them on VW Workstation 7.0 to do the upgrades or does it need a full VM server version?

It makes an eror on Workstation even trying from DVD as from .iso file I get from Cisco.


After creation from VM server, durring running of the Unified Communication 6.1 system installer I get an error!

/usr/bin/anaconda: line19 : /mnt/source/Cisco/base_scripts/ilog2.sh: Input/Output error

install exited abnormaly

and the server sends the kill and disable swap + unmount the file systems and stop

Danjor,

I haven't personally tried using workstation but it's not Cisco supported. Below is a link for everything that you would need to know for VMWare with Cisco UCM.

http://docwiki.cisco.com/wiki/Unified_Communications_in_a_Virtualized_Environment

Regards,

Yosh

HTH Regards, Yosh

When you create the VM for CUCM 6.1 set the HDD size to a minimum of 72 GB and 2 GB of memory.

HTH Regards, Yosh

I still have problem on installing the ISO I get from TAC

I have the same error on Client as on Server ESXi and ESX

Did try to install them on ESX1.0 and also on ESXi Vsphare 4.1.0 Buid 258902

I do attache a screen copy from server resume and the screen from error I get (every time this error on line

19 in a script….)

      

Does some OV file exist for the server from Cisco to define the right model?

You're not using the correct Guest Operating System. You need to use Red Hat Enterprise Linux 4 (32-Bit). I have attached 2 screenshots of the VM hardware settings.

Yosh

HTH Regards, Yosh
Create
Recognize Your Peers
Content for Community-Ad