cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

1721
Views
20
Helpful
10
Replies
KBCISCO
Beginner

International Dialing - New Zealand

Hi, I am having some issues with a new CME that I have configured in New Zealand. I can make local calls but can not call out International. I have checked with the telco and the ISDN Pri is not restricted.

I'm assuming I have made a mess up with the translation rules but I'm not a voice guy and not sure where to begin with troubleshooting this.

I have pasted a chunk of the configuration below (real DDI has been changed). Any help would be much appreciated.

Thanks,

K

!

isdn switch-type primary-net5

!

!

trunk group FXO

hunt-scheme sequential both up

!

!

voice call disc-pi-off

!

!

!

voice class codec 10

codec preference 1 g729r8

codec preference 2 g711alaw

codec preference 3 g711ulaw

!

!

!

!

!

!

!

!

!

!

!

!

!

voice translation-rule 1

rule 1 // /00/ type national national

rule 2 // /000/ type international international

!

voice translation-rule 2

rule 1 /^0\.*/ /\1/

!

voice translation-rule 3

rule 1 /^\.*/ /09312\1/

!

voice translation-rule 4

rule 1 /^312/ //

!

!

voice translation-profile PSTN-Incoming

translate calling 1

translate called 4

!

voice translation-profile PSTN-Outgoing

translate calling 3

translate called 2

!

!

voice-card 0

dsp services dspfarm

!

!

controller E1 0/1/0

pri-group timeslots 1-10,16

!

!

interface FastEthernet0/0.52

description ** MGMT VLAN Interface **

encapsulation dot1Q 52

ip address 10.8.173.12 255.255.255.128

!

interface FastEthernet0/0.53

description ** Voice VLAN Interface **

encapsulation dot1Q 53

ip address 10.8.173.130 255.255.255.128

!

interface FastEthernet0/1

no ip address

shutdown

duplex auto

speed auto

!

interface Internal-Service-Module0/0

ip unnumbered FastEthernet0/0.52

service-module ip address 10.8.173.13 255.255.255.128

!Application: CUE Running on AIM2

service-module ip default-gateway 10.8.173.12

hold-queue 512 out

!

interface Serial0/1/0:15

no ip address

encapsulation hdlc

isdn switch-type primary-net5

isdn incoming-voice voice

no cdp enable

!

!

voice-port 0/0/0

!

voice-port 0/0/1

!

voice-port 0/1/0:15

translation-profile incoming PSTN-Incoming

!

voice-port 0/2/0

!

voice-port 0/2/1

!

voice-port 0/2/2

!

voice-port 0/2/3

!

!

!

sccp local FastEthernet0/0.53

sccp ccm 10.8.173.130 identifier 1 version 6.0

sccp

!

dspfarm profile 1 conference

codec g711ulaw

codec g711alaw

codec g729ar8

codec g729abr8

codec g729r8

codec g729br8

associate application SCCP

!

!

dial-peer voice 1 pots

incoming called-number .

direct-inward-dial

forward-digits all

!

dial-peer voice 10 pots

destination-pattern 0T

progress_ind setup enable 3

progress_ind alert enable 8

progress_ind connect enable 8

port 0/1/0:15

forward-digits all

!

dial-peer voice 3 pots

translation-profile outgoing PSTN-Outgoing

destination-pattern 0[2-9].......

progress_ind setup enable 3

progress_ind alert enable 8

progress_ind connect enable 8

port 0/1/0:15

forward-digits all

!

dial-peer voice 4 pots

translation-profile outgoing PSTN-Outgoing

destination-pattern 01[1-2]T

progress_ind setup enable 3

progress_ind alert enable 8

progress_ind connect enable 8

port 0/1/0:15

forward-digits all

!

dial-peer voice 5 pots

translation-profile outgoing PSTN-Outgoing

destination-pattern 013T

progress_ind setup enable 3

progress_ind alert enable 8

progress_ind connect enable 8

port 0/1/0:15

forward-digits all

!

dial-peer voice 6 pots

translation-profile outgoing PSTN-Outgoing

destination-pattern 00[1-9]........

progress_ind setup enable 3

progress_ind alert enable 8

progress_ind connect enable 8

port 0/1/0:15

forward-digits all

!

dial-peer voice 7 pots

translation-profile outgoing PSTN-Outgoing

destination-pattern 0016......

progress_ind setup enable 3

progress_ind alert enable 8

progress_ind connect enable 8

port 0/1/0:15

forward-digits all

!

dial-peer voice 8 pots

translation-profile outgoing PSTN-Outgoing

destination-pattern 0001[0-9]T

progress_ind setup enable 3

progress_ind alert enable 8

progress_ind connect enable 8

port 0/1/0:15

forward-digits all

!

dial-peer voice 9 pots

translation-profile outgoing PSTN-Outgoing

destination-pattern 0009T

progress_ind setup enable 3

progress_ind alert enable 8

progress_ind connect enable 8

port 0/1/0:15

forward-digits all

!

dial-peer voice 12 pots

translation-profile outgoing PSTN-Outgoing

destination-pattern 01900......

progress_ind setup enable 3

progress_ind alert enable 8

progress_ind connect enable 8

port 0/1/0:15

forward-digits all

!

dial-peer voice 11 pots

translation-profile outgoing PSTN-Outgoing

destination-pattern 00055......

progress_ind setup enable 3

progress_ind alert enable 8

progress_ind connect enable 8

port 0/1/0:15

forward-digits all

!

dial-peer voice 15 pots

translation-profile outgoing PSTN-Outgoing

destination-pattern 01800......

progress_ind setup enable 3

progress_ind alert enable 8

progress_ind connect enable 8

port 0/1/0:15

forward-digits all

!

dial-peer voice 16 pots

translation-profile outgoing PSTN-Outgoing

destination-pattern 0000

progress_ind setup enable 3

progress_ind alert enable 8

progress_ind connect enable 8

port 0/1/0:15

forward-digits all

!

dial-peer voice 2000 voip

description ** CUE VOICEMAIL **

destination-pattern 9388

session protocol sipv2

session target ipv4:10.8.173.13

dtmf-relay sip-notify

codec g711ulaw

no vad

!

!

sip-ua

mwi-server ipv4:10.8.173.13 expires 3600 port 5060 transport udp

!

!

telephony-service

sdspfarm units 2

max-ephones 30

max-dn 150

ip source-address 10.8.173.130 port 2000

auto assign 1 to 5

url services http://10.8.173.13/voiceview/common/login.do

time-zone 48

time-format 24

date-format dd-mm-yy

voicemail 9388

max-conferences 3 gain -6

moh music-on-hold.au

multicast moh 239.1.100.1 port 2000

dn-webedit

time-webedit

transfer-system full-consult

create cnf-files version-stamp Jan 01 2002 00:00:00

!

!

ephone-dn  16  dual-line

number 9316

description +64 9 312 9316

name Test phone 1

call-forward busy 9388

call-forward noan 9388 timeout 15

mwi sip

!

ephone  1

mac-address 5478.1AE0.4387

type 7942

button  1:16

10 REPLIES 10
Bruno Rangel
Advocate

Hi

When you make a International call what exactly are you dialing ? all digits included the access code zero.

You can find the error with

Debug isdn q931

debug voice ccapi inout

Cheers
Bruno Rangel

"Se você quiser alguém em quem confiar, confie em si mesmo. Quem acredita sempre alcança"
Renato Russo

Cheers
Bruno Rangel
Please remember to rate helpful responses using the star bellow and identify helpful or correct answers

Hi Bruno,

When calling Australia, the guys on site are dialing 0 for an outside line, followed by 00 - 61 - Area Code - TEL # (i.e

00061299511888)

I have pasted the output below from the debugs

Called Number=00061299511888(TON=Unknown, NPI=Unknown), Calling Translated=FALSE,

   Subscriber Type Str=RegularLine, FinalDestinationFlag=FALSE, Outgoing Dial-peer=10, Call Count On=FALSE,

   Source Trkgrp Route Label=, Target Trkgrp Route Label=, tg_label_flag=0, Application Call Id=)

*Nov 15 04:17:15.087: //-1/xxxxxxxxxxxx/CCAPI/cc_get_feature_vsa:

*Nov 15 04:17:15.087: :cc_get_feature_vsa malloc success

*Nov 15 04:17:15.087: //-1/xxxxxxxxxxxx/CCAPI/cc_get_feature_vsa:

*Nov 15 04:17:15.087:  cc_get_feature_vsa count is 2

*Nov 15 04:17:15.087: //-1/xxxxxxxxxxxx/CCAPI/cc_get_feature_vsa:

*Nov 15 04:17:15.087: :FEATURE_VSA attributes are: feature_name:0,feature_time:1742120072,feature_id:12

*Nov 15 04:17:15.087: //12/29C57FB68029/CCAPI/ccIFCallSetupRequestPrivate:

   SPI Call Setup Request Is Success; Interface Type=6, FlowMode=1

*Nov 15 04:17:15.091: //12/29C57FB68029/CCAPI/ccCallSetContext:

   Context=0x67D82854

*Nov 15 04:17:15.091: //11/29C57FB68029/CCAPI/ccSaveDialpeerTag:

   Outgoing Dial-peer=10

*Nov 15 04:17:15.099: ISDN Se0/1/0:15 Q931: Applying typeplan for sw-type 0x12 is 0x0 0x1, Calling num 9316

*Nov 15 04:17:15.099: ISDN Se0/1/0:15 Q931: Sending SETUP  callref = 0x0083 callID = 0x8004 switch = primary-net5 interface = User

*Nov 15 04:17:15.103: ISDN Se0/1/0:15 Q931: TX -> SETUP pd = 8  callref = 0x0083

        Bearer Capability i = 0x8090A3

                Standard = CCITT

                Transfer Capability = Speech

                Transfer Mode = Circuit

                Transfer Rate = 64 kbit/s

        Channel ID i = 0xA9838A

                Exclusive, Channel 10

        Progress Ind i = 0x8183 - Origination address is non-ISDN

        Calling Party Number i = 0x0180, '9316'

                Plan:ISDN, Type:Unknown

        Called Party Number i = 0x81, '00061299511888'

                Plan:ISDN, Type:Unknown

*Nov 15 04:17:15.203: ISDN Se0/1/0:15 Q931: RX <- SETUP_ACK pd = 8  callref = 0x8083

        Channel ID i = 0xA9838A

                Exclusive, Channel 10

*Nov 15 04:17:22.711: ISDN Se0/1/0:15 Q931: RX <- CALL_PROC pd = 8  callref = 0x8083

        Channel ID i = 0xA9838A

                Exclusive, Channel 10

        Progress Ind i = 0x8183 - Origination address is non-ISDN

*Nov 15 04:17:22.715: //12/29C57FB68029/CCAPI/cc_api_call_proceeding:

   Interface=0x6748F66C, Progress Indication=ORIGINATING SIDE IS NON ISDN(3

Call goes out with the orignal calling number and that may not be acceptable by telco.

Try use the translation rule like that to change your calling number:

voice translation-profile PSTN-Outgoing-ITNL

translate calling 3

Add that to dial-peer voice 10 pots

If still trouble, look at complete debug isdn q931, and nothing else.

Cheers
Bruno Rangel

Cheers
Bruno Rangel
Please remember to rate helpful responses using the star bellow and identify helpful or correct answers

I seem to be getting somewhere with this. I can dial internationally from the CLI line when I type the following command csim start 0061299512121

but I still can't dial internationally from a handset. Must be something with my translation rules?

Hi

Try change your dial-peer voice 10 with no forward-digits all

Please rate all post using the stars

Cheers
Bruno Rangel

"Se você quiser alguém em quem confiar, confie em si mesmo. Quem acredita sempre alcança"
Renato Russo

Cheers
Bruno Rangel
Please remember to rate helpful responses using the star bellow and identify helpful or correct answers

Hi, I tried that but still unable to dial international from the handset. Can only dial from the command line

When you dial it from the command line you dialed 0061299512121, but from the phone you dialed 00061299512121, ie with a zero in front for the outside prefix. In your original debug it showed that you didn't remove the outside prefix from the called number, you need to setup your outgoing voice translation rule to remove that extra zero or use dial peer digit drop to remove it.

On all other outgoing pots dial peers you have a outgoing voice translation, but not on the one used for international calls, DP 10. Why is that?

Add the translation to that dial peer with the below commands.

dial-peer voice 10 pots
translation-profile outgoing PSTN-Outgoing

That will both take care of called number, ie drop the leading zero and also set the calling number to the format that your Telco seem to want it in.

Please remember to rate all useful posts.

Sent from Cisco Technical Support iPhone App



Response Signature


Thanks for everyones help on this but after trying all suggestions,  i am still have a issues dialing international. I am going to ring the Telco after the weekend and see if they can see any issues at their end.

Below is my latest debug when calling an international number 0006199501234 (I have change dlast 6 digits of real number)

As you can see, the first 0 is dropped but the call still doesnt get through.

If I type 'csim start 006199501234' from the command line the call goes through

Bearer Capability i = 0x8090A3

                Standard = CCITT

                Transfer Capability = Speech

                Transfer Mode = Circuit

                Transfer Rate = 64 kbit/s

        Channel ID i = 0xA98389

                Exclusive, Channel 9

        Progress Ind i = 0x8183 - Origination address is non-ISDN

        Calling Party Number i = 0x1183, '0931200061400945432'

                Plan:ISDN, Type:International

        Called Party Number i = 0x81, '0061499501234'

                Plan:ISDN, Type:Unknown

*Nov 24 08:05:02.361: ISDN Se0/1/0:15 Q931: RX <- RELEASE_COMP pd = 8  callref = 0x8124

*Nov 24 08:05:02.561: ISDN Se0/1/0:15 Q931: RX <- CALL_PROC pd = 8  callref = 0x8125

        Channel ID i = 0xA98389

                Exclusive, Channel 9

        Progress Ind i = 0x8183 - Origination address is non-ISDN

*Nov 24 08:05:03.001: ISDN Se0/1/0:15 Q931: RX <- DISCONNECT pd = 8  callref = 0x8125

        Cause i = 0x87FF - Interworking error; unspecified

        Progress Ind i = 0x8183 - Origination address is non-ISDN

*Nov 24 08:05:03.005: ISDN Se0/1/0:15 Q931: TX -> RELEASE pd = 8  callref = 0x0125

*Nov 24 08:05:03.017: ISDN Se0/1/0:15 Q931: TX -> DISCONNECT pd = 8  callref = 0x91E1

        Cause i = 0x80FF - Interworking error; unspecified

*Nov 24 08:05:03.033: ISDN Se0/1/0:15 Q931: RX <- RELEASE_COMP pd = 8  callref = 0x8125

*Nov 24 08:05:03.105: ISDN Se0/1/0:15 Q931: RX <- RELEASE pd = 8  callref = 0x11E1

        Cause i = 0x80FF - Interworking error; unspecified

*Nov 24 08:05:03.105: ISDN Se0/1/0:15 Q931: TX -> RELEASE_COMP pd = 8  callref = 0x91E1

The first thing that pops to mind is that you have totally different calling numbers in your two posts.

Below part is from your latest post.
Calling Party Number i = 0x1183, '0931200061400945432'
Plan:ISDN, Type:International

And this is from your previous post.
Calling Party Number i = 0x0180, '9316'
Plan:ISDN, Type:Unknown

So you must have changed more than what was suggested by me and Bruno between the two posts. Please describe the changes made for us to be able to help.

Also you say that it works when you do a csim start, could you please post the output from these debugs when you do a csim.

debug isdn q931
debug voip dialpeer
debug voice translation

Post them as separate output.

The thing that still stands out to me is that you do the successful csim start call with a called number that is different than what you use on the phone. Why is that? Do you have a DDI in the CUCM that drops the prefix 0 (zero) before its sent to the VGW? If not, ie you send the complete called number from CUCM to the VGW and do all digits manipulation in it, you should use the same format for called number when you do the csim start. Otherwise the test won't reveal the reason for why you have problem with calling to a international number.

Please remember to rate all useful posts.

Sent from Cisco Technical Support iPhone App



Response Signature


International calls started working after speaking to the Telco. Cheers for all the advice guys

Create
Recognize Your Peers
Content for Community-Ad