cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
5890
Views
5
Helpful
13
Replies
Beginner

IP Communicator CME Host not found

Hi,

I have a cisco call manager express version 8.0 running on a cisco 2821 with IOS 15.1(1).  This is running perfectly with over 30 phones connected to it apart from one single problem.

We have some users who are using cisco ip communicator ver 7.0.5 running on windows 7.  Everything is fine except when they try to access either the local directory or the services.  So far this is what I have found:

-The hard phone users work fine.

-No ACLs or firewalls between CIPS clients and CME.

-tried to debug tftp events, but no abnormal messages appear (apart from the ldapdirectories.xml)

-tried debug ip http all.  I get 'Index not found: Invalid phone' when I press the directories button.

-the ephone is defined as type CIPC

-tried an older 2.1.2 version of IP communicator.

-tried to configure CME to listen on the IP of the data vlan (where the PCs with CIPC are residing).

Coould someone please suggest a possible solution for this issue.  I cannot use the services button to access the voiceview express on CUE and extension mobility and this is causing me problems.

Thanks,

Alex.

13 REPLIES 13
Rising star

Re: IP Communicator CME Host not found

I'm guessing here, but I've seen problems like this before.

Try adding lines to the host file to the workstations that are using IPC.  In the host file, add in the server names and IP addresses of CME and of the Voicemail system.

When I've seen this in the past, you'd actually see on wireshark where the machine will be arping for the name of the server (not fully qualified) and it won't find it because it's on a different subnet.  There are various ways to address this, but a host file is the fastest way to determine if that's the problem.

You can use wireshark to see what the machine is attempting to access.  That may help as well

Highlighted
Beginner

Re: IP Communicator CME Host not found

Thanks for your post. It really help !
Rising star

Re: IP Communicator CME Host not found

Also, have you confirmed that the versions of CME and IPC are compatible with each other?  It's silly, but this one can bit you sometimes too if they aren't.

Beginner

Re: IP Communicator CME Host not found

Hi,

I have checked with wireshark but there are no requests for the IP of a DNS name.  When I press the directories button, I can see the HTTP request for the CME router IP and when I press the Services button, I can see the request to the CUE IP so it doesnt seem to be a name resolution issue.

With regards to compatibility, unfortunately CME 8.0 is not listed in the IP Communicator list.  The most recent CME supported version is 7.1 but I think it is not worthed to downgrade both CME and IOS.

Any other ides where I could look at?


Thanks

As

Cisco Employee

Re: IP Communicator CME Host not found

The CME webserver may not be runing. So just issue ip http server command
and hit directory button and check if it works

Thnaks,

Ishan

P.S :rate if helpful

Beginner

Re: IP Communicator CME Host not found

Hi,

I checked both http and http secure server and they are already enabled.  Infact, all the hard phones work perfectly.

I am attaching some exerpts of the config that I have:

network-clock-participate wic 0
network-clock-select 3 E1 0/0/0

ip dhcp excluded-address 10.20.10.254
!
ip dhcp pool VOICE
   network 10.20.10.0 255.255.255.0
   option 150 ip 10.20.10.254
   default-router 10.20.10.254

!

interface GigabitEthernet0/0
no ip address
duplex auto
speed auto
!
interface GigabitEthernet0/0.1
encapsulation dot1Q 1 native
ip address 10.254.0.254 255.255.255.0
!
interface GigabitEthernet0/0.100
encapsulation dot1Q 100
ip address 10.20.10.254 255.255.255.0
!
interface GigabitEthernet0/0.200
encapsulation dot1Q 200
ip address 192.168.130.250 255.255.255.0
!
interface Service-Engine0/0
ip unnumbered GigabitEthernet0/0.100
service-module ip address 10.20.10.253 255.255.255.0
service-module ip default-gateway 10.20.10.254

!

ip forward-protocol nd
ip http server
ip http authentication local
ip http secure-server
ip http path flash:cme8

!

ip route 0.0.0.0 0.0.0.0 192.168.xxx.xxx

ip route 10.20.10.253 255.255.255.255 Service-Engine0/0

!

telephony-service
no auto-reg-ephone
authentication credential xxxxxx xxxxxxx
max-ephones 50
max-dn 55
ip source-address 10.20.10.254 port 2000
max-redirect 9
service dnis overlay
service dnis dir-lookup
system message Computer Solutions Ltd.
url services http://10.20.10.253/voiceview/common/login.do
url authentication http://10.20.10.254/CCMCIP/authenticate.asp
network-locale GB
load 7914 S00105000400.sbn
load 7905 CP7905080003SCCP070409A.sbin
load 7906 SCCP11.8-5-3S.loads
load 7911 SCCP11.8-5-3S.LOADS
load 7912 CP7912080004SCCP080108A.sbin
load 7921 CP7921G-1.3.3.LOADS
load 7936 cmterm_7936.3-3-16-0.bin
load 7941 SCCP41.8-5-3S.LOADS
load 7941GE SCCP41.8-5-3S.LOADS
load 7942 SCCP42.8-5-3S.LOADS
load 7961 SCCP41.8-5-3S.LOADS
load 7961GE SCCP41.8-5-3S.LOADS
load 7962 SCCP42.8-5-3S.LOADS
load 7970 SCCP70.8-5-3S.LOADS
load 7971 SCCP70.8-5-3S.LOADS
load 6921 SCCP69XX.8-5-3-0.LOADS
load 6941 SCCP69XX.8-5-3-0.LOADS
load 6961 SCCP69XX.8-5-3-0.LOADS
time-zone 23
time-format 24
date-format dd-mm-yy
dialplan-pattern 1 22767... extension-length 3
voicemail 600
max-conferences 8 gain -6
moh flash:/cme8/music-on-hold.au
web admin system name xxxxxx secret xxxxxx

dn-webedit
transfer-system full-consult
night-service code *1234
night-service day Sun 08:31 08:30
night-service day Mon 17:00 08:30
night-service day Tue 17:00 08:30
night-service day Wed 17:00 08:30
night-service day Thu 17:00 08:30
night-service day Fri 17:00 08:30
night-service day Sat 08:31 08:30
create cnf-files version-stamp 7960 Nov 18 2010 16:11:04

!

ephone-dn  20  octo-line
number 234 secondary xxxxxxxx label Mr xxxx xxxx name xxxxx xxxxxx
call-forward busy 676
call-forward noan 600 timeout 25
no huntstop
mwi sip

!

ephone  16
no multicast-moh
device-security-mode none
video
mac-address 001F.1610.75BF
username "xxxxxxxl" password xxxxxxxx

codec ilbc dspfarm-assist
mtp
type CIPC
button  1:20

Any ideas?

PS.  The urls in the ip communicqator are being taken correctly as specified in telephony-service.

Thanks

AS

Rising star

Re: IP Communicator CME Host not found

Can you post the full CME config please?

NOTICE OF CONFIDENTIALITY:

The information contained in this email transmission is confidential information which may contain information that is legally privileged and prohibited from disclosure under applicable law or by contractual agreement. The information is intended solely for the use of the individual or entity named above.

If you are not the intended recipient, you are hereby notified that any disclosure, copying, distribution or taking of any action in reliance on the contents of this email transmission is strictly prohibited.

If you have received this email transmission in error, please notify us immediately by telephone to arrange for the return of the original transmission to us.

Cisco Employee

Re: IP Communicator CME Host not found

Hi,

For complete configuration help on how to configure local directory on CME .Please refer to the following

http://www.cisco.com/en/US/docs/voice_ip_comm/cucme/admin/configuration/guide/cmedirs.html#wp1010670

Regards,

Ishan

Beginner

Re: IP Communicator CME Host not found

Sry posted it in the post above.

Rising star

Re: IP Communicator CME Host not found

It all looks correct. Since you say it's working on all the other devices except the CME phones, I would suggest you open a TAC case.

NOTICE OF CONFIDENTIALITY:

The information contained in this email transmission is confidential information which may contain information that is legally privileged and prohibited from disclosure under applicable law or by contractual agreement. The information is intended solely for the use of the individual or entity named above.

If you are not the intended recipient, you are hereby notified that any disclosure, copying, distribution or taking of any action in reliance on the contents of this email transmission is strictly prohibited.

If you have received this email transmission in error, please notify us immediately by telephone to arrange for the return of the original transmission to us.

Beginner

Re: IP Communicator CME Host not found

Yes this is infact the only thing remaining.

Thanks again for your help

AS

Enthusiast

Re: IP Communicator CME Host not found

Hello,

Please can you tell me did you manage to resolve the case with CIPC and 15.1(3)T?

I've just stucked with the same issue you've described. The CIPC reports "Host not found"

every time I hit "Services" or "Directory" buttons. However, the wireshark reports that the

http request is sent and the router itself reports that it receive this request.

BRs

Hall of Fame Master

Re: IP Communicator CME Host not found

I was looking at this and I found that one condition under which it happens, is when the phone is not registered to CME receiving the request. Sort of a security features, but it precludes a multi-CME system to use a single one for directory services.

CreatePlease to create content
Content for Community-Ad
August's Community Spotlight Awards