cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
Whebcast-Overview of Cisco's Branch Routing Portfolio
143
Views
10
Helpful
3
Replies
Highlighted
Beginner

ip phone 8945 not registered on cisco router 2951 with CME 12.0

Dear All,

 

I have a problem with my IP phones it can't be registered on CME.

my network is CISCO router 2951 connecting to switch 3750 and my IP phones 8945 connecting to the switch.

I attached config files for review.

 

Notes:-

-phones has a firmware sccp 9-3-4-17 and and take ip from DHCP and TFTP ip 

 

-do show ephone

ephone-1[0] Mac:64E9.50CA.17BA TCP socket:[-1] activeLine:0 whisperLine:0 UNREGISTERED
mediaActive:0 whisper_mediaActive:0 startMedia:0 offhook:0 ringing:0 reset:0 reset_sent:0 paging 0 debug:1 caps:0
IP:0.0.0.0* 0 Unknown 0 keepalive 0 max_line 0 available_line 0
button 1: cw:1 ccw:(0)
dn 1 number 1001 CH1 DOWN
Preferred Codec: g711ulaw
Lpcor Type: none

 

-TFTP debug messages

 

*Feb 11 10:14:10.180: TFTP: Looking for ITLSEP64E950CA17BA.tlv
*Feb 11 10:14:10.216: TFTP: Looking for ITLFile.tlv
*Feb 11 10:14:10.256: TFTP: Looking for SEP64E950CA17BA.cnf.xml.sgn
*Feb 11 10:14:46.384: TFTP: Looking for XMLDefault.cnf.xml.sgn

 

-show run command 

Current configuration : 5380 bytes
!
! Last configuration change at 04:56:54 UTC Mon Feb 11 2019
!
version 15.7
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname CME
!
boot-start-marker
boot-end-marker
!
!
enable secret 5 $1$46TS$xt1/3YV6YVatIku.qRHRj0
!
no aaa new-model
!
!
!
!
!
!
!
!
!
ip dhcp excluded-address 172.16.1.1 172.16.1.20
ip dhcp excluded-address 172.16.2.1 172.16.2.20
!
ip dhcp pool DATA_SCOPE
network 172.16.2.0 255.255.255.0
default-router 172.16.2.1
dns-server 4.2.2.2
!
ip dhcp pool VOICE_SCOPE
network 172.16.1.0 255.255.255.0
default-router 172.16.1.1
dns-server 4.2.2.2
option 150 ip 172.16.1.1
!
!
!
ip cef
no ipv6 cef
!
multilink bundle-name authenticated
!
!
!
!
!
!
crypto pki trustpoint TP-self-signed-1088521604
enrollment selfsigned
subject-name cn=IOS-Self-Signed-Certificate-1088521604
revocation-check none
rsakeypair TP-self-signed-1088521604
!
!
crypto pki certificate chain TP-self-signed-1088521604
certificate self-signed 01
3082022B 30820194 A0030201 02020101 300D0609 2A864886 F70D0101 05050030
31312F30 2D060355 04031326 494F532D 53656C66 2D536967 6E65642D 43657274
69666963 6174652D 31303838 35323136 3034301E 170D3138 30363234 31313131
32365A17 0D323030 31303130 30303030 305A3031 312F302D 06035504 03132649
4F532D53 656C662D 5369676E 65642D43 65727469 66696361 74652D31 30383835
32313630 3430819F 300D0609 2A864886 F70D0101 01050003 818D0030 81890281
8100B496 440C76E0 E60DDB8D 4335B1E5 A7189A41 38704BE7 F2BC2B38 0941C92E
0738A376 B63147C6 4E94B925 179E89A0 64D1F537 0D3172B5 B5C67AC2 68243EDF
07E4BC81 CB9112A0 6D6CEC24 09791E4F 60A72D19 A91A5A5E 2A90FD33 82B6A684
855BA67E D318BA76 557A3C9A 7C13C1C1 23B2AF13 3C72EE9B 0BE63684 3700F0FB
F7350203 010001A3 53305130 0F060355 1D130101 FF040530 030101FF 301F0603
551D2304 18301680 140EACC3 AC497834 06D13AD8 36FC5810 96BFD36D 16301D06
03551D0E 04160414 0EACC3AC 49783406 D13AD836 FC581096 BFD36D16 300D0609
2A864886 F70D0101 05050003 8181007A 3DD6F074 D799648A BB4815CC D788DAB8
343B8877 A40CADAE 183E2C0C 1CBEBDB2 8911DEC2 20997C68 E9147797 13988215
9B8072A2 3A54F7A1 F931024D 687C11AF 1D826903 5DE6CD80 280854D9 AEFEE20E
C8C83341 15D76C9E 7D2F09E2 F6D3F0DC D5CD8DEA 0C902DAB 8791E5B7 CBA0FC9D
E611B8E6 FBA8A41C DDF07E8F 654D82
quit
voice-card 0
!
!
!
!
!
!
!
!
vxml logging-tag
license udi pid CISCO2951/K9 sn FTX1810AKFM
license accept end user agreement
hw-module pvdm 0/0
!
hw-module sm 2
!
!
!
file privilege 0
!
redundancy
!
!
!
!
!
!
interface Embedded-Service-Engine0/0
no ip address
shutdown
!
interface GigabitEthernet0/0
description CISCO 2951 ROUTER
ip address 192.168.10.10 255.255.255.0
duplex auto
speed auto
!
interface GigabitEthernet0/1
no ip address
duplex auto
speed auto
!
interface GigabitEthernet0/1.10
description VOICE VLAN
encapsulation dot1Q 10
ip address 172.16.1.1 255.255.255.0
ip helper-address 172.16.2.5
!
interface GigabitEthernet0/1.50
description DATA VLAN
encapsulation dot1Q 50
ip address 172.16.2.1 255.255.255.0
ip nat inside
ip virtual-reassembly in
!
interface GigabitEthernet0/2
ip address dhcp
ip nat outside
ip virtual-reassembly in
duplex auto
speed auto
!
interface Integrated-Service-Engine2/0
no ip address
shutdown
!Application: CUE Running on NME
no keepalive
!
ip forward-protocol nd
!
ip http server
ip http authentication local
no ip http secure-server
ip http path flash:/CME-GUI-12.2
!
ip nat inside source list 104 interface GigabitEthernet0/2 overload
ip route 0.0.0.0 0.0.0.0 192.168.2.1
!
!
nls resp-timeout 1
cpd cr-id 1
!
tftp-server flash:SCCP8941_8945.9-3-4-17.bin1.sgn alias SCCP8941_8945.9-3-4-17.bin1.sgn
tftp-server flash:SCCP8941_8945.9-3-4-17.bin2.sgn alias SCCP8941_8945.9-3-4-17.bin2.sgn
tftp-server flash:SCCP8941_8945.9-3-4-17.bin3.sgn alias SCCP8941_8945.9-3-4-17.bin3.sgn
tftp-server flash:SCCP8941_8945.9-3-4-17.bin4.sgn alias SCCP8941_8945.9-3-4-17.bin4.sgn
tftp-server flash:SCCP8941_8945.9-3-4-17.bin5.sgn alias SCCP8941_8945.9-3-4-17.bin5.sgn
access-list 104 permit ip 172.16.2.0 0.0.0.255 any
!
control-plane
!
!
voice-port 0/3/0
!
voice-port 0/3/1
!
voice-port 0/3/2
!
voice-port 0/3/3
!
!
!
!
!
mgcp behavior rsip-range tgcp-only
mgcp behavior comedia-role none
mgcp behavior comedia-check-media-src disable
mgcp behavior comedia-sdp-force disable
!
mgcp profile default
!
!
!
!
!
!
!
gatekeeper
shutdown
!
!
telephony-service
no auto-reg-ephone
max-ephones 24
max-dn 24
ip source-address 172.16.1.1 port 2000
cnf-file location flash:
load 8945 SCCP8941_8945.9-3-4-17.loads
max-conferences 8 gain -6
web admin system name abdo password cisco
dn-webedit
time-webedit
transfer-system full-consult
create cnf-files version-stamp Jan 01 2002 00:00:00
!
!
ephone-dn 1
number 1001
!
!
ephone 1
mac-address 64E9.50CA.17BA
type 8945
button 1:1
!
!
!
vstack
!
line con 0
line aux 0
line 2
no activation-character
no exec
transport preferred none
transport output pad telnet rlogin lapb-ta mop udptn v120 ssh
stopbits 1
line 131
no activation-character
no exec
transport preferred none
transport input all
transport output pad telnet rlogin lapb-ta mop udptn v120 ssh
line vty 0 4
password 7 1119180E1E595C5452
login local
transport input all
!
scheduler allocate 20000 1000
!
end

 

I waiting for Any help.

Thanks.

 

 

Everyone's tags (1)
2 ACCEPTED SOLUTIONS

Accepted Solutions
Rising star

Re: ip phone 8945 not registered on cisco router 2951 with CME 12.0

1) Phone is requesting for .sgn configuration file. Please delete the itl files and reset phone it should register.

Follow below link to reset security settings.
https://www.variphy.com/kb/delete-itl-file-reset-security-settings-on-cisco-8800-ip-phone-models

**PLEASE DON'T FORGET TO ACCEPT SOLUTION AND RATE IF APPLICABLE

Thanks
Haris
VIP Advisor

Re: ip phone 8945 not registered on cisco router 2951 with CME 12.0

Hi,

Your phone is requesting signed config file. Go to your phone settings and
delete ITL file by resetting the security setting. Then the phone will
request unsigned config.
3 REPLIES 3
Rising star

Re: ip phone 8945 not registered on cisco router 2951 with CME 12.0

1) Phone is requesting for .sgn configuration file. Please delete the itl files and reset phone it should register.

Follow below link to reset security settings.
https://www.variphy.com/kb/delete-itl-file-reset-security-settings-on-cisco-8800-ip-phone-models

**PLEASE DON'T FORGET TO ACCEPT SOLUTION AND RATE IF APPLICABLE

Thanks
Haris
VIP Advisor

Re: ip phone 8945 not registered on cisco router 2951 with CME 12.0

Hi,

Your phone is requesting signed config file. Go to your phone settings and
delete ITL file by resetting the security setting. Then the phone will
request unsigned config.
Beginner

Re: ip phone 8945 not registered on cisco router 2951 with CME 12.0

Thanks a lot it's working.

CreatePlease to create content

Spotlight awards-March 2019