cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

2317
Views
20
Helpful
12
Replies
Beginner

IP Phones not registering in CME

Hello,

 

I have ISR 4321 with CME installed and 3 IP Phones (7811, 8841 and 8865).

 

The phone get an IP from DCHP serve but aren't registering.

 

This is the output from debugging TFTP events and packets:

May 24 13:06:49.952: TFTP: Server request for port 1130, socket_id 0x7F4284DE77C0 for process 464
May 24 13:06:57.938: TFTP: Server request for port 1131, socket_id 0x7F4284BEF050 for process 601
May 24 13:07:01.930: TFTP: Server request for port 1131, socket_id 0x7F4284CB5610 for process 608
May 24 13:07:06.931: TFTP: Server request for port 1131, socket_id 0x7F427B743EF0 for process 453
May 24 13:07:12.931: TFTP: Server request for port 1131, socket_id 0x7F4285012BE0 for process 609
May 24 13:07:19.930: TFTP: Server request for port 1131, socket_id 0x7F4284FF8DA0 for process 610
May 24 13:07:27.932: TFTP: Server request for port 1131, socket_id 0x7F4285005BE0 for process 611
May 24 13:07:35.938: TFTP: Server request for port 1132, socket_id 0x7F4284F9DDA0 for process 612
May 24 13:07:39.932: TFTP: Server request for port 1132, socket_id 0x7F4284FB7BE0 for process 613
May 24 13:07:44.932: TFTP: Server request for port 1132, socket_id 0x7F4284FC4DA0 for process 614
May 24 13:07:50.931: TFTP: Server request for port 1132, socket_id 0x7F42736363E8 for process 464
May 24 13:08:05.935: TFTP: Server request for port 1132, socket_id 0x7F4284BEF050 for process 601
May 24 13:09:14.542: TFTP: Server request for port 50180, socket_id 0x7F4284BEF050 for process 453
May 24 13:09:14.542: TFTP: read request from host 10.0.111.4(50180) via GigabitEthernet0/0/1
May 24 13:09:14.542: TFTP: Looking for CTLSEP003C10E9D0F3.tlv
May 24 13:09:14.542: TFTP: Sending error 1 No such file
May 24 13:09:15.433: TFTP: Server request for port 52047, socket_id 0x7F4284BEF050 for process 453
May 24 13:09:15.433: TFTP: read request from host 10.0.111.4(52047) via GigabitEthernet0/0/1
May 24 13:09:15.433: TFTP: Looking for ITLSEP003C10E9D0F3.tlv
May 24 13:09:15.433: TFTP: Sending error 1 No such file
May 24 13:09:16.308: TFTP: Server request for port 53146, socket_id 0x7F426517E908 for process 453
May 24 13:09:16.309: TFTP: read request from host 10.0.111.4(53146) via GigabitEthernet0/0/1
May 24 13:09:16.309: TFTP: Looking for ITLFile.tlv
May 24 13:09:16.309: TFTP: Sending error 1 No such file
May 24 13:09:17.237: TFTP: Server request for port 49860, socket_id 0x7F426517E908 for process 453
May 24 13:09:17.237: TFTP: read request from host 10.0.111.4(49860) via GigabitEthernet0/0/1
May 24 13:09:17.237: TFTP: Looking for SEP003C10E9D0F3.cnf.xml
May 24 13:09:17.238: TFTP: Sending error 1 No such file
May 24 13:09:18.216: TFTP: Server request for port 50540, socket_id 0x7F426517E908 for process 453
May 24 13:09:18.216: TFTP: read request from host 10.0.111.4(50540) via GigabitEthernet0/0/1
May 24 13:09:18.216: TFTP: Looking for XMLDefault.cnf.xml
May 24 13:09:18.218: TFTP: Opened flash:/its/vrf1/XMLDefault.cnf.xml, fd 10, size 3572 for process 453
May 24 13:09:18.218: TFTP: Sending block 1 (retry 0), len 512, socket_id 0x7F426517E908
May 24 13:09:18.220: TFTP: Received ACK for block 1, socket_id 0x7F426517E908
May 24 13:09:18.220: TFTP: Sending block 2 (retry 0), len 512, socket_id 0x7F426517E908
May 24 13:09:18.221: TFTP: Received ACK for block 2, socket_id 0x7F426517E908
May 24 13:09:18.221: TFTP: Sending block 3 (retry 0), len 512, socket_id 0x7F426517E908
May 24 13:09:18.222: TFTP: Received ACK for block 3, socket_id 0x7F426517E908
May 24 13:09:18.222: TFTP: Sending block 4 (retry 0), len 512, socket_id 0x7F426517E908
May 24 13:09:18.223: TFTP: Received ACK for block 4, socket_id 0x7F426517E908
May 24 13:09:18.224: TFTP: Sending block 5 (retry 0), len 512, socket_id 0x7F426517E908
May 24 13:09:18.224: TFTP: Received ACK for block 5, socket_id 0x7F426517E908
May 24 13:09:18.225: TFTP: Sending block 6 (retry 0), len 512, socket_id 0x7F426517E908
May 24 13:09:18.226: TFTP: Received ACK for block 6, socket_id 0x7F426517E908
May 24 13:09:18.226: TFTP: Sending block 7 (retry 0), len 500, socket_id 0x7F426517E908
May 24 13:09:18.227: TFTP: Received ACK for block 7, socket_id 0x7F426517E908
May 24 13:09:18.227: TFTP: Finished flash:/its/vrf1/XMLDefault.cnf.xml, time 00:00:00 for process 453

and this is the #sh run output:

Building configuration...


Current configuration : 5228 bytes
!
! Last configuration change at 15:05:59 UTC Thu May 24 2018
! NVRAM config last updated at 13:51:23 UTC Thu May 24 2018
!
version 16.7
service timestamps debug datetime msec
service timestamps log datetime msec
platform qfp utilization monitor load 80
no platform punt-keepalive disable-kernel-core
!
hostname VoIP
!
boot-start-marker
boot-end-marker
!
!
vrf definition Mgmt-intf
 !
 address-family ipv4
 exit-address-family
 !
 address-family ipv6
 exit-address-family
!
enable secret 5 $1$/62z$3sHCBxzAaU2gzMy3tfb/e/
!
no aaa new-model
clock timezone UTC 2 0
!
ip dhcp excluded-address 10.0.111.200 10.0.111.254
!
ip dhcp pool VOIP_SCOPE
 network 10.0.111.0 255.255.255.0
 default-router 10.0.111.254 
 dns-server 4.2.2.2 
 option 150 ip 10.0.111.254 
!
!
!
!
!
!
!
!
!         
!
subscriber templating
!
!
multilink bundle-name authenticated
!
!
!
!
!
!
!
!         
voice service voip
 allow-connections h323 to h323
 allow-connections h323 to sip
 allow-connections sip to sip
 fax protocol t38 version 0 ls-redundancy 0 hs-redundancy 0 fallback none
 sip
  registrar server expires max 600 min 60
!
!
!
!
!
voice register global
 mode cme
 load 7811 sip78xx.12-1-1-12
 timezone 25
 file text
 create profile sync 0006305904945347
 auto-register
 !
!
!
!         
!
!
!
voice-card 0/1
 no watchdog
!
voice-card 0/4
 no watchdog
!
license udi pid ISR4321/K9 sn FDO22160KK6
no license smart enable
diagnostic bootup level minimal
!
spanning-tree extend system-id
!
!
!
username admin privilege 15 password 0 Cisco@123
!
redundancy
 mode none
!         
!
!
!
!
!
!
!
interface GigabitEthernet0/0/0
 no ip address
 no negotiation auto
!
interface GigabitEthernet0/0/1
 ip address 10.0.111.254 255.255.255.0
 negotiation auto
!
interface Service-Engine0/1/0
!
interface Service-Engine0/4/0
!
interface GigabitEthernet0
 vrf forwarding Mgmt-intf
 ip address 10.0.100.251 255.255.255.0
 negotiation auto
!
ip forward-protocol nd
ip http server
ip http authentication local
ip http secure-server
ip http path flash:CME-GUI-12.1
ip tftp source-interface GigabitEthernet0/0/1
ip tftp blocksize 8192
ip route 0.0.0.0 0.0.0.0 GigabitEthernet0/0/1
!
!
!
!
tftp-server flash:8841/Cisco_Creek_Patch.ptc alias Cisco_Creek_Patch.ptc
tftp-server flash:8841/ciscoheadsetfirmware.xml alias ciscoheadsetfirmware.xml
tftp-server flash:8841/kern288xx.12-1-1-12.sbn alias kern288xx.12-1-1-12.sbn
tftp-server flash:8841/m0patch288xx.BE-01-001.sbn alias m0patch288xx.BE-01-001.sbn
tftp-server flash:8841/rootfs88xx.12-1-1-12.sbn alias rootfs88xx.12-1-1-12.sbn
tftp-server flash:8841/ssb288xx.BE-01-007.sbn alias ssb288xx.BE-01-007.sbn
tftp-server flash:8841/vc488xx.12-1-1-12.sbn alias vc488xx.12-1-1-12.sbn
tftp-server flash:8841/sip88xx.12-1-1-12.loads alias sip88xx.12-1-1-12.loads
tftp-server flash:8841/sb2288xx.BE-01-013.sbn alias sb2288xx.BE-01-013.sbn
tftp-server flash:8841/rootfs288xx.12-1-1-12.sbn alias rootfs288xx.12-1-1-12.sbn
tftp-server flash:8841/fbi88xx.BE-01-010.sbn alias fbi88xx.BE-01-010.sbn
tftp-server flash:8841/boot1288xx.BE-01-007.sbn alias boot1288xx.BE-01-007.sbn
tftp-server flash:8865/fbi8845_65.BEV-01-006.sbn alias fbi8845_65.BEV-01-006.sbn
tftp-server flash:8865/kern8845_65.12-1-1-12.sbn alias kern8845_65.12-1-1-12.sbn
tftp-server flash:8865/rootfs8845_65.12-1-1-12.sbn alias rootfs8845_65.12-1-1-12.sbn
tftp-server flash:8865/sb28845_65.BEV-01-015.sbn alias sb28845_65.BEV-01-015.sbn
tftp-server flash:8865/sip8845_65.12-1-1-12.loads alias sip8845_65.12-1-1-12.loads
tftp-server flash:8865/vc48845_65.12-1-1-12.sbn alias vc48845_65.12-1-1-12.sbn
tftp-server flash:sip78xx.12-1-1-12.loads
tftp-server flash:sboot78xx.12-1-1-12.sbn
tftp-server flash:sboot2.78xx.12-1-1-12.sbn
tftp-server flash:rootfs2.78xx.12-1-1-12.sbn
tftp-server flash:rootfs78xx.12-1-1-12.sbn
tftp-server flash:kern2.78xx.12-1-1-12.sbn
tftp-server flash:kern78xx.12-1-1-12.sbn
!
!
control-plane
!
!         
voice-port 0/1/0
!
voice-port 0/1/1
!
mgcp behavior rsip-range tgcp-only
mgcp behavior comedia-role none
mgcp behavior comedia-check-media-src disable
mgcp behavior comedia-sdp-force disable
!
mgcp profile default
!
!
!
!
telephony-service
 protocol mode ipv4
 max-ephones 40
 max-dn 20
 ip source-address 10.0.111.254 port 2000
 cnf-file location flash:
 cnf-file perphone
 time-format 24
 date-format dd-mm-yy
 max-conferences 8 gain -6
 web admin system name Admin secret 5 $1$i78H$8I4kKTLBQgrYCqkx2gVf2/
 web admin customer name customer secret 5 $1$ktYb$7gAnejVZrA/de.NAtzDIp/
 transfer-system full-consult
 create cnf-files version-stamp 7960 May 24 2018 14:51:36
!
!
!
sip-ua 
!
!
ephone-dn  1  dual-line
 number 1000
!
!
line con 0
 transport input none
 stopbits 1
line aux 0
 stopbits 1
line vty 0 4
 password Cisco@123
 logging synchronous
 login
line vty 5 15
 logging synchronous
 login
!
ntp logging
ntp master
ntp server 10.0.100.254 prefer source GigabitEthernet0
wsma agent exec
!
wsma agent config
!
wsma agent filesys
!
wsma agent notify
!
!
end
Everyone's tags (4)
2 ACCEPTED SOLUTIONS

Accepted Solutions
VIP Collaborator

Re: IP Phones not registering in CME

Hi there


Can you share show voice register tftp-bind

 

Also try add the source address under voice register global

 

voice register global

source-address 10.0.111.254 port 5060

create profile

 

 

 

Hope this helps!

Cheers
Rath!


***Please rate helpful posts***

 

 

 

Participant

Re: IP Phones not registering in CME

Ok @ArwaSh

 

For your 7811 registration issue the problem is that your ip phone try to load sgn file ( signed file ). You can see that with your log.....the SEP file has got sgn extension...

It s due to an old secure configurarion register on the ip phone (hardware).

The best way is to do a factory reset of that phone in order to delete this old hardware secure configuration.

 

1. You need to load 7811's sip firmware files on your cme and configure the tftp-server. 

 

2. Do a factory reset and check that your ip phone load its firmware files.

 

3. Check the log if your ip phone try to donwload by tftp the SEP xml.cnf ( not sgn anymore ) configuration file.

 

 

 

Best regards
******* If This Helps, Please Rate *******
Ben
12 REPLIES 12
Enthusiast

Re: IP Phones not registering in CME

You don't have any phones configured.  You'll need to configure pools/ephones to allow SIP and SCCP phones to register and CUCME to generate the configuration files.

 

This link should help:

 

https://www.cisco.com/c/en/us/td/docs/voice_ip_comm/cucme/admin/configuration/manual/cmeadm/cmebasic.html

Cisco Employee

Re: IP Phones not registering in CME

Are you trying to auto register phones or need manual registration ? For auto registration you don't need to do any config but your phones won't get any DN's in case of SCCP. SIP has auto DN assignment. Look at the CME Admin Guide for information about setting this up.

Nipun Singh Raghav
"We cannot solve our problems with the same thinking we used when we created them"
VIP Collaborator

Re: IP Phones not registering in CME

Hi there


Can you share show voice register tftp-bind

 

Also try add the source address under voice register global

 

voice register global

source-address 10.0.111.254 port 5060

create profile

 

 

 

Hope this helps!

Cheers
Rath!


***Please rate helpful posts***

 

 

 

Beginner

Re: IP Phones not registering in CME

tftp-server url flash:/its/syncinfo.xml alias syncinfo.xml
tftp-server url flash:/its/SIPDefault.cnf alias SIPDefault.cnf
tftp-server url flash:/its/softkeyDefault_kpml.xml alias softkeyDefault_kpml.xml
tftp-server url flash:/its/softkeyDefault.xml alias softkeyDefault.xml
tftp-server url flash:/its/featurePolicyDefault.xml alias featurePolicyDefault.xml
tftp-server url flash:/its/SEP003C10E9D0F3.cnf.xml alias SEP003C10E9D0F3.cnf.xml

After adding the source command under voice register global  the 7811 phone registered with an auto DN. But the 8865 did not register. 

Cisco Employee

Re: IP Phones not registering in CME

Take a "debug ccsip message" and "debug tftp events" are reseting the phone and share the logs file here.

Nipun Singh Raghav
"We cannot solve our problems with the same thinking we used when we created them"
Beginner

Re: IP Phones not registering in CME

Now the 8865 have registered (I forgot to create a dn pool before now), and the 7811 stooped registering. 

tftp logs for the 7811:

May 27 12:16:59.531: TFTP: Server request for port 50181, socket_id 0x7FCE22351EA8 for process 453
May 27 12:16:59.531: TFTP: read request from host 10.0.111.2(50181) via GigabitEthernet0/0/1
May 27 12:16:59.531: TFTP: Looking for SEP003C10E9D0F3.cnf.xml.sgn
May 27 12:16:59.531: TFTP: Sending error 1 No such file
May 27 12:17:00.454: TFTP: Server request for port 50924, socket_id 0x7FCE223522D8 for process 453
May 27 12:17:00.454: TFTP: read request from host 10.0.111.2(50924) via GigabitEthernet0/0/1
May 27 12:17:00.454: TFTP: Looking for XMLDefault.cnf.xml.sgn
May 27 12:17:00.455: TFTP: Sending error 1 No such file

and ccsip messages logs showing for 7811. for 8865 it shows successful message.

 

voice service voip
 allow-connections h323 to h323
 allow-connections h323 to sip
 allow-connections sip to sip
 fax protocol t38 version 0 ls-redundancy 0 hs-redundancy 0 fallback none
 sip
  registrar server expires max 600 min 60
!
!
!
!
!
voice register global
 mode cme
 source-address 10.0.111.254 port 5060
 max-dn 50
 max-pool 3
 load 7811 sip78xx.12-1-1-12
 load 8865 sip8845_65.12-1-1-12
 timezone 25
 tftp-path flash:
 file text
 create profile sync 0006305904945346
 auto-register
 !
!
voice register dn  2
 number 1002
!
voice register dn  3
 number 1003
 name CP8865
!
voice register pool  2
 busy-trigger-per-button 2
 id mac 003C.10E9.D0F3
 type 7811
 number 1 dn 2
!
voice register pool  3
 busy-trigger-per-button 2
 id mac 7001.B576.E79A
 type 8865
 number 1 dn 3
!

 

Beginner

Re: IP Phones not registering in CME

when I enter the create profile command I get this error:

%Error deleting flash:/its/jabber-config.xml (No such file or directory)
%Error deleting flash:/its/SEP003C10E9D0F3.cnf.xml (No such file or directory)
Cisco Employee

Re: IP Phones not registering in CME

That's fine. You can ignore them. They won't hamper your phone registration.

Nipun Singh Raghav
"We cannot solve our problems with the same thinking we used when we created them"
Participant

Re: IP Phones not registering in CME

Ok @ArwaSh

 

For your 7811 registration issue the problem is that your ip phone try to load sgn file ( signed file ). You can see that with your log.....the SEP file has got sgn extension...

It s due to an old secure configurarion register on the ip phone (hardware).

The best way is to do a factory reset of that phone in order to delete this old hardware secure configuration.

 

1. You need to load 7811's sip firmware files on your cme and configure the tftp-server. 

 

2. Do a factory reset and check that your ip phone load its firmware files.

 

3. Check the log if your ip phone try to donwload by tftp the SEP xml.cnf ( not sgn anymore ) configuration file.

 

 

 

Best regards
******* If This Helps, Please Rate *******
Ben
Beginner

Re: IP Phones not registering in CME

It Worked! Thank you!
Participant

Re: IP Phones not registering in CME

You're welcome

 

See U

Best regards
******* If This Helps, Please Rate *******
Ben
Highlighted
Beginner

Re: IP Phones not registering in CME

I have an issue somewhat similar to this, can you help please?

I was registering my phones with this method; 

ephone-dn 1 dual-line
number 1001
label John Smith
description John Smith
name John Smith

 

ephone 1
mac-address 1CAA.xxxx.xxxx
ephone-template 1
type 7945
button 1:1

 

BUT I WANT TO CHANGE IT TO THIS SO I CAN USE THE "NO-REG" COMMAND.

voice register dn 1
number 1008
name John Smith
label John Smith

no-reg

 

voice register pool 1
id mac 1CAA.xxxx.xxxx
type 7945
number 1 dn 1

 

The problem is, my phones are not picking up configuration from TFTP but are actually registered via SSCP. How do I solve this please?

CreatePlease to create content
Content for Community-Ad
August's Community Spotlight Awards