cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
496
Views
0
Helpful
4
Replies
Highlighted
Participant

Is this a faulty VIC2-2FXO ? (CUCME 8.8 2901)

I did start a thread on CLI based on this router but have not come to any solid conclusion apart from this is looking like a fault, however I'm hoping now someone can point me as to where this fault lies.

I originally had caller ID issues. I live in England and believe, with guidance from this forum and other online posts, that I have correctly configured the FXO interface for my provider (BT). Also, I have tried variants of the below configuration, setting cptone to US (default) but of course this had no effect and either did not change the outcome or it made things worse. As this is a home-lab router, it is unimportant although an annoyance. My FXO configuration is below:

voice-port 0/1/0

trunk-group POTS

supervisory disconnect anytone

cptone GB

timing sup-disconnect 85

connection plar opx 3162

impedance complex3

description PSTNtoSkyBT

caller-id enable

caller-id alerting line-reversal

caller-id alerting dsp-pre-allocate

My symptoms:

Caller ID works, however the specific issue is that if I do not receive a call for a few hours when a call arrives caller ID is not picked up. After you end that call, if you immediately call the line, caller ID is picked up on every new call. Until there is a lack of calls for a few hours or more. For example, no one calls me during the late hours of the night. When a call comes in the next day the caller ID displays "unknown". In the logs you see "cgn:" showing no caller ID received.

Here is the log showing the issue:

000113: Oct 11 19:20:31.011 GMT: %VOIPAAA-5-VOIP_FEAT_HISTORY: FEAT_VSA=fn:TWC,ft:10/11/2011 19:20:22.295,cgn:,cdn:1001,frs:0,fid:14,fcid:844F373EF36C11E08035CE6F4B604ED0,legID:E,bguid:844F373EF36C11E08035CE6F4B604ED0

000117: Oct 11 19:22:59.003 GMT: %VOIPAAA-5-VOIP_FEAT_HISTORY: FEAT_VSA=fn:TWC,ft:10/11/2011 19:22:50.851,cgn:07738xxxxx0,cdn:1001,frs:0,fid:16,fcid:DCDB01BFF36C11E08040CE6F4B604ED0,legID:10,bguid:DCDB01BFF36C11E08040CE6F4B604ED0

As you can see, two minutes later and the caller ID is received.

I know my POTS line has caller ID on each call because I have a caller ID unit which sits on the POTS line to display caller ID specifically. It is an old unit from the late 90s, but works every time!

As well as trying all different variations of voice-port configuration, I have tried CME versions 7.1, 8.6 and now 8.8. Each has the same issue.

I have also swapped my DSP chip to the next slot on the main board.

I have also switched FXO ports (VIC2-2FXO)

Lastly I have also moved the FXO card from slot 0 on the chassis to one of the other slots, where it currently resides, each without change.

This is beginning to lead me to think that possibly my FXO card is faulty? Would anyone be in agreement with this? What are the possibilities of this being a faulty DSP chip?  I ask because of the "dsp-pre-allocate" command under the FXO interface.

I would really like to have this working first time every time. I would like some guidance before I buy another VIC2-2FXO, in case it is unnecessary. I'm probably not going to be able to buy a PVDM3 though.

Thank you,
Regards,

Tony

Everyone's tags (3)
4 REPLIES 4
Hall of Fame Master

Is this a faulty VIC2-2FXO ? (CUCME 8.8 2901)

Seems a "normal" bug, to which only Cisco can remedy, provided you can demonstrate the issue, and they can reproduce it. It cab take months just to get to that point.

Participant

Is this a faulty VIC2-2FXO ? (CUCME 8.8 2901)

I can reproduce the issue, although I need to wait for around two hours before the symptoms re-occur.

Of course, I do not have TAC or a SMARTnet as I bought this router myself for lab and studies.

Cisco - please see this and fix it! Thanks.

Participant

Is this a faulty VIC2-2FXO ? (CUCME 8.8 2901)

I have logged a TAC case for this issue. I did not know I was eligible to do this. I'll keep updated.

Participant

Is this a faulty VIC2-2FXO ? (CUCME 8.8 2901)

The TAC engineer took some captures and advised me to adjust the input gain so the router receives a better signal for Caller ID. I've made the following change and the whole of today Caller ID has worked flawlessly.

voice-port 0/1/0

  input gain -6

I'm going to continue testing but before, I was easily able to reproduce the problem by not receiving a call for a few hours.

CreatePlease to create content
Content for Community-Ad
August's Community Spotlight Awards