ANNOUNCEMENT - The community will be down for maintenace this Thursday August 13 from 12:00 AM PT to 02:00 AM PT. As a precaution save your work.
cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
200
Views
0
Helpful
2
Replies
Highlighted

Issue on voice vlan and vlan data

Hi, I'm Fernando Priego, I have a problem, I set up a Catalyst 2960-x switch in 3 layer mode, first I made 3 VLAN'S vlan10 = admin, vlan 20 = data, vlan 30 voice, then I made 3 dhcp servers for each vlans, in second instead I configured the SVI of each vlan and its default getagay, the problem is when I connect my ip phone to the configuration port with the vlan access and the vlan voice this message appears, the one gave me the ip for segment 20 and segment 30 on the computer and ip phone:

 

Jan 1 21:12:54.882: %ADJ-5-RESOLVE_REQ_FAIL: Adj resolve request failed for 192.168.20.11 on Vlan20

This is my running-configuration:

SW-D#show run
Building configuration...

Current configuration : 3359 bytes
!
! Last configuration change at 21:03:15 UTC Sat Jan 1 2000
!
version 15.2
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname SW-D
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
switch 1 provision ws-c2960x-48ts-l
!
!
!
!
ip routing
ip dhcp excluded-address 192.168.30.254
ip dhcp excluded-address 192.168.20.251
!
ip dhcp pool VOICE
network 192.168.30.0 255.255.255.0
default-router 192.168.30.254 255.255.255.0
dns-server 8.8.8.8
lease 0 1
!
ip dhcp pool VLAN-20
network 192.168.20.0 255.255.255.0
default-router 192.168.20.252
dns-server 192.168.20.251
lease 0 1
!
ip dhcp pool POOL
!
!
!
!
!
!
!
!
!
!
!
spanning-tree mode rapid-pvst
spanning-tree extend system-id
!
!
!
!
!
lldp run
!
!
!
!
!
!
!
!
!
!
interface FastEthernet0
no ip address
no ip route-cache
!
interface GigabitEthernet1/0/1
switchport access vlan 20
switchport mode access
!
interface GigabitEthernet1/0/2
!
interface GigabitEthernet1/0/3
!
interface GigabitEthernet1/0/4
!
interface GigabitEthernet1/0/5
switchport access vlan 20
switchport mode access
switchport voice vlan 30
spanning-tree portfast edge
!
interface GigabitEthernet1/0/6
!
interface GigabitEthernet1/0/7
switchport access vlan 20
switchport mode access
switchport voice vlan dot1p
spanning-tree portfast edge
!
interface GigabitEthernet1/0/8
!
interface GigabitEthernet1/0/9
switchport access vlan 20
switchport mode access
!
interface GigabitEthernet1/0/10
!
interface GigabitEthernet1/0/11
!
interface GigabitEthernet1/0/12
!
interface GigabitEthernet1/0/13
switchport access vlan 20
switchport mode access
switchport voice vlan 30
spanning-tree portfast edge
!
interface GigabitEthernet1/0/14
!
interface GigabitEthernet1/0/15
!
interface GigabitEthernet1/0/16
!
interface GigabitEthernet1/0/17
!
interface GigabitEthernet1/0/18
!
interface GigabitEthernet1/0/19
!
interface GigabitEthernet1/0/20
!
interface GigabitEthernet1/0/21
!
interface GigabitEthernet1/0/22
!
interface GigabitEthernet1/0/23
!
interface GigabitEthernet1/0/24
!
interface GigabitEthernet1/0/25
!
interface GigabitEthernet1/0/26
!
interface GigabitEthernet1/0/27
!
interface GigabitEthernet1/0/28
!
interface GigabitEthernet1/0/29
!
interface GigabitEthernet1/0/30
!
interface GigabitEthernet1/0/31
!
interface GigabitEthernet1/0/32
!
interface GigabitEthernet1/0/33
!
interface GigabitEthernet1/0/34
!
interface GigabitEthernet1/0/35
!
interface GigabitEthernet1/0/36
!
interface GigabitEthernet1/0/37
!
interface GigabitEthernet1/0/38
!
interface GigabitEthernet1/0/39
!
interface GigabitEthernet1/0/40
!
interface GigabitEthernet1/0/41
!
interface GigabitEthernet1/0/42
!
interface GigabitEthernet1/0/43
!
interface GigabitEthernet1/0/44
!
interface GigabitEthernet1/0/45
!
interface GigabitEthernet1/0/46
!
interface GigabitEthernet1/0/47
!
interface GigabitEthernet1/0/48
!
interface GigabitEthernet1/0/49
!
interface GigabitEthernet1/0/50
!
interface GigabitEthernet1/0/51
!
interface GigabitEthernet1/0/52
!
interface Vlan1
no ip address
!
interface Vlan20
ip address 192.168.20.252 255.255.255.0
!
interface Vlan30
ip address 192.168.30.254 255.255.255.0
!
!
ip http server
ip http secure-server
!
!
!
!
line con 0
line vty 0 4
logging synchronous
login
line vty 5 15
logging synchronous
login
!
!
end

2 REPLIES 2
Highlighted
VIP Advisor

Re: Issue on voice vlan and vlan data

Hi @fernandopriego1994R&S 

 

I have seen in some forums that solved the problem with the following command:

 

(config)#no ip cef optimize neighbor resolution

 

Check if it is useful for you

 

Regards

 

https://community.cisco.com/t5/switching/3750x-stack-is-repeatedly-showing-error-quot-adj-3-resolve-req/td-p/2472784

https://community.cisco.com/t5/discusiones-routing-y-switching/adj-5-resolve-req-fail-adj-resolve-request-failed/td-p/3686111

Highlighted
Rising star

Re: Issue on voice vlan and vlan data

You have a problem with your default router your handing out two addresses? remove 255.255.255.0 at the end of the command I assume that is not a valid default router for you.

 

https://www.cisco.com/c/en/us/td/docs/routers/access/1800/1801/software/configuration/guide/scg/dhcpvlan.html

 

 

ip dhcp pool VOICE
network 192.168.30.0 255.255.255.0
default-router 192.168.30.254 ,<remove this part>
dns-server 8.8.8.8
lease 0 1
!

 

Also please post a show vlan make sure your see your vlan as active. 

 

Please post output of show cdp neighbor <interface attached to phones> details 

if