cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
331
Views
0
Helpful
7
Replies
Highlighted
Beginner

jabber-config.xml displays a weird character at the beginning of the file

Hi.

 

I'm preparing a Cisco certification and I'm having problems with Jabber for Windows. The Disable_IM_Histore does not work (workaround is to open jabber-config.xml and erase all the blank lines and save again the file, exit Jabber and reopen it).

 

This is my original configuration file before sending it to CUCM TFTP, everything looks good

no-chat.xml.png

 

 

 

 

 

 

When I send it to the CUCM Pub and Sub (both TFTPs) + restart of service, I start Jabber after deleting the folder here \AppData\Roaming\Cisco\Unified Communications, the jabber-config.xml is create again but when I open it  with Notepad++ or inside the gateway, it shows a weird character at the beginning or blank lines:

From the gateway

no-chat-gw.png

 

 

 

 

 

 

 

 

From Notepad++ after opening the file in Windowsblank.png

 

 

 

 

 

 

 

 

 

I created the no-chat.xml file with notepad and save it as UTF-8 encoding.

 

What am I doing wrong?

 

 

7 REPLIES 7
Hall of Fame Cisco Employee

Re: jabber-config.xml displays a weird character at the beginning of the file

You can't use the parameters wherever you want in the .xml, Disable_IM_History is not a directory parameter.

Review the parameter reference guide in regards to that parameter to find out where it should be used.

HTH

java

if this helps, please rate
Beginner

Re: jabber-config.xml displays a weird character at the beginning of the file

Hi Jaime,

I know it is a client parameters; however, i'm having the same behavior.

Beginner

Re: jabber-config.xml displays a weird character at the beginning of the file

Hi Jaime,

 

I know it is a client parameter; however, the behavior is the same.

 

Regards,

Cesar

Hall of Fame Cisco Employee

Re: jabber-config.xml displays a weird character at the beginning of the file

Try http://tftp_server_address:6970/jabber-config.xml

What do you see??

 

I agree with Maren, I haven't had any issues with Notepad++ and hidden/non-printable characters, but for a .xml so short, you can try manually typing the whole thing to discard that.

HTH

java

if this helps, please rate
VIP Collaborator

Re: jabber-config.xml displays a weird character at the beginning of the file

Have you tried re-typing it from scratch? The artifact may be hidden from the plain text, even in Notepad++.

And when Jaime was saying that disable_im_history is a client parameter, he meant that the syntax of your jabber-config.xml file is missing the Client section:

<?xml version="1.0" encoding="utf-8"?>
<config version="1.0">
 <Client>
   <Disable_IM_History>true</Disable_IM_History>
 </Client>
 <Directory>
   <DirectoryServerType>UDS</DirectoryServerType>
 </Directory>
</config>

Try using the text above as your jabber-config.xml and see if that helps.

Maren

Beginner

Re: jabber-config.xml displays a weird character at the beginning of the file

Thank you guys, I'm going to retype it from the scratch and let you know the result.

Beginner

Re: jabber-config.xml displays a weird character at the beginning of the file

Guys,

This is the result of my tests:

If I copy-pasted Maren code inside Notepad file > Save As > nochat2.xml (UTF-8 encoding), then sent it to the CUCM TFTP and restarted the service TFTP.

nochat2.png

 

Netx, I copied nochat2.xml file from TFTP to the gateway and checked-out its content:nochat2-2.png

 

 

 

 

 

 

 

 

 

As you can see there is a o;? at the beginning of the file (is it normal?). If I type the whole file from scratchs (no copy-paste), the result is the same. Now compare the previous with this youtube video:

https://youtu.be/p-96RoA5wEY?t=2451

 

... the output is not the same, the question is: the quality of my configuration file is in jeopardy because of these characters?

 

@Jaime Valencia

 nochat2-3.png

 

Thanks again for your inputs.

Cesar

CreatePlease to create content
Content for Community-Ad
July's Community Spotlight Awards