cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1174
Views
0
Helpful
9
Replies

Jabber Error over Expressway

Rajan R
Beginner
Beginner

Hey Guys,

 

I have completed the setup (or so i assume). When I look intot the Jabber Logs it gives the below error. The host is reachable from outside.

Any ideas?

 

 

2014-10-13 15:17:11,495 INFO  [0x000016f4] [ls\src\http\CurlAnswerEvaluator.cpp(108)] [csf.httpclient] [http::CurlAnswerEvaluator::curlCodeToResult] - curlCode=[7] error message=[Failed to connect to expe.xxx.com port 8443: Connection refused] result=[HOST_UNREACHABLE_ERROR]
2014-10-13 15:17:11,495 INFO  [0x000016f4] [ls\src\http\BasicHttpClientImpl.cpp(373)] [csf.httpclient] [http::executeImpl] - *-----* HTTP response from: https://expe.xxx.com:8443/Y2RzcGwuY29t/get_edge_config?service_name=_cisco-uds&service_name=_cuplogin[1] -> 0.
2014-10-13 15:17:11,495 ERROR [0x000016f4] [ls\src\http\BasicHttpClientImpl.cpp(377)] [csf.httpclient] [http::executeImpl] - There was an issue performing the call to curl_easy_perform: HOST_UNREACHABLE_ERROR
2014-10-13 15:17:11,495 DEBUG [0x000016f4] [etutils\src\http\HttpRequestData.cpp(82)] [csf.httpclient] [http::HttpRequestData::returnEasyCURLConnection] - Returning borrowed EasyCURLConnection from request : 1

 

Thanks

VR

9 REPLIES 9

I guess its as simple as Jabber is reporting.. Have you checked your DNS records? Do you have the A record for your expressway-e setup on your public DNS?

Please rate all useful posts

Yes. My A Record as well as SRV records are in place on my public dns and are verified.

 

Thanks

VR

Please send your full jabber logs.

Please rate all useful posts

Please find attached.

 

Thanks

VR

What is the status of your unified communications on your expressway-C. Is your XCP and XMPP router, http proxy service active?

Please rate all useful posts

Thanks Ayodeji. It is not. I have added the IMP server and all the services are active on the Presence Server. But says inactive on exp-c. On the Discovery Page for Presence in exp-c it says Jabber:Inactive.

 

Thanks

VR

Is your traversal zone active between expwc and expwe? How is your expressway E configured? is it dual interface? Does your MRA Traversal zone point to the DNS name of the expressway E (which should resolve to the public ip address of expressway e)..

If you are using a single interface, you need to disable the second nic on your expressway-e

You need to configure NAT reflexion for expressway to be bale to reach the public IP of expressway-e

Please rate all useful posts

Traversal Zone is active. Exp-E has only one interface. It just says LAN1. This is virtual by the way. exp-E is on DMZ.  It does point to the DNS name of exp-e.

 

I am using one interface. How do I disable the second ?Where is NAT Reflexion configured ? On the firewall ?

 

Thanks

VR

I believe you get the second nic when you have the Advanced Networking license.

Please look through this thread for similar issue on inactive jabber

https://supportforums.cisco.com/discussion/12200046/mobile-remote-access-expressway-inactive-jabber

Yes NAT reflection is configured on firewall

Please rate all useful posts
Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community: