cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

AMA-CUCM Troubleshooting: Best Practices for Reading Trace Files

220
Views
15
Helpful
5
Replies
Rising star

LDAP Users are not Sychornizing CUCM 11.0.1.22900-14

I have CUCM 11.0.1.22900-14 and AD 2012 R2.  Trying to setup the Synchronization between two. CUCM Is able to connect the LDAP Server but none of the user populates. Based on search on forums i have confirmed that last name is not empty in the AD and also all the fields listed in  AD ( Table 16-4 Synchronized LDAP Attributes and Corresponding Unified CM Field Names):

http://www.cisco.com/c/en/us/td/docs/voice_ip_comm/cucm/srnd/collab10/collab10/directry.html.

On further analyzing the packet capture  and logs what i see is that CUCM is sending the Request and no results are found.

18           2016-11-09 10:32:43.971702         192.168.10.15     172.24.155.65     LDAP     275         searchRequest(2) "ou=Trainee, ou=Users Accounts, dc=*****, dc=local" baseObject

19           2016-11-09 10:32:43.972095         172.24.155.65     192.168.10.15     LDAP     88           searchResDone(2) success  [0 results]

Tried Restarting Dir Service.

On Packet capture i can see below filter [Although I have not choosen any filter in the LDAP Directory page]

Any One here has any Ideas what is going on.

5 REPLIES 5
Highlighted
Enthusiast

Have you verified the search

Have you verified the search base string is correct? I suggest using something like Apache's Directory Studio (free) and verify the search base string that CUCM is issuing to AD is correct.

Thanks,

Ryan

Hall of Fame Cisco Employee

There's always a default

There's always a default filter for any LDAP config, and that's what you're seeing.

Does the user you're using in the sync has read permissions over the OU(s) you're trying to sync?

HTH

java

if this helps, please rate
Participant

Lets run thru a quick couple

Lets run thru a quick couple things-

*Please omit sensitive information

Paste your LDAP Manager Distinguished Name field and LDAP User Search Base

Make sure password is correct

Are you using a filter? If so, show what it is

Do a screen capture of LDAP Directory Synchronization Schedule and Standard User Fields To Be Synchronized

I assume you're able to verify connectivity between the two? Maybe try a couple pings

What port number are you using? TLS?

Hostname or IP? 

Rising star

Thanks everyone for the

Thanks everyone for the update.

I was struggling to resolve this issue , I installed test CUCM 10.5 and configured same LDAP Sync rule and it worked !! Which confirms that configuration on LDAP Side is working Fine.

Tried restarting Dir Syc service still no luck.

Finally i rebooted the server and It started working.

Also another issue where presence users will show Unassigned in IMP server although assigned in CUCM was resolved. Same issue is reported in below post.

 https://supportforums.cisco.com/discussion/11708161/cisco-ucm-im-and-presence-90-syncing-not-working

Not sure what was the root cause but seems like something on LDAP was not working fine

Thanks

Haris

Participant

Did you change the port

Did you change the port number for the IM&P fix prior to the reboot?

CreatePlease to create content
Content for Community-Ad
August's Community Spotlight Awards