cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
Walkthrough Wednesdays
435
Views
0
Helpful
7
Replies
Asim Afzal
Beginner

LDP filter not working in cisco 8.5

HI,

I am applying an ldap filter in Cisco CCM 8.5 to filter record whoes ipphone field contain null vale

I apply below mention filter and still its not working

(&(objectclass=user)(!(objectclass=Computer))(!(UserAccountControl:1.2.840.113556.1.4.803:=2))(|(ipPhone=*))

(&(objectclass=user)(&(ipPhone=*))(!(objectclass=Computer))(!(UserAccountControl:1.2.840.113556.1.4.803:=2)))

(&(objectCategory=person)(objectClass=user)(ipPhone=*)(!(userAccountControl:1.2.840.113556.1.4.803:=2)))

(&(objectclass=user)(ipphone=*)(!(objectclass=Computer))(!(UserAccountControl:1.2.840.113556.1.4.803:=2)))

Any body advise

7 REPLIES 7

Asim,

Try this

(&(objectCategory=person)(objectClass=user)(ipPhone=*)(!(userAccountControl:1.2.840.113556.1.4.803:=2)))

Please rate all useful posts

"'Nature is too thin a screen, the glory of the omnipresent God bursts through it everywhere"-Ralph Waldo Emerson

Please rate all useful posts

hi,

i already applied the same but its not working

How many filters do you have? Please remove all the other filters leaving only this one.

Please rate all useful posts

"'Nature is too thin a screen, the glory of the omnipresent God bursts through it everywhere"-Ralph Waldo Emerson

Please rate all useful posts

hi

There is only onw filter applied but still its not working

Please send the screen shot of your CUCM filter configuration page. What is the version of the LDAP you are using? is AD 2003 or 2008?

Please rate all useful posts

"'Nature is too thin a screen, the glory of the omnipresent God bursts through it everywhere"-Ralph Waldo Emerson

Please rate all useful posts

hi,

AD is 2008 .Its only one filter applied at a time .i tested the same filter you mention in the thread.i followed the below mention link documentation but still when i am using corporate directory on my ip phone i can see the user without ip phone extension.

Do i need to restart any service ?

https://supportforums.cisco.com/docs/DOC-26925

I suspect it might be AD 2008. There is a slight need for syntax modification..try this..Note the & with the IpPhone field..

Please use as exactly below and try again

(&(objectclass=user)(&(ipPhone=*))(!(objectclass=Computer))(!(UserAccountControl:1.2.840.113556.1.4.803:=2)))

Please rate all useful posts

"'Nature is too thin a screen, the glory of the omnipresent God bursts through it everywhere"-Ralph Waldo Emerson

Please rate all useful posts
Content for Community-Ad

Spotlight Awards 2021