cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
436
Views
0
Helpful
9
Replies
Highlighted
Collaborator

Looking for some CME 12.x config help.

I'm setting up a home lab and while I'm close to having a lot of this figured out, there are a few things which I can't just get.

1. Outbound calls take ~30 seconds to connect after entering the number I want to dial. (no issues with inbound)

2. If I make a call on line 2 (2001) I can't get my caller ID to be different.

3. I had to make the international calling dial peer super exact to get it to work, no idea why.

 

no ip domain lookup
ip domain name domain.int
ip name-server 192.168.1.1
ip cef
no ipv6 cef
!
multilink bundle-name authenticated
!
voice-card 0
dsp services dspfarm
!
voice rtp send-recv
!
voice service voip
ip address trusted list
ipv4 34.226.36.32 255.255.255.240
ipv4 34.226.36.32
ipv4 34.226.36.33
ipv4 34.226.36.34
ipv4 34.226.36.35
ipv4 34.226.36.36
ipv4 34.226.36.37
ipv4 34.226.36.38
ipv4 34.226.36.39
ipv4 34.226.36.40
ipv4 34.226.36.41
ipv4 34.226.36.42
ipv4 34.226.36.43
ipv4 34.226.36.44
ipv4 34.226.36.45
ipv4 34.226.36.46
ipv4 34.226.36.47
rtp-port range 20000 20010
address-hiding
allow-connections sip to sip
no supplementary-service sip moved-temporarily
no supplementary-service sip refer
fax protocol t38 version 0 ls-redundancy 0 hs-redundancy 0 fallback none
sip
bind control source-interface GigabitEthernet0/0
bind media source-interface GigabitEthernet0/0
registrar server expires max 3600 min 3600
localhost dns:us-east-va.sip.flowroute.com:5060
early-offer forced
!
voice class codec 1
codec preference 1 g729r8
codec preference 2 g711ulaw
!
voice iec syslog
voice register global
mode cme
source-address 192.168.1.100 port 5060
max-dn 20
max-pool 10
load 8851 sip88xx.11-5-1SR1-1
authenticate register
authenticate realm all
tftp-path flash:
create profile sync 0782338578280544
auto-register
!
voice register dn 1
number 5000
name David Macias
!
voice register pool 1
busy-trigger-per-button 2
id mac 9C57.BBBB.64F2
type 8851
number 1 dn 1
username david password 1234
description David Macias
codec g711ulaw
no vad
!
voice translation-rule 1
rule 1 /.+/ /2000/
!
voice translation-rule 2
rule 1 /^911$/ /911/
rule 2 /^9\(.*\)/ /+\1/
!
voice translation-rule 3
rule 1 /^2001/ /9795550458/
rule 2 /^2000/ /8455551898/
!
voice translation-rule 4
rule 1 /^9011\(.*\)/ /+\1/
!
voice translation-profile InboundProfile
translate called 1
!
voice translation-profile OutboundInternationalProfile
translate called 4
!
voice translation-profile OutboundProfile
translate calling 3
translate called 2
!
vxml logging-tag
license udi pid CISCO2911/K9 sn FTX140001DN
hw-module ism 0
!
hw-module pvdm 0/0
!
hw-module pvdm 0/1
!
username admin privilege 15 password 0
!
redundancy
!
interface Embedded-Service-Engine0/0
no ip address
shutdown
!
interface GigabitEthernet0/0
ip address dhcp
duplex auto
speed auto
!
interface ISM0/0
ip unnumbered GigabitEthernet0/1
service-module ip address 192.168.1.99 255.255.255.0
!Application: CUE Running on ISM
service-module ip default-gateway 192.168.1.254
!
interface GigabitEthernet0/1
ip address 192.168.1.100 255.255.255.0
duplex auto
speed auto
!
interface GigabitEthernet0/2
no ip address
shutdown
duplex auto
speed auto
!
interface ISM0/1
no ip address
shutdown
!
interface Vlan1
no ip address
!
ip forward-protocol nd
!
ip http server
no ip http secure-server
ip http path flash:/GUI
!
ip route 192.168.0.0 255.255.0.0 192.168.1.1
ip route 192.168.1.99 255.255.255.255 ISM0/0
ip route 192.168.1.99 255.255.255.255 Embedded-Service-Engine0/0
ip route 34.0.36.32 255.255.255.240 dhcp
ip route 0.0.0.0 0.0.0.0 dhcp
ip ssh version 2
!
ip access-list extended OUTSIDE-IN
permit udp any any range 20000 30000
permit udp 34.0.36.32 0.0.0.16 any eq 5060
deny ip any any log
!
tftp-server flash:/PhoneFirmware/SCCP/7945-7965-9-2-1SR2/apps45.9-2-1ES4.sbn alias apps45.9-2-1ES4.sbn
tftp-server flash:/PhoneFirmware/SCCP/7945-7965-9-2-1SR2/cnu45.9-2-1ES4.sbn alias cnu45.9-2-1ES4.sbn
tftp-server flash:/PhoneFirmware/SCCP/7945-7965-9-2-1SR2/cvm45sccp.9-2-1ES4.sbn alias cvm45sccp.9-2-1ES4.sbn
tftp-server flash:/PhoneFirmware/SCCP/7945-7965-9-2-1SR2/dsp45.9-2-1ES4.sbn alias dsp45.9-2-1ES4.sbn
tftp-server flash:/PhoneFirmware/SCCP/7945-7965-9-2-1SR2/jar45sccp.9-2-1ES4.sbn alias jar45sccp.9-2-1ES4.sbn
tftp-server flash:/PhoneFirmware/SCCP/7945-7965-9-2-1SR2/SCCP45.9-2-1SR2S.loads alias SCCP45.9-2-1SR2S.loads
tftp-server flash:/PhoneFirmware/SCCP/7945-7965-9-2-1SR2/term45.default.loads alias term45.default.loads
tftp-server flash:/PhoneFirmware/SCCP/7945-7965-9-2-1SR2/term65.default.loads alias term65.default.loads
tftp-server flash:/PhoneFirmware/SIP/88xx.11-5-1SR1-1/fbi88xx.BE-01-010.sbn alias fbi88xx.BE-01-010.sbn
tftp-server flash:/PhoneFirmware/SIP/88xx.11-5-1SR1-1/kern88xx.11-5-1SR1-1.sbn alias kern88xx.11-5-1SR1-1.sbn
tftp-server flash:/PhoneFirmware/SIP/88xx.11-5-1SR1-1/rootfs88xx.11-5-1SR1-1.sbn alias rootfs88xx.11-5-1SR1-1.sbn
tftp-server flash:/PhoneFirmware/SIP/88xx.11-5-1SR1-1/sb288xx.BE-01-019.sbn alias sb288xx.BE-01-019.sbn
tftp-server flash:/PhoneFirmware/SIP/88xx.11-5-1SR1-1/sip88xx.11-5-1SR1-1.loads alias sip88xx.11-5-1SR1-1.loads
tftp-server flash:/PhoneFirmware/SIP/88xx.11-5-1SR1-1/vc488xx.11-5-1SR1-1.sbn alias vc488xx.11-5-1SR1-1.sbn
!
control-plane
!
mgcp behavior rsip-range tgcp-only
mgcp behavior comedia-role none
mgcp behavior comedia-check-media-src disable
mgcp behavior comedia-sdp-force disable
!
mgcp profile default
!
sccp local GigabitEthernet0/1
sccp ccm 192.168.1.100 identifier 1 version 7.0
sccp
!
sccp ccm group 1
bind interface GigabitEthernet0/1
associate ccm 1 priority 1
associate profile 1 register MTPd0d0fdd016a1
keepalive retries 1
switchover method immediate
switchback method immediate
switchback interval 1
!
dspfarm profile 1 transcode
codec g711ulaw
codec g729r8
maximum sessions 10
associate application SCCP
!
dial-peer voice 1 voip
description ** Incoming Flowroute **
translation-profile incoming InboundProfile
session protocol sipv2
incoming called-number .T
voice-class codec 1
voice-class sip dtmf-relay force rtp-nte
no voice-class sip early-offer forced
voice-class sip bind control source-interface GigabitEthernet0/0
voice-class sip bind media source-interface GigabitEthernet0/0
dtmf-relay rtp-nte
no vad
!
dial-peer voice 2 voip
description **Outgoing Call to SIP Trunk**
translation-profile outgoing OutboundProfile
destination-pattern 91[2-9]..[2-9]......
session protocol sipv2
session target sip-server
voice-class codec 1
voice-class sip dtmf-relay force rtp-nte
voice-class sip bind control source-interface GigabitEthernet0/0
voice-class sip bind media source-interface GigabitEthernet0/0
dtmf-relay rtp-nte
no vad
!
dial-peer voice 3 voip
description **Outgoing International Call to SIP Trunk**
translation-profile outgoing OutboundInternationalProfile
destination-pattern 9011T
session protocol sipv2
session target sip-server
voice-class codec 1
voice-class sip dtmf-relay force rtp-nte
voice-class sip bind control source-interface GigabitEthernet0/0
voice-class sip bind media source-interface GigabitEthernet0/0
dtmf-relay rtp-nte
no vad
!
dial-peer voice 1000 voip
description ** CUE Voice Mail **
destination-pattern 1000$
session protocol sipv2
session target ipv4:192.168.1.99
dtmf-relay rtp-nte
codec g711ulaw
no vad
!
dial-peer voice 4 voip
description **Outgoing International Argentina Call to SIP Trunk**
destination-pattern 90115411........
session protocol sipv2
session target sip-server
voice-class codec 1
voice-class sip dtmf-relay force rtp-nte
voice-class sip bind control source-interface GigabitEthernet0/0
voice-class sip bind media source-interface GigabitEthernet0/0
dtmf-relay rtp-nte
no vad
!
sip-ua
credentials username username password 7 password realm sip.flowroute.com
authentication username username password 7 password
calling-info pstn-to-sip from number set 18455551898
no remote-party-id
retry invite 3
retry bye 3
retry cancel 3
retry register 3
mwi-server ipv4:192.168.1.99 expires 3600 port 5060 transport udp unsolicited
registrar dns:us-east-va.sip.flowroute.com expires 3600
sip-server dns:us-east-va.sip.flowroute.com
host-registrar
!
gatekeeper
shutdown
!
telephony-service
sdspfarm units 4
sdspfarm transcode sessions 40
sdspfarm tag 1 MTPd0d0fdd016a1
no auto-reg-ephone
max-ephones 10
max-dn 2
ip source-address 192.168.1.100 port 3000
timeouts interdigit 5
load 7945 SCCP45.9-2-1SR2S
time-zone 13
dialplan-pattern 1 8455551898 extension-length 4
voicemail 1000
mwi relay
max-conferences 8 gain -6
web admin system name admin password C1sc0
dn-webedit
time-webedit
transfer-system full-consult
secondary-dialtone 9
create cnf-files version-stamp 7960 Nov 25 2019 05:59:35
!
ephone-dn 1 dual-line
number 2000
label 2000-+18455551898
description David Macias
name David Macias
call-forward busy 1000
call-forward noan 1000 timeout 20
mwi sip
!
ephone-dn 2 dual-line
number 2001
label 2001-+19795550458
!
ephone 1
device-security-mode none
description 7945 Ext 2000
mac-address 0023.5555.8846
type 7945
button 1:1 2:2
!
line con 0
line aux 0
line 2
no activation-character
no exec
transport preferred none
transport output pad telnet rlogin lapb-ta mop udptn v120 ssh
stopbits 1
line 131
no activation-character
no exec
transport preferred none
transport input all
transport output pad telnet rlogin lapb-ta mop udptn v120 ssh
stopbits 1
line vty 0 4
password damuall
login local
transport input ssh
!
scheduler allocate 20000 1000
ntp server 216.239.35.0
!
end

Everyone's tags (1)
1 ACCEPTED SOLUTION

Accepted Solutions
VIP Advisor

Re: Looking for some CME 12.x config help.

Smells like a DNS issue. Maybe try changing your DNS name server to a different one. ;)

Anthony Holloway

View solution in original post

9 REPLIES 9
Highlighted
Hall of Fame Master

Re: Looking for some CME 12.x config help.

David,

 

For issues 1 and 3 can you post "debug ccsip messages" and "debug voice ccapi inout"?

 

Highlighted
Collaborator

Re: Looking for some CME 12.x config help.

Thank you @Chris Deren for taking a look. Here's the debug for calling a US based PSTN number.

 

 

Highlighted
Hall of Fame Master

Re: Looking for some CME 12.x config help.

I see the call matching the outbound dial-peer 2 at 13:52:28.886

 

Jan 14 13:52:28.886: //2518/EEA7DC3989A3/CCAPI/ccSaveDialpeerTag:
Outgoing Dial-peer=2

 

Then, the SIP INVITE does not get out until 13:52:46.910 (18 seconds later)

 

Jan 14 13:52:46.910: //2519/EEA7DC3989A3/SIP/Msg/ccsipDisplayMsg:
INVITE sip:+19493646000@us-east-va.sip.flowroute.com:5060 SIP/2.0

 

This is odd and the debug does not reveal why, can us-east-va.sip.flowroute.com be resolved?

 

Lastly, It appears the provider does not come back with 200 OK until 11 seconds after the call is initiated as the Trying message from them arrives at 13:52:47.046, but the OK not until  13:52:58.058

 

Have you tried using the TCP as the transport instead of UDP just for kicks? I am not sure what the router would wait 18 seconds before proceeding with the INVITE after it matched correct dial-peer.

Highlighted
Collaborator

Re: Looking for some CME 12.x config help.

When I pinged us-east-va.sip.flowroute.com it was not resolving, but after adding ip domain lookup I get this:

 

911-01#ping us-east-va.sip.flowroute.com
Translating "us-east-va.sip.flowroute.com"...domain server (104.0.36.150) [OK]

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 34.226.36.32, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 24/26/28 ms

 

I'm not following where to set transport to tcp. Can you elaborate please? I see in the access list that I'm only allowing udp, but int he sip-ua config it appears that udp is only used for mwi-server.

 

I apologize in advance if my questions seem a bit silly, the IOS side of things has always been a bit of black magic to me. Thank you for your help.

 

Highlighted
Hall of Fame Master

Re: Looking for some CME 12.x config help.

First try to remove this from sip-ua as I don't think you need this (not CME expert here either):

registrar dns:us-east-va.sip.flowroute.com expires 3600

 

if that does not do it to change it to TCP (this is long shot) do this:

dial-peer voice 2 voip

session-transport tcp

 

and update your ACL to include TCP as well.

Highlighted
Collaborator

Re: Looking for some CME 12.x config help.

Removing the registrar had no effect so I added back in. As for TCP I have the following still with no change:

 

ip access-list extended OUTSIDE-IN
permit udp any any range 20000 30000
permit udp 34.226.36.32 0.0.0.16 any eq 5060
deny ip any any log
permit tcp 34.226.36.32 0.0.0.16 any eq 5060

 

dial-peer voice 2 voip
description **Outgoing Call to SIP Trunk**
translation-profile outgoing OutboundProfile
destination-pattern 91[2-9]..[2-9]......
session protocol sipv2
session target sip-server
session transport tcp
voice-class codec 1
voice-class sip dtmf-relay force rtp-nte
voice-class sip bind control source-interface GigabitEthernet0/0
voice-class sip bind media source-interface GigabitEthernet0/0
dtmf-relay rtp-nte
no vad

 

Any other ideas?

Highlighted
Collaborator

Re: Looking for some CME 12.x config help.

I read a post (can't find now) about using a different IOS version solved their timing issue. Think it's worth a shot? Just seems so random that it would help.

 

david

VIP Advisor

Re: Looking for some CME 12.x config help.

Smells like a DNS issue. Maybe try changing your DNS name server to a different one. ;)

Anthony Holloway

View solution in original post

Highlighted
Collaborator

Re: Looking for some CME 12.x config help.

You can't try to get karma across two different sites! Also, it's never DNS <it was>.

 

david

CreatePlease to create content