cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

1817
Views
20
Helpful
13
Replies
Highlighted
Beginner

MGCP gateway registration problem

Hi all

we do have a Cisco 2821 router running c2800nm-advipservicesk9-mz.124-24.T4.bin on it. We configured it for MGCP as we did for more than 20 locations.  It is connected via E1 PRI. The CUCM servers are on 8.5.1. CUCM shows unregistered but router says it is registered.

I got the following situation:

  • at the router I can see that it is registered with the primary CUCM (via show ccm-manager) and show mgcp displays oper state active
  • inside the call managers it shows unregistered but I can see the IP and if force a reset I can see the interfaces going down and up again

If it would be a displaying issue we wouldn't worry about it but the E1 doesn't come up as show isdn status shows:

ISDN Serial0/0/0:15 interface
        dsl 0, interface ISDN Switchtype = primary-net5
        L2 Protocol = Q.921 0x0000  L3 Protocol(s) = CCM MANAGER 0x0003
    Layer 1 Status:
        SHUTDOWN
    Layer 2 Status:
        TEI = 0, Ces = 1, SAPI = 0, State = TEI_ASSIGNED

Is the reason that it is at unregistered state in CUCM?

Domain name at both sides matches. We restarted the network services Cisco RIS Data Collector on all CUCM servers - no success.

Reload of router or reset via CUCM didn't help at all.

 

Any help on this is highly appreciated as many users are awaiting to call their customers.

If you need further information please let me know!

 

Thanks and regards

Jochen

Everyone's tags (6)
1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted

Hi.So you need a E1 crossover

Hi.

So you need a E1 crossover cable.

The pinout is the following:

1<-->4

2<-->5

4<-->1

5<-->2

 

Try it and let us know

 

HTH

 

Regards

 

Carlo

Please rate all helpful posts "The more you help the more you learn"

View solution in original post

13 REPLIES 13
Highlighted

Hi Jochen,correct.Until the

Hi Jochen,

correct.

Until the ISDN layer 2 will stay "TEI ASSIGNED" you will see mgcp endpoints unregistered on CUCM

 

 

HTH

 

Regards

 

Carlo

Please rate all helpful posts "The more you help the more you learn"
Highlighted
Hall of Fame Cisco Employee

Carlo, forget layer 2, layer

Carlo, forget layer 2, layer 1 is shutdown, make sure cables are the right ones, and that they are live.

http://docwiki.cisco.com/wiki/Voice_Gateways_FAQ#How_to_check_MGCP_registration.3F.3F

HTH

java

if this helps, please rate
Highlighted

Jaime, if layer 1 is up but

Jaime, if layer 1 is up but layer 2 remains , for some reason, down , MGCP endpoint will remain unregistered

 

As per document you posted

 

Your PRI will NEVER show up as registered in CUCM, once you plug in a live PRI in the card and Layers 1, 2 and 3 come up, it will register fine.

 

Cheers

 

Carlo

Please rate all helpful posts "The more you help the more you learn"
Highlighted
Hall of Fame Cisco Employee

Yes, I'm merely remarking

Yes, I'm merely remarking that on the output he posted, layer 1 is down, you need to fix that, before worrying about layer 2

HTH

java

if this helps, please rate
Highlighted

 I know :)   

 

I know :)

 

 

 

@inderpreetsingh23 

 

Bind commands has been already submitted.

If you see the output of the show isdn status he posted the Layer3 is controlled by CUCM

 

ISDN Serial0/0/0:15 interface
        dsl 0, interface ISDN Switchtype = primary-net5
        L2 Protocol = Q.921 0x0000  L3 Protocol(s) = CCM MANAGER 0x0003
    Layer 1 Status:
        SHUTDOWN
    Layer 2 Status:
        TEI = 0, Ces = 1, SAPI = 0, State = TEI_ASSIGNED

 

 

@johaas123

 

It depends of what kind of adapter you have on Telco device.

Can you describe it? (db-17 , baloon)

You can also try to send the model of telco device in order to find the correct adapter and pinout

Please let us know

 

 

Regards

 

Carlo

Please rate all helpful posts "The more you help the more you learn"
Highlighted
Beginner

controller e1 0/0/0 and int

controller e1 0/0/0 and int serial 0/0/0:15 are not administratively down just in normal down state. Looks like we do have a cabling issue.

The telco device is a Yeastar TE100. I assume it does SIP to the outside and isdn pri to our router.

 

Highlighted

Hi.So you need a E1 crossover

Hi.

So you need a E1 crossover cable.

The pinout is the following:

1<-->4

2<-->5

4<-->1

5<-->2

 

Try it and let us know

 

HTH

 

Regards

 

Carlo

Please rate all helpful posts "The more you help the more you learn"

View solution in original post

Highlighted
Beginner

Thank you for your assistance

Thank you for your assistance. As I am not onsite I will try to organize a cable with this pinout. I will inform you when it's done. Thank you!

Highlighted
Beginner

After connecting a cable with

After connecting a cable with correct pinout layer 1 went ACTIVE and GW registered at CUCM. Layer 2 was awaiting establishment. Then we adjusted some settings on our gateway and Telco site to get it synchronized. Thank you guys for your help!

Highlighted
Beginner

Okay so we have to check the

Okay so we have to check the cabling..? I guess there is a normal RJ45 patch cable connected between the providers box and our E1 interface card. I know Cisco uses pins 1,2 and 4,5. As we normally use always standard patch cables I wasn't thinking about layer 1 cabling issue.. Any suggestion which kind of cable we should try? This office is located in CZ. Btw. the provider says that their E1 is activated.

Highlighted
Hall of Fame Cisco Employee

Start by making sure your

Start by making sure your controller and serial interfaces are not shutdown, if they are up, and you still cannot get layer 1 up, do check the cable is the right one, and you're plugging it to the right E1 port, assuming you have more than one.

HTH

java

if this helps, please rate
Highlighted

Hi,Try the following:mgcp

Hi,

Try the following on your Router:

 

mgcp bind media source-interface <interface>

mgcp bind control source-interface <interface>

 

interface ser0/0/0:23 

isdn bind-l3 ccm-manager

Then reset your mgcp gateway

 

HTH

 

Highlighted
Beginner

These commands are set. And

These commands are set. And as it is a E1 it is interface s0/0/0:15 ;-)

CreatePlease to create content
Content for Community-Ad
Future of Work Virtual Summit Day 5

Cisco COVID-19 Survey