cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
918
Views
0
Helpful
6
Replies
Highlighted
Beginner

MGCP GW Fails to Register to CUCM

Hi,

I have a CUCM v10.5.1 and MGCP GW 2921 and 2911. I have tried on configuring the two as MGCP GWs but both could not be registered. 

 

Oct 16 09:48:20.947: MGCP Packet sent to 172.31.36.5:2427--->
RSIP 997524371 *@UAS_2911 MGCP 0.1
RM: restart
<---

Oct 16 09:48:20.947: MGCP Packet received from 172.31.36.5:2427--->
500 997524371 
<---

 

This is the output from the debug mgcp packet. 

 

 

ccm-manager fallback-mgcp 
ccm-manager mgcp
no ccm-manager fax protocol cisco
ccm-manager music-on-hold
ccm-manager config server 172.31.36.5  
ccm-manager config
!
mgcp
mgcp call-agent 172.31.36.5 2427 service-type mgcp version 0.1
mgcp rtp unreachable timeout 1000 action notify
mgcp modem passthrough voip mode nse
mgcp package-capability rtp-package
mgcp package-capability sst-package
mgcp package-capability pre-package
no mgcp package-capability res-package
no mgcp timer receive-rtcp
mgcp sdp simple
mgcp fax t38 inhibit
!
mgcp profile default

 

This is the config. 

 

I have already issued "no mgcp" and "mgcp" to initialize the mgcp service. Still doesn't work. Also tried upgrading the 2921 to a new and stable version. 

 

Hope someone can help me. 

 

Thank you.

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
Rising star

are you sure the domain name

are you sure the domain name is correctly configured in CUCM side?

also can you configure backup server and check if it is trying to register there?

command to add the backup server: ccm-manager redundant-host x.x.x.x

if no luck, try reloading the gateway once and check?

 

can you get the logs for show ccm-manager and debug mgcp packet in a file and attach it here?

//Suresh Please rate all the useful posts.

View solution in original post

6 REPLIES 6
Highlighted
Rising star

are you sure the domain name

are you sure the domain name is correctly configured in CUCM side?

also can you configure backup server and check if it is trying to register there?

command to add the backup server: ccm-manager redundant-host x.x.x.x

if no luck, try reloading the gateway once and check?

 

can you get the logs for show ccm-manager and debug mgcp packet in a file and attach it here?

//Suresh Please rate all the useful posts.

View solution in original post

Highlighted
Advisor

Hi, In addition to what

Hi,

 

In addition to what Suresh has asked,can u share the show run  as well?Are u using BRI or PRI?

regds,

aman

Highlighted
Beginner

on the 2921, I am using PRI.

on the 2921, I am using PRI. On the 2911, I am using FXO. When I was doing the PoC, I also used this same 2911 as the MGCP GW and I didn't have a problem back then. But it was a different server. I don't know what's with this new server that it won't work.

Highlighted
Beginner

solved! solution is to ping

solved!

 

solution is to ping the GW from the CUCM OS.

Highlighted

Check that you configure the

Check that you configure the correct voice port module on CUCM, "show inventory/ show diag" will help you.

What is the voice port that you try to register.

Provide The Whole Show Runn. and The Below Show Commands:
- show ccm-manager
- show mgcp
- show mgcp endpoint
- show mgcp connection
- show mgcp statistics


Shutdown and Enable the Voice Ports.

Highlighted
Beginner

sorry, wrong click. still not

sorry, wrong click. still not answered.

 

 

regarding your question, I did not use DNS client on the CUCM.