cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
1437
Views
0
Helpful
14
Replies
Highlighted
Enthusiast

MGCP or H323??

Hello,

I have 3 sites connected to one main site (all using cme).Main site has 12 FXO Ports. Now i want to connect that main site with our HQ CUCM. Which protocol do i need to use? and why any idea???

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted

It is not done adding interfaces, but dial-peers.

It is a normal configuration.

You should not ever use MGCP.

View solution in original post

14 REPLIES 14
Highlighted
Contributor

Hello,

You have not mentioned any details with regards to main site. Are you connecting another CME from main site or a Voice GW?

If I presume a Voice GW at main site, you can utilize MGCP if you would like to have complete control from CUCM (HQ).


Regrds...

-Ashok.


With best regards...
Ashok
Highlighted

Main site is running CME itself. sO it has already one h323 interface. I dont think so that i can add two h323 interaces in one router one for local phones and other for CUCM ?

Highlighted

It is not done adding interfaces, but dial-peers.

It is a normal configuration.

You should not ever use MGCP.

View solution in original post

Highlighted

Can you please give me a clue or example of what type of Dial-peer we require without binding the virtual interface via using h323???

Highlighted

Something like this should work:

voice class codec 1

codec preference 1 g711ulaw

codec preference 2 g711alaw

codec preference 3 g729r8

codec preference 4 g729br8

!

dial-peer voice 101 voip

description CallManager Publisher

preference 2

destination-pattern 1...

voice-class codec 1

session target ipv4:10.1.1.1

dtmf-relay h245-alphanumeric

!

dial-peer voice 102 voip

description CallManager Subscriber

preference 1

destination-pattern 1...

voice-class codec 1

session target ipv4:10.1.1.2

dtmf-relay h245-alphanumeric

!

It assmumes that you have two CUCM servers - a Publisher with IP address 10.1.1.1, a Subscriber 10.1.1.2 - and that the CallManager extensions are four digits starting with a 1.

Highlighted

thnx v much for your info.

I just googled and came to know that in order to h323 protocol on gateway, we dont need the h323-gateway voip interface command to register h323 gateways to Call Manager, only needed the h323-gateway source address command.

But i am gettting below error whenever i put h323-gateway voip bind srcaddr X.X.X.X command under loopback interface.

Bind IP Address configured. Please remove before reconfiguring

Highlighted

Would you please upload the " sh run" from the GW.

Highlighted

The command is not need unless you have multiple interfaces.

Highlighted

answered in the other post

Highlighted

ip dhcp excluded-address 10.5.83.100 10.5.83.254

ip dhcp excluded-address 10.5.81.0 10.5.81.254

!

ip dhcp pool VOICE

network 10.5.82.0 255.255.254.0

default-router 10.5.83.254

option 150 ip 10.5.83.254

!

ip dhcp pool DATA

network 10.5.80.0 255.255.254.0

default-router 10.5.81.254

dns-server 212.76.68.200 212.76.68.201

!

interface GigabitEthernet0/0.20

encapsulation dot1Q 20

ip address 10.5.83.254 255.255.254.0

ip nbar protocol-discovery

ip flow ingress

ip flow egress

h323-gateway voip interface

h323-gateway voip bind srcaddr 10.5.83.254

!

interface Loopback10 ( here i want to put h323 command in order to get connected with cucm)

ip address 172.16.250.150 255.255.255.252

!

telephony-service

no auto-reg-ephone

max-ephones 64

max-dn 65

ip source-address 10.5.83.254 port 2000

max-conferences 8 gain -6

transfer-system full-consult

secondary-dialtone 9

!

Highlighted

interface GigabitEthernet0/0.20

no h323-gateway voip bind srcaddr 10.5.83.254

interface Loopback10

h323-gateway voip bind srcaddr 172.16.250.150

that's only

Highlighted

I dont want to remove that h323 bind (this is for other cme's). I want to add one more h323 in order to connect cucm.

Highlighted

this command enable you to source h323 traffic with a specific ip add

It help in defining ur security policy to this specific IP

from my understanding, you need to use the same cme as h323 gw in many cucms

so why you don't use the same ip add as h323 gw in all the cucms

Highlighted

Don't think you can not have more than one bind cmd on one GW.