cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
7569
Views
10
Helpful
21
Replies
keanej
Participant

MGCP Pri in Germany - DDI Problem -

I am having a problem with a PRI in Berlin, Germany.

People can ring from mobiles fine but when they ring from German landlines it fails.

So lets say the main number is 220 83720

The DDIs are 220 83720 01 - 99

Its a bit weird but basically the PRI is 8 digits and the extensions are 10 digits.

The main number works, but when you dialled a DDI say ending in 10, we were seeing 220 83721.

Now whats a bit wacky - it all works grand from a mobile, its only German landlines...

Now I configured

interface Serial0/0/0:15
isdn overlap-receiving

and I have enabled the 'Overlap receiving flag for PRI' in the service parameters.

Any ideas ??? Apparently its related to enbloc and overlap dialling.

Anyhelp greatly appreciated ..

FYI : The Telco have said

They found out that it always works when using Blockwahl and that it never works when using Einzelwahl. If you dial the number including the extension in one block (which is the case when you have the number registered on your phone (either Festnetz or mobile) then you always get through directly to the member of staff. If however you pick up the receiver and dial each number individually (Einzelwahl) then the call is interrupted after 030/220721- when dialing the next digit.

The cisco engineers have to configure the phone system in such a way that you can use Einzelwahl i.e. the system waits until all the digits are dialled/until the dialling is complete.

Deutsche Telekom cannot switch all incoming calls to enblock dialling because this is technically not possible.

Mr XXXX said something about this problem ocurring often with Cisco IP. Apparently Cisco IP is sometimes using a U.S. standard with certain timer settings that don't match with the German Telekom system. He said it would be best to ask the technicians at Cisco. They should be familiar with this problem and might know a solution.

21 REPLIES 21
Adam Thompson
Enthusiast

I have seen this problem before, but our gateway was H.323 instead of MGCP. Have you tried manipulating the t302 timer on the ISDN overlap-receiving command? I would think it works the same way if it is applied to the D-channel of the PRI.

Syntax: isdn overlap-receiving t302 <

Example: isdn overlap-receiving t302 2000

Thanks,

Adam

Please rate if helpful

I tried that .. no joy - but thanks for giving it a go !!

Basically I am missing the last digit - I am not seeing it on the gateway when overlap dialling is being used. When enbloc dialling is used it works fine.

Here is the config - but I believe much of this is only used in H323 mode - I'm using MGCP and Backhaul. I have also included the call manager mgcp config in a file.

Many thanks for the help.


!
controller E1 0/0/0
pri-group timeslots 1-31 service mgcp
description Full PRA XXXXXXX
!

interface Serial0/0/0:15

no ip address

encapsulation hdlc

isdn switch-type primary-net5

isdn overlap-receiving T302 2000

isdn incoming-voice voice

isdn bind-l3 ccm-manager

no cdp enable

!
voice-port 0/0/0:15
translation-profile incoming Trans-From-PSTN
translation-profile outgoing OutboundCallerPresentation
cptone DE
!

dial-peer voice 9 pots
description Dial 9 for PSTN
preference 1
destination-pattern 9T
incoming called-number .
fax rate disable
direct-inward-dial
port 0/0/0:15

By the way I have tried setting the service parameters

ccm service parameter - "Discard Non Inband Progress in Overlap Sending" to true.

ccm service parameter - "Overlap Receiving Flag for PRI" to true.

javascript:getHelp('OverlapReceivingForPriFlag')

Any ideas ??

The missing piece of the puzzle was

significant digits inbound must be set to ALL

also we had to reboot all the  call managers to get the

'Overlap Receiving Flag for PRI' enterprise setting to work ..  :-(

joanesga1
Beginner

Hi

I have exactly the same problem on a PRI in Germany.

I have pointed Cisco TAC to your post.


Can you confirm which steps were required to resolve the issue ?

The service parameter for overlap receiving was already set to true.
I have then added overlap receiving to the serial interface

interface Serial0/1/0:15
no ip address
encapsulation hdlc
isdn switch-type primary-net5
isdn overlap-receiving T302 2000
isdn incoming-voice voice
isdn bind-l3 ccm-manager
isdn bchan-number-order ascending
isdn sending-complete
no cdp enable

I did have significant digits set to 4 - (last 4 to matchDN) but have changed this to all...

Was this everything ?

Many thanks for your post

Hello,

here is a nice document which describes the problem:

http://www.cisco.com/warp/public/788/signalling/isdn_overlap_prob.pdf

I recommend to set the overlap receiving timer to 5000.

Also create a Translation Pattern which translates the number for example 030555.XXX (preDot discard) to the internal DN 912XXX.

Do not use the significant digits, because (mostly) in germany the 030555.0 is the number of the assistant =>

(0305550. (preDot discard) to internal 921100)

Kind regards,

Marcel Ammann

Many thanks Marcel

Issue is fixed

Summary of changes / config used to resolve issue..

changed T302 timer to 6000 (as below) and ensured overlap receiving enabled in CM service parameters (MGCP)

interface Serial0/1/0:15
no ip address
encapsulation hdlc
isdn switch-type primary-net5
isdn overlap-receiving T302 6000
isdn incoming-voice voice
isdn bind-l3 ccm-manager
isdn send-alerting
isdn bchan-number-order ascending
isdn sending-complete
no cdp enable

Set E1 contoller to ALL significant digits in call manager

Added Translation in CM to 123.XXXX to then match DN XXXX

Used T in incoming dial peer to ensure timer used

dial-peer voice 1 pots
description DID processing peer
incoming called-number 123T
direct-inward-dial

Tested OK - Debug now shows additional missing digits being received
need debug isdn q931 and debug voip ccapi inout

This was a bit of a nightmare for us to be honest. The issue was that the extension digits were being sent in messages after connection in setup messages, rather than a typical dialled number.

The Three Things I needed to do to fix it were

!

1:

You need to set the Signigicant digits to all and the Prefix DN Blank.

If you point the CSS at a limited area you can process the digits in a custom manner

!

2:

System | Service Parameter | Server | Service:Cisco Call Manager | Overlap Receiving Flag for PRI = True

Change on all Call Managers - Reboot all call managers.

!

!

3:
controller E1 0/0/0
pri-group timeslots 1-31 service mgcp
!
interface Serial0/0/0:15
no ip address
encapsulation hdlc
isdn switch-type primary-net5
isdn overlap-receiving T302 2000
isdn incoming-voice voice
isdn bind-l3 ccm-manager
no cdp enable

!

Thats what we ended up doing - hope that helps

James

PS: This is a bug, if sigificant digits is set - it is only processing connection digits rather than dialled digits - Cisco TAC view it as a config quirk - I disagree - it should be fixed in maintenance release.

Thanks James

Fortunately I didnt need to reboot the call maangers as the service parameter was already set to true

I agree the Significant digits field issue should be fixed....

I have asked tac to review this post and create documentation for others - as we only resolved this by finding your original post..

regards

Graham

Hi All -

I have this exact issue with a site in Germany using an MGCP gateway. My problem is I cannot get the last digit to come in. When I do a debug ISDN q931 I see the following:

Sep  7 08:31:36 UTC: ISDN Se1/1:15 Q931: RX <- SETUP pd = 8  callref = 0x0101

        Bearer Capability i = 0x8090A3

                Standard = CCITT

                Transfer Capability = Speech

                Transfer Mode = Circuit

                Transfer Rate = 64 kbit/s

        Channel ID i = 0xA18392

                Preferred, Channel 18

        Progress Ind i = 0x8183 - Origination address is non-ISDN

        Calling Party Number i = 0x2180, '61964728442'

                Plan:ISDN, Type:National

        Calling Party Number i = 0x2183, '619647280'

                Plan:ISDN, Type:National

        Called Party Number i = 0xC1, '907582'

                Plan:ISDN, Type:Subscriber(local)

Sep  7 08:31:36 UTC: ISDN Se1/1:15 Q931: TX -> RELEASE_COMP pd = 8  callref = 0x 8101

        Cause i = 0x8081 - Unallocated/unassigned number

The DN on the phone is 6735824 and as you can see I am missing the last digit.

Heres what I have done so far:

Set the t302 timer to 5000. - no change

Removed the Significant digits and also the Prefix DN - still no change and also this stops all other calls from working so had to put this back on.

Can someone explain how I get the last digit to be sent to my gateway?

Hi Shane

Did you also set the service parameter to enable overlap receiving ?

Regards

Graham

Hi Graham,

Yes I have enabled this on the call manager servers already... I think my problem is in regards to the translation pattern?

Have you set incoming dial peer eg..

* Used T in incoming dial peer to ensure timer

used

dial-peer voice 1 pots

description DID processing peer

incoming called-number 123T

direct-inward-dial

translation then needed to match received digits in CM if 4 digit ext

eg 123XXXX > XXXX

I do not have a dial peer as I am using MGCP...

Create
Recognize Your Peers
Content for Community-Ad