cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
68
Views
5
Helpful
3
Replies
Highlighted
Beginner

Mulitcast

Hello Everyone,

 

I have just enabled multicast on my routers for our voice paging system and everything seems to work fine.  However, I'm afraid I maybe missing some commands I could use to prevent multicast traffic from being generated to other interfaces that are not needed.  I was looking at this command "ip pim passive"

 

Do you think I should enable this command in all the interfaces that are not required to have multicast traffic ?

 

Thanks to all in advanced!

 

Here is my router config:

 

Rainbow-4331RTR#sh run
Building configuration...


Current configuration : 9066 bytes
!
! Last configuration change at 07:15:34 pdt Tue Jun 18 2019 by cruza
! NVRAM config last updated at 11:52:36 pdt Mon Jun 17 2019 by cruza
!
version 15.5
no service pad
service tcp-keepalives-in
service tcp-keepalives-out
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
no platform punt-keepalive disable-kernel-core
platform hardware throughput level 300000
!
hostname 4331RTR
!
boot-start-marker
boot system flash bootflash:isr4300-universalk9.03.16.05.S.155-3.S5-ext.SPA.bin
boot-end-marker
!
!
vrf definition Mgmt-intf
!
address-family ipv4
exit-address-family
!
address-family ipv6
exit-address-family
!
security authentication failure rate 4 log
logging buffered informational
logging console informational
logging monitor informational

!
aaa new-model
!
!
aaa authentication login default group radius local
aaa authorization exec default group radius local
!
!
!
!
!
!
aaa session-id common
clock timezone pst -8 0
clock summer-time pdt recurring
no ip source-route
!
ip multicast-routing distributed
!
!
!
!
!
!
!
!
!
!


no ip bootp server

 

!
!
!
login block-for 100 attempts 6 within 60
login on-failure log
login on-success log
!
!
!
!
!
!
!
subscriber templating
multilink bundle-name authenticated
!
flow record qradar_r1
match ipv4 tos
match ipv4 protocol
match ipv4 source address
match ipv4 destination address
match transport source-port
match transport destination-port
collect counter bytes long
collect counter packets long
!
!

!

!
!
!
!
!
license udi pid ISR4331/K9 sn FDO21151380
archive
log config
logging enable
logging size 200
notify syslog contenttype plaintext
hidekeys
!
spanning-tree extend system-id
!

redundancy
mode none
!
!
!
!
class-map match-all Staff
match access-group name Staff
class-map match-all Voice
match access-group name Voice
!
policy-map LLQ
class Voice
priority 2000
class Staff
bandwidth 4000
class class-default
fair-queue
!
!
!
!
!
!
interface Loopback0
no ip address
!
interface GigabitEthernet0/0/0
bandwidth 100000
ip address xx.xx.2.98 255.255.255.0
no ip redirects
ip pim sparse-dense-mode
ip flow monitor FLOW-MONITOR-1 input
ip flow monitor FLOW-MONITOR-1 output
speed 100
no negotiation auto
service-policy output LLQ
!
interface GigabitEthernet0/0/1
no ip address
shutdown
negotiation auto
!
interface GigabitEthernet0/0/2
no ip address
ip helper-address xx.xx.64.91
no ip redirects
no ip unreachables
no ip proxy-arp
negotiation auto
!
interface GigabitEthernet0/0/2.10
description *** WIRED_ELECTION ***
encapsulation dot1Q 10
ip address xx.xx.98.1 255.255.255.0
ip helper-address 204.62.64.91
!
interface GigabitEthernet0/0/2.98
description ***Data ***
encapsulation dot1Q 98
ip address xx.xx.98.1 255.255.255.0
ip helper-address xx.xx.64.91
ip directed-broadcast 117
!
interface GigabitEthernet0/0/2.298
description *** Managemen***
encapsulation dot1Q 298 native
ip address xx.xx.98.1 255.255.255.0
!
interface GigabitEthernet0/0/2.403
description *** Voice ***
encapsulation dot1Q 403
ip address xx.xx.98.1 255.255.255.0
ip pim sparse-dense-mode
!
interface GigabitEthernet0
vrf forwarding Mgmt-intf
ip address 10.1.1.57 255.255.255.0
negotiation auto
!
!
router eigrp 10450
network xx.xx.98.0 0.0.0.255
network xx.xx.98.0 0.0.0.255
network xx.xx.2.0
network xx.xx.98.0
network xx.xx.98.0
passive-interface GigabitEthernet0/0/2
no eigrp log-neighbor-changes
!
ip forward-protocol nd
ip forward-protocol udp echo
ip forward-protocol udp discard
ip pim rp-address xx.xx.76.1
no ip http server
no ip http secure-server
ip ssh version 2
!
!


s
!
!
control-plane
!


!
ntp server 10.10.10.15
!
end

Rainbow-4331RTR#

1 ACCEPTED SOLUTION

Accepted Solutions
VIP Advisor

Re: Mulitcast

This command will stop the router from sending or accepting pim messages on
that interface making the router as pim DR. However, routers don't flood
multicast traffic out of all interfaces as switches. It floods multicast
based on pim trees and groups. therefore you shouldn't be concerned about
the router flooding multicast of all interfaces if you don't have pim
neighbors.

On the other hand, at the LAN you need to use IGMP snooping to prevent
flooding multicast of all interfaces within a vlan because switches do
flood by default.
3 REPLIES 3
VIP Advisor

Re: Mulitcast

This command will stop the router from sending or accepting pim messages on
that interface making the router as pim DR. However, routers don't flood
multicast traffic out of all interfaces as switches. It floods multicast
based on pim trees and groups. therefore you shouldn't be concerned about
the router flooding multicast of all interfaces if you don't have pim
neighbors.

On the other hand, at the LAN you need to use IGMP snooping to prevent
flooding multicast of all interfaces within a vlan because switches do
flood by default.
Beginner

Re: Mulitcast

Thanks Mohammed!  I appreciate the feedback!

VIP Advisor

Re: Mulitcast

No worries, please remember to rate useful posts and marking resolved
queries as answered :)
CreatePlease to create content
Content for Community-Ad
July's Community Spotlight Awards