cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
Walkthrough Wednesdays
1687
Views
0
Helpful
5
Replies
Highlighted

My MoH not work for PSTN

Hi everybody,

I need to help,

I have CUCM 7.1 in my environment, but MOH calls internally normally more calls of the PSTN does not work in Hold (3 BEP).

-------------                            -----------------

| CUCM | --------------->G0/0 --| Gateway  |-(E1)-----------------|PSTN|.

-------------                  (h323)  --------------   ( MGCP)

interface GigabitEthernet0/0

XXXXX SKIPPED XXXXXXXX                       

h323-gateway voip interface

Help-me.

Thanks all.

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted

if the codec for the call from the GW to the MOH server is g729

go to Service Parameters and choose

Cisco IP Voice Media Streaming App from the Service pull down menu

Under Clusterwide Parameters, select the codecs that you want supported for MoH.

hold the Ctrl key and select g711 and g729

however if you want your MOH to be g711 only and calls to be g729 you can do that, see the bellow link ( although it is for a older CM version but the config and idea still amost the same )

http://www.cisco.com/en/US/products/sw/voicesw/ps556/products_configuration_example09186a00803f8950.shtml

HTH

if helpful Rate

View solution in original post

5 REPLIES 5
Highlighted

what is the GW model and IOS version ?

is the device pool and moh source configured in the GW settings ?

you configure the moh source using common device configuration

is the MRGL with MRG assigned to the GW/device pool with MOH server ?

what is the codec for calls from the GW to the MOH server ?

Highlighted

Hi Marwanshawi,

GW=Cisco 2851 - Ok

IOS=c2800nm-advipservicesk9-mz.124-2.T3 - Ok

Device Pool and Moh Source configured in gw settings - Not configured.

MRGL with MRG assigned to GW / Device Pool with Moh - OK.

My codec for call = uLaw/aLaw/g729

--------------------------------------------------------------------------------------------------------------------------------------------

There was GW Settings set the "Device Pool", more tone now have none. (silence).

Is there anything else I can do?

Thanks =) There was GW Settings set the "Device Pool", more tone now have none. (silence).
Is there anything else I can do?

Thanks =)

Highlighted

if the codec for the call from the GW to the MOH server is g729

go to Service Parameters and choose

Cisco IP Voice Media Streaming App from the Service pull down menu

Under Clusterwide Parameters, select the codecs that you want supported for MoH.

hold the Ctrl key and select g711 and g729

however if you want your MOH to be g711 only and calls to be g729 you can do that, see the bellow link ( although it is for a older CM version but the config and idea still amost the same )

http://www.cisco.com/en/US/products/sw/voicesw/ps556/products_configuration_example09186a00803f8950.shtml

HTH

if helpful Rate

View solution in original post

Highlighted

I did the steps mentioned but not get the result, in making connections outside waiting to hear the music.
help me on the part of the "GW Settings" I am performing the following steps.

CM Administrator
Device> Gateway> status I click on "see Endpoint" and shows me my device type "MGCP"
put in Device Pool "test_codec" and Media Resource Group List = MOH_PSTN.

You need some configuration on the router?


Thank you for your attention

Highlighted

Hi,

MoH is running fine after setting the GW, it lacked some features that set was not include.

Thanks for the support =).

Content for Community-Ad