cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
Walkthrough Wednesdays
1366
Views
0
Helpful
11
Replies
michaeljbyrne
Beginner

need some help with dial-peers

   Office is in south ameriaca

h323 gaetway

extensions are 4XXXX so when I call in it's 901155114505XXXX

Same with outbound

I have my 2 voip dialpeers with the target of my 2 CCM's in the cluster

My debug shows the call comming in with the  last 4 digits of the full number

ON CUCM on the h323 gateway I have 4 as the prefix

dial-peer voice 1 pots

description *** Incoming via PRI ***

incoming called-number .

direct-inward-dial

port 0/0/0:1

!

dial-peer voice 100 voip

preference 1

destination-pattern 4....

session target ipv4:10.XXX.XXX.XXX

voice-class h323 1

!

dial-peer voice 101 voip

preference 2

destination-pattern 4....

session target ipv4:10.XXX.XXX.XXX

!

11 REPLIES 11
Amer rajai Sha'er
Rising star

Hello,

Do you have a problem with incoming calls ?

If this is the case , just add the command dtmf-relay h245-alphanumeric to the voip dial-peer , i can't see anything else wrong ?

Amer

ok,

I added it

and still have a problem

Jun 23 18:42:04.331 EDT: //-1/DA03C7F68177/CCAPI/cc_api_call_setup_ind_common:

   Interface=0x3186F720, Call Info(

   Calling Number=001212XXXXXX,(Calling Name=)(TON=Unknown, NPI=Unknown, Screening=Not Screened, Presentation=Allowed),

   Called Number=3770(TON=Unknown, NPI=Unknown),

   Calling Translated=FALSE, Subscriber Type Str=Unknown, FinalDestinationFlag=TRUE,

   Incoming Dial-peer=1, Progress Indication=ORIGINATING SIDE IS NON ISDN(3), Calling IE Present=TRUE,

   Source Trkgrp Route Label=, Target Trkgrp Route Label=, CLID Transparent=FALSE), Call Id=-1

   Sub Calling(TON=Subscriber, NPI=National, Data=G()H#D(#D)HG()H(W)HG0, Length=41)

   Sub Called(TON=National, NPI=National, Data=W)HG0, Length=8)

Jun 23 18:42:04.331 EDT: //-1/DA03C7F68177/CCAPI/ccCheckClipClir:

   In: Calling Number=001212XXXX(TON=Unknown, NPI=Unknown, Screening=Not Screened, Presentation=Allowed)

Jun 23 18:42:04.331 EDT: //-1/DA03C7F68177/CCAPI/ccCheckClipClir:

   Out: Calling Number=0012128873000(TON=Unknown, NPI=Unknown, Screening=Not Screened, Presentation=Allowed)

Jun 23 18:42:04.331 EDT: //-1/xxxxxxxxxxxx/CCAPI/cc_get_feature_vsa:

Jun 23 18:42:04.331 EDT: :cc_get_feature_vsa malloc success

Jun 23 18:42:04.331 EDT: //-1/xxxxxxxxxxxx/CCAPI/cc_get_feature_vsa:

Jun 23 18:42:04.331 EDT:  cc_get_feature_vsa count is 1

Jun 23 18:42:04.331 EDT: //-1/xxxxxxxxxxxx/CCAPI/cc_get_feature_vsa:

Jun 23 18:42:04.331 EDT: :FEATURE_VSA attributes are: feature_name:0,feature_time:700029872,feature_id:64

Jun 23 18:42:04.331 EDT: //64/DA03C7F68177/CCAPI/cc_api_call_setup_ind_common:

   Set Up Event Sent;

   Call Info(Calling Number=0012128873000(TON=Unknown, NPI=Unknown, Screening=Not Screened, Presentation=Allowed),

   Called Number=3770(TON=Unknown, NPI=Unknown))

Jun 23 18:42:04.331 EDT: //64/DA03C7F68177/CCAPI/cc_process_call_setup_ind:

   Event=0x29C70430

Jun 23 18:42:04.331 EDT: //-1/xxxxxxxxxxxx/CCAPI/cc_setupind_match_search:

   Try with the demoted called number 3770

Jun 23 18:42:04.331 EDT: //64/DA03C7F68177/CCAPI/ccCallSetContext:

   Context=0x2A175284

Jun 23 18:42:04.331 EDT: //64/DA03C7F68177/CCAPI/cc_process_call_setup_ind:

   >>>>CCAPI handed cid 64 with tag 1 to app "_ManagedAppProcess_Default"

Jun 23 18:42:04.331 EDT: //64/DA03C7F68177/CCAPI/ccCallProceeding:

   Progress Indication=NULL(0)

Jun 23 18:42:04.335 EDT: //64/DA03C7F68177/CCAPI/ccCallDisconnect:

   Cause Value=1, Tag=0x0, Call Entry(Previous Disconnect Cause=0, Disconnect Cause=0)

Jun 23 18:42:04.335 EDT: //64/DA03C7F68177/CCAPI/ccCallDisconnect:

   Cause Value=1, Call Entry(Responsed=TRUE, Cause

Jun 23 18:42:04.335 EDT: //64/DA03C7F68177/CCAPI/cc_api_get_transfer_info:

   Transfer Number Is Null

Can you please share the sh run , it looks to me that you have a problem with forwarding the call to the CUCM , the debug shows that it matches the incoming dial-peer but there is no outgoing dial-peer.

Amer

controller E1 0/0/0

framing NO-CRC4

ds0-group 1 timeslots 1-15,17-31 type r2-digital r2-compelled ani

!

voice-card 0

dspfarm

dsp services dspfarm

voice service voip

allow-connections h323 to h323

allow-connections h323 to sip

fax protocol t38 ls-redundancy 0 hs-redundancy 0 fallback none

h323

  h225 h245-address on-connect

!

voice class h323 1

interface Loopback1

description VOIP LOOPBACK

ip address 10.84.191.63 255.255.255.255

no ip redirects

ip ospf cost 100

ip ospf hello-interval 3

ip ospf retransmit-interval 3

h323-gateway voip interface

h323-gateway voip bind srcaddr 10.84.191.63

voice-port 0/0/0:1

!

no ccm-manager fax protocol cisco

!

no mgcp package-capability res-package

no mgcp package-capability fxr-package

no mgcp timer receive-rtcp

!

sccp local Loopback1

sccp ccm 10.84.122.11 identifier 1 version 7.0

sccp ccm 10.84.95.229 identifier 2 version 7.0

sccp ip precedence 3

sccp

!

sccp ccm group 1

associate ccm 1 priority 1

associate ccm 2 priority 2

associate profile 1 register VGR1-SAO_CFB

keepalive retries 5

switchback method graceful

!

dspfarm profile 1 conference

description VGR1-SAO_CFB

associate application SCCP

shutdown

!

dial-peer voice 1 pots

description *** Incoming via PRI ***

incoming called-number .

direct-inward-dial

port 0/0/0:1

!

dial-peer voice 100 voip

preference 1

destination-pattern 4....

session target ipv4:10.XX.XX.XX

voice-class h323 1

dtmf-relay h245-alphanumeric

!

dial-peer voice 101 voip

preference 2

destination-pattern 4....

session target ipv4:10.XX.XX.XX

dtmf-relay h245-alphanumeric

!

Thats about all I can show you....

Hello,

This is all what i need.

To be straight , you are calling from outside , so the call come in to the PRI , i don't see any translation or plar on the voice-port , is this mean that the number you are calling is DID ???

The voip dial-peer shows a destination-pattern 4.... , this means that the number that arrived from the PSTN (PRI) should only be 4.... , so i suggest for troubleshooting to add the following command to the voice-port config:

connection-plar "extension" which should be 41234 something.

also add to the voip dial-peers this command :

no vad

Amer

Correct,

DID numbers which end in 3XXX however my extension sin call manager are 43XXX

Ok so I added the connection plar and it worked along with the no vad on the dial peer voip

reat , this means that the numbers arriving from the PSTN is not the same as the destin-pattern so do this :

connection plar 4... and test on more than one number and let me know how it will go.

Amer

Hello,

In order to match the destination-pattern with a number , the called number from the PRI should be exactly the same , so can you do a debug isdn q931 so we can see what is the number arriving to the PRI interface so we can solve this.

Amer

It's an E1 r2 not a PRI

You need to add a translation-rule to add the 4 in front.

voice translation-rule 100

     rule 1 /^\(3...\)$/ /4\1/

voice translation-profile Inbound

     translate called 100

dial-peer voice 1 pots

     translation-profile incoming Inbound

Content for Community-Ad

Spotlight Awards 2021

This widget could not be displayed.