cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1646
Views
0
Helpful
8
Replies

NIC config of VMware installation of Call Manager

David Hunt
Beginner
Beginner

System version: 8.6.2.22900-9


VMware Installation: 1 vCPU Intel(R) Xeon(R) CPU E5-2609 0 @ 2.40GHz, disk 1: 80Gbytes, 4096Mbytes RAM

A few month ago we had a vendor come in and upgrade our old VOIP system with a VMware solution of Call Manager. Versions are shown above.

I use Veeam to backup these VM's and it was taking hours to finsih so I starting digging into VCenter to look at the netwroking setup.

Even though the server has gigabit ethernet cards they "hard coded" the speed down to 100 Meg and changed the duplex to half.

Does anyone know of any reason why they might have done that? Will it fail if I change the speed to GB and utilze full duplex?

thanks...

1 Accepted Solution

Accepted Solutions

Actually, according to CUCM 9.1 (and 8.6) installation guide @

http://www.cisco.com/en/US/docs/voice_ip_comm/cucm/virtual/CUCM_BK_CA526319_00_cucm-on-virtualized-servers.pdf

"You should configure the same NIC settings on the server and on the switch port. For GigE (1000/FULL), you should set NIC and switch port settings to Auto/Auto; do not set hard values."

I have done 100+ virtual CUCM deployments and always use Auto across the board (Application, Hypervisor, Switchport). At this point, I would probably try the Hypervisor and Switchport hardcoded at 1000/Full to match CUCM. Check interface counters and watch for errors and runts.

I can't recommend mismatching CUCM at 1000/Full and Hypervisor/Switchport at Auto. It's not something I have ever done and YMMV.

Changing CUCM back to Auto would require a license change...if it comes to that have you integrator come back correct their installation.

View solution in original post

8 Replies 8

joe.lazzaro
Enthusiast
Enthusiast

Absolutely no reason to have the NICs hardcoded to 100/half. I would personally just leave them at Auto.

If you decide to hardcode 1000/full on the Hypervisor, make sure you hardcode the switch-side to the same settings otherwise you will still get half-duplex operation.

Thanks Joe,

through the command line interface, each of the 4 VM's

Call Manager 1

Call Manager 2

Cisco Emergengy Responder

Cisco Unified Messaging

are setup as below...

So, from Cisco Side, things look okay correct?

Yes that looks fine.

Just a tid-bit of information, if you were to change any eth0 settings within CUCM/UCxn/etc, your product licenses would become invalid. The system MAC address (which is used to license the product) is generated by hashing all the NIC specific information. Virtual server = no physical MAC of course.

Actually, according to CUCM 9.1 (and 8.6) installation guide @

http://www.cisco.com/en/US/docs/voice_ip_comm/cucm/virtual/CUCM_BK_CA526319_00_cucm-on-virtualized-servers.pdf

"You should configure the same NIC settings on the server and on the switch port. For GigE (1000/FULL), you should set NIC and switch port settings to Auto/Auto; do not set hard values."

I have done 100+ virtual CUCM deployments and always use Auto across the board (Application, Hypervisor, Switchport). At this point, I would probably try the Hypervisor and Switchport hardcoded at 1000/Full to match CUCM. Check interface counters and watch for errors and runts.

I can't recommend mismatching CUCM at 1000/Full and Hypervisor/Switchport at Auto. It's not something I have ever done and YMMV.

Changing CUCM back to Auto would require a license change...if it comes to that have you integrator come back correct their installation.