cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
Walkthrough Wednesdays
1914
Views
0
Helpful
6
Replies
Highlighted
Beginner

no dial tone at fxs port (pots)

hi there,

firstly i apologise for my bad English.

i have a 2611XM router with 4 PORT Voice PM for C2600 Port adapter with 2 FXO slots and 2 FXS slots.

firstly i want to attach a regular telephone to FXS port and redirect to a sip server. secondly i want to attach a line from pbx and redirect to sip server and vice verse (linking phones and regular phones).

however i failed at my first aim. i can not get a dial tone. i tried several things that i found at forums and cisco documents. however they do not work.

please help me for understand why is not working?

the configuration:

ios version:

Cisco Internetwork Operating System Software

IOS (tm) C2600 Software (C2600-IS-M), Version 12.3(22), RELEASE SOFTWARE (fc2)

Technical Support: http://www.cisco.com/techsupport

Copyright (c) 1986-2007 by cisco Systems, Inc.

Compiled Wed 24-Jan-07 16:48 by ccai

Image text-base: 0x80008098, data-base: 0x81AB3AD4

ROM: System Bootstrap, Version 12.2(7r) [cmong 7r], RELEASE SOFTWARE (fc1)

ROM: C2600 Software (C2600-IS-M), Version 12.3(22), RELEASE SOFTWARE (fc2)

RouterVoice uptime is 4 hours, 24 minutes

System returned to ROM by reload

System image file is "flash:c2600-is-mz.123-22.bin"

cisco 2611XM (MPC860P) processor (revision 0x100) with 61440K/4096K bytes of memory.

Processor board ID JAE07230AVT (3122572197)

M860 processor: part number 5, mask 2

Bridging software.

X.25 software, Version 3.0.0.

2 FastEthernet/IEEE 802.3 interface(s)

4 Serial(sync/async) network interface(s)

2 Voice FXO interface(s)

2 Voice FXS interface(s)

32K bytes of non-volatile configuration memory.

49152K bytes of processor board System flash (Read/Write)

Configuration register is 0x2102

voiceport:

Foreign Exchange Station 1/1/0 Slot is 1, Sub-unit is 1, Port is 0

Type of VoicePort is FXS

Operation State is DORMANT

Administrative State is UP

The Last Interface Down Failure Cause is Administrative Shutdown

Description is not set

Noise Regeneration is enabled

Non Linear Processing is enabled

Non Linear Mute is disabled

Non Linear Threshold is -21 dB

Music On Hold Threshold is Set to -38 dBm

In Gain is Set to 0 dB

Out Attenuation is Set to 3 dB

Echo Cancellation is disabled

Echo Cancellation NLP mute is disabled

Echo Cancellation NLP threshold is -21 dB

Echo Cancel Coverage is set to 8 ms

Echo Cancel worst case ERL is set to 6 dB

Playout-delay Mode is set to adaptive

Playout-delay Nominal is set to 60 ms

Playout-delay Maximum is set to 200 ms

Playout-delay Minimum mode is set to default, value 40 ms

Playout-delay Fax is set to 300 ms

Connection Mode is normal

Connection Number is not set

Initial Time Out is set to 10 s

Interdigit Time Out is set to 10 s

Call Disconnect Time Out is set to 60 s

Supervisory Disconnect Time Out is set to 750 ms

Ringing Time Out is set to infinity

Wait Release Time Out is set to 30 s

Companding Type is u-law

Region Tone is set for TR

Analog Info Follows:

Currently processing none

Maintenance Mode Set to None (not in mtc mode)

Number of signaling protocol errors are 0

Impedance is set to 600r Ohm

Station name None, Station number None

Caller ID Info Follows:

Standard ETSI

Output attenuation is set to 14 dB

Caller ID is transmitted after 1 ring(s)

Translation profile (Incoming):

Translation profile (Outgoing):

Voice card specific Info Follows:

Signal Type is loopStart

Ring Frequency is 50 Hz

Hook Status is On Hook

Ring Active Status is inactive

Ring Ground Status is inactive

Tip Ground Status is inactive

Digit Duration Timing is set to 100 ms

InterDigit Duration Timing is set to 100 ms

Hookflash-in Timing is set to 1000 ms

Hookflash-out Timing is set to 400 ms

No disconnect acknowledge

Ring Cadence is defined by CPTone Selection

Ring Cadence are [20 40] * 100 msec

Ringer Equivalence Number is set to 1

dialpeer:

VoiceEncapPeer1

        peer type = voice, information type = voice,

        description = `',

        tag = 1, destination-pattern = `10',

        answer-address = `', preference=0,

        CLID Restriction = None

        CLID Network Number = `'

        CLID Second Number sent

        CLID Override RDNIS = disabled,

        source carrier-id = `', target carrier-id = `',

        source trunk-group-label = `',  target trunk-group-label = `',

        numbering Type = `unknown'

        group = 1, Admin state is up, Operation state is up,

        Outbound state is up,

        incoming called-number = `', connections/maximum = 0/unlimited,

        DTMF Relay = disabled,

        huntstop = disabled,

        in bound application associated: 'DEFAULT'

        out bound application associated: ''

        dnis-map =

        permission :both

        incoming COR list:maximum capability

        outgoing COR list:minimum requirement

        Translation profile (Incoming):

        Translation profile (Outgoing):

        incoming call blocking:

        translation-profile = `'

        disconnect-cause = `no-service'

        advertise 0x40 capacity_update_timer 25 addrFamily 4 oldAddrFamily 4

        type = pots, prefix = `',

        forward-digits default

        session-target = `', voice-port = `1/1/0',

        direct-inward-dial = disabled,

        digit_strip = enabled,

        register E.164 number with GK = TRUE

        fax rate = system,   payload size =  20 bytes

        supported-language = ''

        Time elapsed since last clearing of voice call statistics never

        Connect Time = 0, Charged Units = 0,

        Successful Calls = 0, Failed Calls = 0, Incomplete Calls = 0

        Accepted Calls = 0, Refused Calls = 0,

        Last Disconnect Cause is "",

        Last Disconnect Text is "",

        Last Setup Time = 0.

dsp:

DSP  DSP             DSPWARE CURR  BOOT                         PAK     TX/RX

TYPE NUM CH CODEC    VERSION STATE STATE   RST AI VOICEPORT TS ABORT  PACK COUNT

==== === == ======== ======= ===== ======= === == ========= == ===== ============

C542 001 01 None      4.1.45 IDLE  idle      0  0 1/0/0     NA     0      609/627

C542 002 01 None      4.1.45 IDLE  idle      0  0 1/0/1     NA     0      596/593

C542 003 01 None      4.1.45 IDLE  idle      0  0 1/1/0     NA     0      605/614

C542 004 01 None      4.1.45 IDLE  idle      0  0 1/1/1     NA     0      599/609

6 REPLIES 6
Highlighted
Rising star

Can you post a "show voice port sum".

HTH

Regards,

Yosh

HTH Regards, Yosh
Highlighted

Kazim,

Firstly you should check you have the correct physical wiring.

FXS (RJ11) PIN 3 ----- RING -------------- PHONE

FXS (RJ11) PIN 4 ----- TIP ----------------- PHONE

http://www.cisco.com/en/US/tech/tk652/tk653/technologies_tech_note09186a0080094fac.shtml

Regards,
Alex.
Please rate useful posts.

Regards, Alex. Please rate useful posts.
Highlighted
Beginner

the output of

show voice port sum

                                     IN       OUT

PORT      CH   SIG-TYPE   ADMIN OPER STATUS   STATUS   EC

========= == ============ ===== ==== ======== ======== ==

1/0/0     --  fxo-ls      up    dorm idle     on-hook  y

1/0/1     --  fxo-ls      up    dorm idle     on-hook  y

1/1/0     --  fxs-ls      up    dorm on-hook  idle     n

1/1/1     --  fxs-ls      up    dorm on-hook  idle     y

i tried echo-cancel both n and y but it does't change anything.

cables works on wall port successfully.

and also there is a strange thing. while booting the in-use leds is on however then they are off.

when i attach both phone line (pots) and the line that come from pbx the lights are both on. however there is no dial tone and if i call outside the line, the pbx response that line is busy.

Highlighted

Hi Kazim,

Did u try connecting Analog Phone directly on ports of FXS cards , just to cross-check whether ports are working fine?

regds,

aman

Highlighted

Hi Kazim,

Have u configured DID on FXS ports? Try removing the command and check.

refer this URL:

http://www.cisco.com/en/US/tech/tk1077/technologies_tech_note09186a00800a4795.shtml

regds,

aman

Highlighted
Beginner

yes i attached to fxs ports straight. there is no did on the port.

when i attach the pbx line to the fxo port, and a i called the the phone, there is debug output such that:

000366: *Mar  1 05:32:32.078: C542 DPR1: D2H Msg: 000C 0080 00A1 0000 0004 1E00
000367: *Mar  1 05:32:32.078: htsp_dsp_message: SEND/RESP_SIG_STATUS: state=0x4 timestamp=7680 systime=1995208
000368: *Mar  1 05:32:32.078: htsp_process_event: [1/0/0, FXOLS_WAIT_RING_MIN, E_DSP_SIG_0100]fxols_ringing_disc
000369: *Mar  1 05:32:32.078: htsp_timer_stop 
000370: *Mar  1 05:32:32.078: TGRM: reg_invoke_tgrm_call_update(1, 0, 0, 0, 1, TGRM_CALL_IDLE, TGRM_CALL_VOICE, TGRM_DIRECTION_IN)
000371: *Mar  1 05:32:32.186: C542 DPR1: D2H Msg: 000C 0080 00A1 0000 0000 1E6E
000372: *Mar  1 05:32:32.186: htsp_dsp_message: SEND/RESP_SIG_STATUS: state=0x0 timestamp=7790 systime=1995218
000373: *Mar  1 05:32:32.186: htsp_process_event: [1/0/0, FXOLS_ONHOOK, E_DSP_SIG_0000]fxols_onhook_ringing
000374: *Mar  1 05:32:32.186: TGRM: reg_invoke_tgrm_call_update(1, 0, 0, 0, 1, TGRM_CALL_PENDING, TGRM_CALL_VOICE, TGRM_DIRECTION_IN)
000375: *Mar  1 05:32:32.186: htsp_timer - 125 msec
000376: *Mar  1 05:32:32.294: C542 DPR1: D2H Msg: 000C 0080 00A1 0000 0004 1EDC
000377: *Mar  1 05:32:32.298: htsp_dsp_message: SEND/RESP_SIG_STATUS: state=0x4 timestamp=7900 systime=1995230
000378: *Mar  1 05:32:32.298: htsp_process_event: [1/0/0, FXOLS_WAIT_RING_MIN, E_DSP_SIG_0100]fxols_ringing_disc
000379: *Mar  1 05:32:32.298: htsp_timer_stop 
000380: *Mar  1 05:32:32.298: TGRM: reg_invoke_tgrm_call_update(1, 0, 0, 0, 1, TGRM_CALL_IDLE, TGRM_CALL_VOICE, TGRM_DIRECTION_IN)
000381: *Mar  1 05:32:32.515: C542 DPR1: D2H Msg: 000C 0080 00A1 0000 0000 1FB8
000382: *Mar  1 05:32:32.515: htsp_dsp_message: SEND/RESP_SIG_STATUS: state=0x0 timestamp=8120 systime=1995251
000383: *Mar  1 05:32:32.523: htsp_process_event: [1/0/0, FXOLS_ONHOOK, E_DSP_SIG_0000]fxols_onhook_ringing
000384: *Mar  1 05:32:32.523: TGRM: reg_invoke_tgrm_call_update(1, 0, 0, 0, 1, TGRM_CALL_PENDING, TGRM_CALL_VOICE, TGRM_DIRECTION_IN)

when i attach both pots and pbx lines to the fxs ports i get these debug messages:

003218: *Mar  1 10:20:41.392: [1/1/1] set signal state = 0x4 timestamp = 750
003219: *Mar  1 10:20:41.392: dsp_set_sig_state: [1/1/1] packet_len=12 channel_id=129 packet_id=39 state=0x4 timestamp=0x2EE
003220: *Mar  1 10:20:41.392: dsp_soutput: [1/1/1]
003221: *Mar  1 10:20:41.392: C542 DPR3: H2D Msg: 000C 0081 0027 007D 0004 02EE
003222: *Mar  1 10:20:41.392: htsp_timer - 950 msec
003223: *Mar  1 10:20:41.664: C542 DPR3: D2H Msg: 000C 0080 00A1 0000 0004 EEA2
003224: *Mar  1 10:20:41.664: htsp_dsp_message: SEND/RESP_SIG_STATUS: state=0x4 timestamp=61090 systime=3724166
003225: *Mar  1 10:20:41.664: htsp_process_event: [1/1/0, FXSLS_OFFHOOK, E_DSP_SIG_0100]fxsls_offhook_onhook, HF duration=1000
003226: *Mar  1 10:20:41.668: htsp_timer - 1000 msec
003227: *Mar  1 10:20:42.301: C542 DPR3: D2H Msg: 000C 0080 00A1 0000 000C F11E
003228: *Mar  1 10:20:42.301: htsp_dsp_message: SEND/RESP_SIG_STATUS: state=0xC timestamp=61726 systime=3724230
003229: *Mar  1 10:20:42.301: htsp_process_event: [1/1/0, FXSLS_OFFHOOK, E_DSP_SIG_1100]fxsls_offhook_offhookhtsp_hook_flash_ind
003230: *Mar  1 10:20:42.301: htsp_timer_stop 
003231: *Mar  1 10:20:42.341: htsp_process_event: [1/1/1, FXSLS_CPC, E_HTSP_EVENT_TIMER]fxsls_cpc_timer
003232: *Mar  1 10:20:42.341: dsp_req_sig_state: [1/1/1] packet_len=8 channel_id=129 packet_id=40 
003233: *Mar  1 10:20:42.341: dsp_soutput: [1/1/1]
003234: *Mar  1 10:20:42.341: C542 DPR3: H2D Msg: 0008 0081 0028 007E
003235: *Mar  1 10:20:42.341: C542 DPR3: D2H Msg: 000A 0081 00A2 007E 000C
003236: *Mar  1 10:20:42.341: htsp_dsp_message: SEND/RESP_SIG_STATUS: state=0xC timestamp=61094 systime=3724234
003237: *Mar  1 10:20:42.341: htsp_timer - 60000 msec
003238: *Mar  1 10:20:42.341: htsp_process_event: [1/1/1, FXSLS_WAIT_ONHOOK, E_DSP_SIG_1100]
003239: *Mar  1 10:20:51.392: dspapi [1/1/0 (8)] dsp_inband_tone_off:
003240: *Mar  1 10:20:51.392: C542 DPR3: H2D Msg: 0008 0001 0047 007Ahtsp_release_req: cause 16, no_onhook 0
003241: *Mar  1 10:20:51.392: htsp_process_event: [1/1/0, FXSLS_OFFHOOK, E_HTSP_RELEASE_REQ]fxsls_offhook_disc
003242: *Mar  1 10:20:51.392: htsp_timer_stop 
003243: *Mar  1 10:20:51.392: [1/1/0] set signal state = 0xC timestamp = 0
003244: *Mar  1 10:20:51.392: dsp_set_sig_state: [1/1/0] packet_len=12 channel_id=128 packet_id=39 state=0xC timestamp=0x0
003245: *Mar  1 10:20:51.392: dsp_soutput: [1/1/0]
003246: *Mar  1 10:20:51.392: C542 DPR3: H2D Msg: 000C 0080 0027 007F 000C 0000
003247: *Mar  1 10:20:51.396: [1/1/0] set signal state = 0x4 timestamp = 750
003248: *Mar  1 10:20:51.396: dsp_set_sig_state: [1/1/0] packet_len=12 channel_id=128 packet_id=39 state=0x4 timestamp=0x2EE
003249: *Mar  1 10:20:51.396: dsp_soutput: [1/1/0]
003250: *Mar  1 10:20:51.396: C542 DPR3: H2D Msg: 000C 0080 0027 0080 0004 02EE
003251: *Mar  1 10:20:51.396: htsp_timer - 950 msec
003252: *Mar  1 10:20:52.346: htsp_process_event: [1/1/0, FXSLS_CPC, E_HTSP_EVENT_TIMER]fxsls_cpc_timer
003253: *Mar  1 10:20:52.346: dsp_req_sig_state: [1/1/0] packet_len=8 channel_id=128 packet_id=40 
003254: *Mar  1 10:20:52.346: dsp_soutput: [1/1/0]
003255: *Mar  1 10:20:52.346: C542 DPR3: H2D Msg: 0008 0080 0028 0081
003256: *Mar  1 10:20:52.346: C542 DPR3: D2H Msg: 000A 0080 00A2 0081 000C
003257: *Mar  1 10:20:52.346: htsp_dsp_message: SEND/RESP_SIG_STATUS: state=0xC timestamp=61754 systime=3725234
003258: *Mar  1 10:20:52.346: htsp_timer - 60000 msec
003259: *Mar  1 10:20:52.346: htsp_process_event: [1/1/0, FXSLS_WAIT_ONHOOK, E_DSP_SIG_1100]
003260: *Mar  1 10:21:09.253: C542 DPR3: D2H Msg: 000C 0080 00A1 0000 0004 5A65
003261: *Mar  1 10:21:09.253: htsp_dsp_message: SEND/RESP_SIG_STATUS: state=0x4 timestamp=23141 systime=3726925
003262: *Mar  1 10:21:09.253: htsp_process_event: [1/1/0, FXSLS_WAIT_ONHOOK, E_DSP_SIG_0100]fxsls_waitonhook_onhook
003263: *Mar  1 10:21:09.253: htsp_timer_stop htsp_report_onhook_sig
003264: *Mar  1 10:21:09.253: TGRM: reg_invoke_tgrm_call_update(1, 1, 0, 0, 1, TGRM_CALL_IDLE, TGRM_CALL_VOICE, TGRM_DIRECTION_IN)

while these happing the fxs leds both are on (green). hence i think that the cards are working. am i wrong?

tomorrow i will cross attach the pots line to the fxs port. can it work?

Content for Community-Ad