cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

4660
Views
8
Helpful
6
Replies
Highlighted
Beginner

No incoming calls in SRST

I've configured SRST fallback and everything is working fine (the phones register, dial each other, outgoing calls work) except the incoming calls.

The extensions are 3 digit. Full number 2124XX, extensions 4XX.

The incoming calls dialed number is 24XX.

        Called Party Number i = 0x81, '2425'
         Plan:ISDN, Type:Unknown

The configuration of the voice gateway is following:

!
card type e1 0 0
logging buffered 51200 warnings
!
no aaa new-model
!
clock timezone UTC 1 0
clock summer-time UTC recurring last Sun Apr 3:00 last Sun Oct 3:00
network-clock-participate wic 0
network-clock-participate wic 1
!
dot11 syslog
ip source-route
!
!
ip cef
!
!
!
multilink bundle-name authenticated
!
!
!
!
isdn switch-type primary-4ess
!
!
!
!
!
!
voice translation-rule 10
rule 1 /^90/ /0/
rule 2 /^91/ /1/
rule 3 /^92/ /2/
rule 4 /^93/ /3/
rule 5 /^94/ /4/
rule 6 /^95/ /5/
rule 7 /^96/ /6/
rule 8 /^97/ /7/
rule 9 /^98/ /8/
rule 10 /^99/ /9/
!
voice translation-rule 20
rule 1 /^40/ /0/
rule 2 /^41/ /1/
rule 3 /^42/ /2/
rule 4 /^43/ /3/
rule 5 /^44/ /4/
rule 6 /^45/ /5/
rule 7 /^46/ /6/
rule 8 /^47/ /7/
rule 9 /^48/ /8/
rule 10 /^49/ /9/
!
!
voice translation-profile PRI
translate called 10
!
voice translation-profile incoming_PRI
translate called 20
!
!
voice-card 0
!
!
application
global
  service alternate DEFAULT
!
!
!
!
archive
log config
  hidekeys
!
redundancy
!
!
controller E1 0/0/0
pri-group timeslots 1-31 service mgcp
!
!
!
!
!
!
!
!
!
interface GigabitEthernet0/0
ip address 192.168.75.51 255.255.255.0
duplex auto
speed auto
!
interface GigabitEthernet0/1
ip address 192.168.55.1 255.255.255.0
shutdown
duplex auto
speed auto
!
interface Serial0/0/0:15
no ip address
encapsulation hdlc
isdn switch-type primary-net5
isdn incoming-voice voice
isdn bind-l3 ccm-manager
no cdp enable
!
interface BRI0/1/0
no ip address
isdn switch-type basic-net3
isdn point-to-point-setup
isdn incoming-voice voice
isdn bind-l3 ccm-manager service mgcp
isdn static-tei 15
!
interface BRI0/1/1
no ip address
isdn switch-type basic-net3
isdn point-to-point-setup
isdn incoming-voice voice
isdn bind-l3 ccm-manager service mgcp
!
interface Internal-Service-Module0/0
ip unnumbered GigabitEthernet0/0
service-module ip address 192.168.75.53 255.255.255.0
!Application: CUE Running on AIM2
service-module ip default-gateway 192.168.75.1
hold-queue 512 out
!
ip forward-protocol nd
ip http server
ip http access-class 23
ip http authentication local
ip http secure-server
ip http timeout-policy idle 60 life 86400 requests 10000
!
!
ip route 0.0.0.0 0.0.0.0 192.168.75.1
ip route 192.168.75.53 255.255.255.255 Internal-Service-Module0/0
!
logging esm config
access-list 23 permit 10.10.10.0 0.0.0.7
access-list 23 permit 192.168.75.0 0.0.0.255
access-list 23 permit 192.168.73.0 0.0.0.255
access-list 23 permit 192.168.72.0 0.0.0.255
!
!
!
!
!
!
control-plane
!
!
voice-port 0/0/0:15
echo-cancel coverage 64
!        
voice-port 0/1/0
echo-cancel coverage 64
compand-type a-law
!
voice-port 0/1/1
echo-cancel coverage 64
compand-type a-law
!
ccm-manager fallback-mgcp
ccm-manager mgcp
no ccm-manager fax protocol cisco
ccm-manager music-on-hold
ccm-manager config server XXXXXX
ccm-manager config
!
mgcp
mgcp call-agent XXXUCM001 2427 service-type mgcp version 0.1
mgcp dtmf-relay voip codec all mode out-of-band
mgcp rtp unreachable timeout 1000 action notify
mgcp modem passthrough voip mode nse
mgcp package-capability mf-package
mgcp package-capability rtp-package
mgcp package-capability sst-package
mgcp package-capability pre-package
mgcp default-package line-package
no mgcp package-capability res-package
no mgcp package-capability fxr-package
no mgcp timer receive-rtcp
mgcp timer net-cont-test 3000
mgcp sdp simple
mgcp fax t38 inhibit
mgcp rtp payload-type g726r16 static
mgcp bind control source-interface GigabitEthernet0/0
mgcp bind media source-interface GigabitEthernet0/0
!
mgcp profile default
!
!
dial-peer voice 10 pots
description Bitola
destination-pattern 9[2345].....
direct-inward-dial
port 0/0/0:15
forward-digits 6
!
dial-peer voice 11 pots
description MobileONEVIP
destination-pattern 907[56789]......
port 0/0/0:15
forward-digits 9
!
dial-peer voice 12 pots
description MobileTMOB
destination-pattern 907[0-2]......
port 0/0/0:15
forward-digits 9
!        
dial-peer voice 13 pots
description National
destination-pattern 90[34].......
port 0/0/0:15
forward-digits 9
!
dial-peer voice 14 pots
description International
translation-profile outgoing PRI
destination-pattern 9T
port 0/0/0:15
!
dial-peer voice 5 pots
translation-profile incoming incoming_PRI
incoming called-number 24..
direct-inward-dial
port 0/0/0:15
forward-digits 0
!
dial-peer voice 7 voip
translation-profile incoming incoming_PRI
incoming called-number .
!
dial-peer voice 1 pots
translation-profile incoming incoming_PRI
incoming called-number .
direct-inward-dial
port 0/0/0:15
!
!
!
!
credentials
ip source-address 192.168.75.51 port 2445
trustpoint srstca
!
!
call-manager-fallback
max-conferences 8 gain -6
transfer-system full-consult
ip source-address 192.168.75.51 port 2000
max-ephones 100
max-dn 200 dual-line
system message primary IPT Fallback Active
system message secondary IPT Fallback
dialplan-pattern 1 212... extension-length 3
keepalive 20
default-destination 400
time-format 24
!
!
!
line con 0
login local
line aux 0
line 194 
no activation-character
no exec 
transport preferred none
transport input all
transport output lat pad telnet rlogin lapb-ta mop udptn v120 ssh
stopbits 1
speed 115200
line vty 0 4
privilege level 15
login local
transport input telnet ssh
transport output telnet
line vty 5
privilege level 15
login local
transport input telnet ssh
transport output telnet
line vty 6 15
privilege level 15
login local
transport input telnet ssh
!
scheduler allocate 20000 1000
ntp master 1
ntp update-calendar
ntp server 206.246.122.250 prefer
end

With all this I get:


XXXVGW001#show dialplan number 2425
Macro Exp.: 2425
No match, result=-1

and "no dial peer matched" error when trying a call on the PRI line.

Any suggestions?

Thanks!

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
Enthusiast

Re: No incoming calls in SRST

I believe you are trying to translate all called numbers from 24XX to 4XX for incoming calls, correct? I saw your config and the voice translation-rule 20, which i believe is being used for internal calls in SRST, does not have the necessary translation to translate 24XX to 4XX. Try this:

voice translation-rule 30
rule 1 /^24/ /4/

voice translation-profile incoming_PRI
translate called 30

Check you translation using XXXVGW001#show dialplan number 2425

Make a test call and post your results

Hope that helps

Regards

Nitesh

PS:Please rate helpful posts

View solution in original post

6 REPLIES 6
Highlighted
Enthusiast

Re: No incoming calls in SRST

I believe you are trying to translate all called numbers from 24XX to 4XX for incoming calls, correct? I saw your config and the voice translation-rule 20, which i believe is being used for internal calls in SRST, does not have the necessary translation to translate 24XX to 4XX. Try this:

voice translation-rule 30
rule 1 /^24/ /4/

voice translation-profile incoming_PRI
translate called 30

Check you translation using XXXVGW001#show dialplan number 2425

Make a test call and post your results

Hope that helps

Regards

Nitesh

PS:Please rate helpful posts

Highlighted
Enthusiast

Re: No incoming calls in SRST

I believe you are trying to translate all called numbers from 24XX to 4XX for incoming calls, correct? I saw your config and the voice translation-rule 20, which i believe is being used for internal calls in SRST, does not have the necessary translation to translate 24XX to 4XX. Try this:

voice translation-rule 30
rule 1 /^24/ /4/

voice translation-profile incoming_PRI
translate called 30

Check you translation using XXXVGW001#show dialplan number 2425

Make a test call and post your results

Hope that helps

Regards

Nitesh

PS:Please rate helpful posts

View solution in original post

Highlighted
Beginner

Re: No incoming calls in SRST

Thanks for the reply...

Yes I can see the mistake, but I think it's not relevant. From my experience when an incoming call arrives, the router first matches the dial-peer and then does the translation.

So even with wrong translation rules, the dial-peer should be matched.

Anyway I will change the rules and try again, but I am little bit sceptical...

Best regards,

Konstantin

Highlighted
Enthusiast

Re: No incoming calls in SRST

Nitesh is correct, the reason your inbound calls are failing is due to the called number not matching anything in your incoming_PRI translation profile. There is also a problem with how you are trying to test. 'show dialplan number xxxx' only shows matching outbound dial-peers. This is why you are not getting any matches. The better test would be to turn on 'debug voip dialpeer' and make an inbound call while the site is in SRST. This output will show you all matching inbound and outbound dial-peers. You could even run 'test voice translation-rule 20 2425' which would show you if the translation-rule 20 is doing anything for you with this inbound number.

However, until you make the necessary changes to your translation-rule 20, it will never successfully match an outbound dial-peer and ring the phone.

HTH

-Adam

If helpful, please rate this posting

Highlighted
Beginner

Re: No incoming calls in SRST

Thank you guys for the responce!

You made me rethink the dial-peer matching and I now realised that the errors of no dial peer matched probably were because no outgoing dial-peer was matched during the call (to fast debug output) - the one outgoing dial-peer associated with the extension.

I changed the translation rules and now they should work...

Will try with live calls in SRST ASAP and post results!

Highlighted
Beginner

Re: No incoming calls in SRST

We finally managed to test the new configuration and your answers were correct!

The extensions were not matched because of the wrong translation rules (I didn't even spend a lot of time on them because I tought the problem was in incoming calls matching), changed them to the correct form (like you said).

Thanks for the help once again!

Best regards,

Konstantin Dimitrovski

CreatePlease to create content
Content for Community-Ad

Cisco COVID-19 Survey