Showing results for 
Search instead for 
Did you mean: 

Outbound Caller ID Drops the Plus (+)

Globalized the dial plan, but when the call goes out the PRI I lose the + when the call goes out the PRI.  I know the + is not supported on PRI, but I'm trying to figure how to stop the updating of the caller ID when the call leaves CUCM.  I've had to fix this on SIP to SIP in the past with "no update-callerid, but this is the first Time I've seen it SIP to PRI.


Phone <---SIP--->CUCM<---SIP--->4331<--PRI---> PSTN


Dial 5035551234 globalized to +15035551234 which is what displays on the phone.  when the call hits the PRI the CallerID is updated to 15035551234.  Once the call is globalized to +15035551234 the display on the phone should not change.


Any help is appreciated.

VIP Advisor



You can use the same command on the gateway since you are using SIP protocol. In this case, gateway you send the updated called number to CUCM


You can also fix it on CUCM from the service parameter "Always display original dialed number"


You've many options other than one of the good option suggested by Mohammed which will be applicable globally for all calls. These options were discussed recently on forum;

1. In gateway under sip-ua, use 'no remote-party-id'

2. Use SIP profiles in gateway to update RPID as per your requirement.

3. Change service parameter in CUCM 'Apply transformation CSS to remote number' to True and apply the relevant called party transformation CSS to Remote Number field on Device page.

- Vivek


Thx Vivek for sharing this. Great piece of information.


Thanks for the suggestions.

1. changed the display back to the original dialed number, so no +

2. Is there a good primer on sip profiles somewhere?  Everything I find assumes the reader already knows EXACTLY what needs to be changed in the 47,000 options available. 

3. Service parameter does not show the update to the called number with the +, so stays as originally dialed.

I think I am looking for the SIP equivalent of "no supplementary-service h225-notify cid-update" which I thought was the global SIP command "no update-callerid", but alas it is not.  Goal is that once the + is put on the the number, it stays put.


1. This should definetly work. Phone basically updates the connected number as per rpid header value recieved from gateway. If rpid header is not recieved, phone should not update the display and you should see globalized number. 

You should check the 200 OK (SDP answer) sent by gateway to CM whether rpid header is present or not.

2. Our community fried Ayodji excellently described it in the below post;

3. Do you mean it worked for you?

The way h323 command doesn't update the connected number, no remote-party id doesn't send the actual dialed number to CM.

- Vivek 


Sorry, was out of time with the customer and just getting to another location where I am seeing the same thing only with a SIP PSTN connection.  I went back and read the post above and I applied a sip-profile, and that seems to do the trick on the connected.  However, if the call forwards to voicemail, the + disappears again.  Frustrating.

Number 3 had no effect.  It looks like from reading the CUCM description, I would have to set the transform on every device.  Not what I was looking for.  

I'm thinking this may have something to do with using a 4300 vs a 2900 gateway.  Or this is the first time I've had a sip provider that refuses to accept the +.   

I'll keep plugging away and update the post if I get an answer but basically what I am looking for is once the phone display is updated with the + from the translation rule, the called number as it is displayed on the phone should not change.  Every external called number should be globalized to +E.164. 


Updated on

The solution was using sip profiles to update the Remote-Party-ID for the 183 session message and the 200 OK messages.



Thanks for the update.

- Vivek

Content for Community-Ad