cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1207
Views
0
Helpful
4
Replies
zach.koncir
Beginner

Outbound CLID/SIP Auth problem

After updating IOS on a UC520, I noticed that outbound calls via SIP Trunk (voip.ms), stopped working. Whenever I would make a call outside the network, I just got an operator message saying, "That number has not yet been assigned." I thought this message was originating from the UC520, so I went over my config, even went as far as wiping the flash and doing a factory reset, and re-installing and configuring.

I finally setup a switch with port mirroring on the external interface, and analyzed the SIP traffic. I noticed that in the SIP headers, rather than sending my username in the from section, it was sending the number I had set as the main outbound caller id I had set for the trunk.

So, it was sending:

NXXNXXXXXX@toronto.voip.ms

At voip.ms, when proxy auth occurs, it needs the username:

xxxxxx@toronto.voip.ms

The workaround is to just set the auth username as the outbound CLID for the SIP trunk.

I'm just wondering if anyone else has had this issue with their voice provider? Does anyone know what changed in IOS that caused this, and is there a better workaround that would still allow me to set the outbound caller ID number on the UC520?

4 REPLIES 4
paolo bevilacqua
Hall of Fame Master

That is normal with SIP trunks. Each ITSP has different ways to authenticate and do things, so sometime settings have to be adjusted user side.

Robert Thomas
Enthusiast

First time I have seen a provider ask for the user name on the from of the Invite.

You cant point at this been industry standard, standard auth means are SIP register, IP based auth, or a 407 authorize challenge.

Seems a little poor the auth method the provider choose.

Sent from Cisco Technical Support iPhone App

It's funny, they use SIP register, and a 407 auth challenge. Then on top of the I have to pass the user ID in outgoing calls.

Now I'm having another issue. My account name has an underscore in it. I cannot figure out how to setup a translation rule that will allow me to use underscores in it.

Any ideas?

did you ever figure this out Zach?

I'm having the same issues.

-----------

EDIT:

I just got off support with my second VoIP.ms support rep.  It seems like one _must_ use their main account.  They did not offer any further support, so unless someone comes up with a way to use underscores in translation rules it seems the only way is to use the main account.

Content for Community-Ad

Spotlight Awards 2021