cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
16074
Views
21
Helpful
27
Replies
Highlighted
Enthusiast

Outbound Ringback Issues over SIP trunk using CUCM 8.6 and H323 Gateway

Im using a SIP provider (voip.ms) to a H323 gateway (2801) and from there go to my CUCM 8.6 server.  Inbound calls work fine, i get ringback and outbound calls connect and work fine, i just hear no ringback on my outbound calls via my SIP provider.

Attached are my debug ccsip messages, debug ccsip calls and debug ccapi inout as well as my running config

Here is also a link to another thread for other stuff ive tried:

http://www.techexams.net/forums/ccnp-voice/78494-outbound-ringback-issues.html

If anyone could solve this, you would be my hero!!!!                  

27 REPLIES 27
Highlighted

Just kidding, it looks like i just need to switch the session protocol to sipv2 then setup a trunk instead of a gateway on CUCM

Highlighted

Yes. On cucm setup a sip trunk, the detsination address will be your cube gateway. Assign MRGL with ANN to the sip trunk.

2. On your gateway configure the ff:

voice servie voip

sip

  bind control source-interface "xxxx"-----xxxx= your inerface eg gig0/0 of fa0/0

  bind media source-interface "xxxx"   

options-ping 60

early-offer forced.......................If you want to use early offer otherwise you can remove this

voice class codec 1---------------------------------to advertise different codecs, change preference as you want

codec preference 1 g729r8

codec preference 2 g711ulaw

codec preference 3 g711alaw

dial-peer voice 1 voip---------------------------------This will be your default dial-peer for incoming calls from cucm and sip provider

session portocol sipv2

incoming called-number .

voice-class codec 1 

dtmf-relay rtp-nte

I believe you already have a dial-peer with sip protocl going to your ITSP.

Please rate useful posts

"For the love of God is broader than the measure of man's mind And the heart of the Eternal is most wonderfully kind"

Please rate all useful posts

View solution in original post

Highlighted

problem im running into now, is that when i bind the sip source interface to the internal FA port rather than the external, now my sip trunk does not register

how can i bind it to the external AND internal interface so it will register and work as a cucm trunk?

Highlighted

John,

What do you mean by your sip trunk does not register? Are you talking about cucm trunk? or the sip trunk to your provider?

CUCM sip trunk does not register and as far as I know, your ITSP trunk does not register. Most ITSP use authentication.

Can you send a sh run of your router...

Please rate useful posts

"For the love of God is broader than the measure of man's mind And the heart of the Eternal is most wonderfully kind"

Please rate all useful posts
Highlighted

The show run is attached in the zip file in the first post

when i do a show sip-ua register status it shows up as registered: YES

if i bind sip to the internal interface it shows registered: NO and no calls work in or out

when i did a debug ccsip messages, its sending the SIP provider my internal IP address, which obviously isnt going to work (when bound to the inside interface)

Highlighted

John,

OK I get you now. I did not know you were using a registrar.

Can you leave your bind on your external interface...Try and send a call to the cube..Let me know what happens. CUCM trunk does not need registration.

Please rate useful posts

"For the love of God is broader than the measure of man's mind And the heart of the Eternal is most wonderfully kind"

Please rate all useful posts
Highlighted

OK.  I bound SIP to the internal interface and setup the SIP traffic to route out my ASA gateway and setup static statements on the ASA to map the SIP traffic to the router behind it and viola, everything is working once i converted cucm to the sip trunk.

Thanks for the help aokanlawon

Highlighted

Make sure the annunciator is inside the MRG of the SIP trunks. I left my ANN inside a not-used MRG, and after put it in the MRG of the SIP trunk, I got the ringback.

Highlighted

Hi Ayodeji,

 

I had the same problem that JZergers06 had and I disabled the early media 180, as you said on pots above and everything worked fine. Thanks a lot!!!

Highlighted

Hello Ayodeji,

I always enjoy reading your posts..Very very informative and i admire your passion on the SIP technology.

Regarding "If you are receiving 183 with SDP but still not getting ringback,", 

1. what can cause this issue ? 

2. What is the side effect of disabling early media on other call flows ?

3. Is it a good idea or valid idea to translate 183 with sdp to 180 ringing on the SBC to do the same ?

Thanks,Padhu

Highlighted

Thank you for your kind words..

1. It is usually a problem on the service provider side. So there is nothing much you can do other than contacting them

2. You will typically not get announcements that are played before media connects. Anything that is sent as media before 200 OK or ACK is early media and if you disable it, then you don't get it

3. It is advisable to let SBC/service provider do it. It is not recommended practice..

Please rate all useful posts
Highlighted

Thank you Ayodeji.

Disabling early media didn't seem to fix but some interesting things in the cm traces and sdp.

(Sip trunk set for early offer with insert MTP if reqd)

when phones have g711 ahead of g729 in ACPL ( same in SDP), the ring back works but ringback fails when G729 is chosen first. CCm Traces indicate a SW_MTP being allocated eventhough MRGL has MRGs with HW_IOS_MTP higher up in the order...So that brings up an anamoly where a G711 based SW MTP being invoked for a G729 call and ring back fails.

we are investigating more on this choice of MTP.

Highlighted

Hi,

I am having the exact same issue. When G729 is negotiated the ringback fails (though the call succeeds).

Did you find any solution to it?