Showing results for 
Search instead for 
Did you mean: 
Kaushik Ray

Passcode on Cisco IP Phone

Hello All

I would need an advise on the following;

I have a remote IP Phone and I am required to create a passcode for it to be able to make phone calls. The IP Phone is registering to a Router offshore setup as a Call Manager Express:

Is there any way I can configure the Call Manager Express Router to be able to allow only one phone registering to it to be setup with this passcode.

Any advice will be most welcome.

Many Thanks in advace.


What version of CCME are you running..You can use FAC to achieve this

Please rate all useful posts

Thanks for the reply

I am using the follwoing:


Can you type show telephony-service on your gateway and send the output here. It will show which CCME version you are running

Please rate all useful posts

Router#     show telephony-service

CONFIG (Version=8.6)


Version 8.6

Max phoneload sccp version 17

Max dspfarm sccp version 18

Cisco Unified Communications Manager Express

For on-line documentation please see:

protocol mode default

ip source-address port 2000

ip qos dscp:

ef (the MS 6 bits, 46, in ToS, 0xB8) for media

cs3 (the MS 6 bits, 24, in ToS, 0x60) for signal

af41 (the MS 6 bits, 34, in ToS, 0x88) for video

default (the MS 6 bits, 0, in ToS, 0x0) for serviceservice directed-pickup

no auto-reg-ephone

load 7906 SCCP11.8-2-2SR1S

load 7911 SCCP11.8-2-2SR1S

load 7942 SCCP42.9-0-3S

max-ephones 35

max-dn 10

max-conferences 4 gain -6

dspfarm units 0

dspfarm transcode sessions 0

conference software


no privacy-on-hold

hunt-group report delay 1 hours

hunt-group logout DND

max-redirect 10

cnf-file location: system:

cnf-file option: PER-PHONE-TYPE

network-locale[0] GB   (This is the default network locale for this box)

network-locale[1] US

network-locale[2] US

network-locale[3] US

network-locale[4] US

user-locale[0] US    (This is the default user locale for this box)

user-locale[1] US

user-locale[2] US

user-locale[3] US

user-locale[4] US

srst mode auto-provision is OFF

srst ephone template is 0

srst dn template is 0

srst dn line-mode single

time-format 24

date-format dd-mm-yy

timezone 0 Greenwich Standard Time

call-forward pattern .T

no transfer-pattern is configured, transfer is restricted to local SCCP phones only.

keepalive 30 auxiliary 30

timeout interdigit 5

timeout busy 10

timeout ringing 180

timeout transfer-recall 0

timeout ringin-callerid 8

timeout night-service-bell 12

caller-id name-only: enable

edit DN through Web:  enabled.

edit TIME through web:  enabled.

background save interval 10 minutes

Log (table parameters):

     max-size: 150

     retain-timer: 15

create cnf-files version-stamp 7960 Apr 13 2012 03:44:26

transfer-system full-consult

transfer-digit-collect new-call

local directory service: enabled.

Extension-assigner tag-type ephone-tag.

Right so you are running CCME 8.6

Below is the link to use to configure FAC..

This is a link on this forum for similar configuration..

Pls rate all helpfull posts

Please rate all useful posts

I put in the followng configuration on the CME router but did not obtain the results: any advice as to why this could be the case?


voice lpcor enable

voice lpcor custom

group 11 IPPhone


voice lpcor policy IPPhone

service fac

accept IPPhone fac



package auth

  param passwd-prompt

  param passwd 1463



ephone  8

lpcor type local

lpcor outgoing IPPhone

device-security-mode none

description BP Jordan

mac-address D4D7.4841.94C7

codec g729r8

type 7942

button  1:8


I will be grateful to have any advise on this.




I provided a link with the full config required. I looked at your configuration and you dont have

1. AA config..

aaa new-model



aaa authentication login default local

aaa authentication login h323 local

aaa authorization exec h323 local

aaa authorization network h323 local

aaa session-id common

gw-accounting aaa

2.your lpcor configuration is wrong/incomplete

1. you need to configure lpcor for phone and PSTN destination you want to force authorization for


voice lpcor enable

voice lpcor custom

group 10 IPPhone

group 11 PSTN


voice lpcor policy IPPhone

service fac

accept IPPhone fac

accept PSTNT fac


voice lpcor policy PSTN

service fac

accept IPPhone fac

accept PSTNT fac

You configured the lpcor wrongly "lpcor outgoing IPPhone" it should be "lpcor incoming IPPhone"

3. You did not configure Paramaters correctly


package auth

  param passwd-prompt

  param passwd 5555

  param term-digit #

  param user-prompt

  param abort-digit *

  param max-digits 32

* PIN Configuration** (for the end user you want restricted)

username xxxxx password 0 yyyyy  (eg.username 5555 password 0 12345)

4. Apply the lpcor to your dial-peer for outgoing calls

dial-peer voice xxx pots

lpcor outgoing PSTN

5. apply lpcor policy to the phone

ephone  8

lpcor type local

lpcor incoming IPPhone

Please rate all useful posts
Recognize Your Peers
Content for Community-Ad