cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
2155
Views
0
Helpful
4
Replies
Beginner

Phone not registering

Hello all. I'm working on my VOIP lab and running into a problem. This is my first attempt at VOIP so I'm really green.

I am running IOS: c3725-ipvoice-mz.124-25d.bin

I'm trying to use the 3725 as a TFTP server for the phones. I have DHCP set up on my asa with 150 pointing to the router. The phones get the appropriate IP address and see the router as the TFTP server.

I am trying to do this with SIP. My phone states that it is Unprovisied. Here is my configuration:

version 12.4

service config

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname .......

!

boot-start-marker

boot-end-marker

!

enable secret 5 $1$pzMy$QYCtzB9IfLsBsE7Xm1aKr/

!

no aaa new-model

clock timezone Eastern -5

no network-clock-participate slot 1

ip cef

!

!

!

!

voice-card 1

no dspfarm

!

!

!

!

interface FastEthernet0/0

description To ASA

ip address 192.168.1.100 255.255.255.0

duplex auto

speed auto

!

interface FastEthernet0/1

no ip address

shutdown

duplex auto

speed auto

!

ip forward-protocol nd

!

ip http server

ip http path flash:/gui

!

!

tftp-server flash:/phones/P0030801SR01.bin

!

control-plane

!

!

!

voice-port 1/0/0

!

voice-port 1/0/1

!

!

!

!

!

!

telephony-service

load 7960-7940 P0030801SR01

max-ephones 1

max-dn 1

ip source-address 192.168.1.100 port 2000

auto assign 1 to 1

create cnf-files version-stamp Jan 01 2002 00:00:00

max-conferences 8 gain -6

web admin system name ........ password .......

dn-webedit

time-webedit

transfer-system full-consult

!

!

ephone-dn  1  dual-line

number 9501

!

!

ephone  1

!

!

!

line con 0

line aux 0

line vty 0 4

password .......

login

!

ntp clock-period 17180322

ntp server 192.168.1.100

!

end

When I try to create the cnf files I get the following error:

%Error deleting flash:SEPDEFAULT.cnf (File not found)

%Error deleting flash:XMLDefault.cnf.xml (File not found)CNF-FILES: Clock is not set or synchronized,

                retaining old versionStamps

I need a nudge in the right direction. I would like to at least assign the phone a number and get moving towards it recognizing the router and receving the appropriate configuration.

Any help would be greately appreciated!

Everyone's tags (2)
4 REPLIES 4
Beginner

Phone not registering

Adam,

I don't see the MAC address added to ephone 1, have you tried adding the MAC?

Rising star

Re: Phone not registering

Look at this for a basic setup of CME.

http://www.ciscopress.com/articles/article.asp?p=1182471&seqNum=2

Some parts of the guide are not really necessary, like the part were the allow-connections commands are used. The SCCP CME phones are seen as virtual POTS ports (FXS in this case) to the router, so it wouldn't be VOIP to VOIP, and that's what the allow commands allow you to have. For normal POTS to VOIP there are no need to use any allow commands.

You also mentioned that you were trying to set the phones up for SIP, but your CME config are for SCCP. I would recommend you to stick with SCCP, the CME implementation for SIP is really clunky and not as easy to setup as it's more evolved SCCP counterpart.

Please rate all useful posts.

Sent from Cisco Technical Support iPhone App

Please remember to rate helpful responses and identify helpful or correct answers.
Highlighted
Beginner

Re: Phone not registering

I've put some more work into this today. I do seem to have a SCCP image but the phone I have is stuck on SIP. I am trying to get it to convert over. I have P0030801SR01.bin / .loads / .sb2 .sbn all in flash:/phones

I have SEP.cnf.xml, SIP.cnf, SIP.cnf.xml, and OS78XX.txt all in flash:

The phone doesn't seem to want to switch over from SIP to SCCP. I've updated the configuration now to:

version 12.4

service config

service timestamps debug datetime msec

service timestamps log datetime msec

service password-encryption

!

hostname Exarch3725

!

boot-start-marker

boot system flash

boot-end-marker

!

enable secret 5 $1$pzMy$QYCtzB9IfLsBsE7Xm1aKr/

!

no aaa new-model

clock timezone EST -5

no network-clock-participate slot 1

ip cef

!

!

!

!

voice-card 1

no dspfarm

!

!

!

!

voice service voip

allow-connections h323 to h323

allow-connections h323 to sip

allow-connections sip to h323

allow-connections sip to sip

sip

  registrar server expires max 600 min 60

!

!

username FerrelEx privilege 15 password 7 122E0A1B1418051C7C6D62

!

!

interface FastEthernet0/0

description To ASA

ip address 192.168.1.100 255.255.255.0

duplex auto

speed auto

!

interface FastEthernet0/1

no ip address

shutdown

duplex auto

speed auto

!

ip forward-protocol nd

!

ip http server

!

!

tftp-server flash:/phones/P0030801SR01.bin

tftp-server flash:SIPDefault.cnf

tftp-server flash:OS79XX.txt

tftp-server flash:SEP0002FD659E85.cnf.xml

tftp-server flash:SIP0002FD659E85.cnf

tftp-server flash:SIP0002FD659E85.cnf.xml

tftp-server system:/its/XMLDefault7960.cnf.xml alias SEP0002FD659E85.cnf.xml

tftp-server flash:/phones

!

control-plane

!

!

!

voice-port 1/0/0

!

voice-port 1/0/1

!

!

!

telephony-service

load 7960-7940 P0030801SR01

max-ephones 10

max-dn 10

ip source-address 192.168.1.100 port 2000

auto assign 1 to 1

create cnf-files version-stamp 7960 Sep 22 2012 23:19:23

max-conferences 8 gain -6

web admin system name FerrelEx secret 5 $1$mr8D$jw3hRNnoMTHDMpb3yvDUr/

transfer-system full-consult

!

!

ephone-dn  1  dual-line

number 9501

name Adams Desk

!

!

ephone  1

mac-address 0002.FD65.9E85

type 7960

button  1:1

!

!

!

line con 0

line aux 0

line vty 0 4

password 7 02310B570D1506391A084F

login

!

ntp master

!

end

The phone now seems to continually reset and I am still getting the same error as before.

Rising star

Re: Phone not registering

Converting a phone from SIP to SCCP, or vice versa, with CME can be a very painful process.You can do a debug tftp events to see the request of the different files during phone boot sequence. From this you might be able to figure out where it goes wrong.

But a much easier way to convert the phone is to temporary point it to boot from a CUCM. After it has downloaded the firmware you can again point it to CME. If you use this method you should remove the load statements.

Please rate all useful posts.

Sent from Cisco Technical Support iPhone App

Please remember to rate helpful responses and identify helpful or correct answers.
CreatePlease to create content
Content for Community-Ad
August's Community Spotlight Awards