cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
168
Views
5
Helpful
1
Replies

phone system not working, please look at my router config

Kaleem Sheikh
Beginner
Beginner

I have all my 7960 phones connected to a 2960 switch and none of my phones are working, I think it is a router problem. My router is a 2911 and the config is below:


ART-RTR#show run
Building configuration...


Current configuration : 6887 bytes
!
! Last configuration change at 16:36:23 UTC Tue Aug 30 2016
! NVRAM config last updated at 16:36:23 UTC Tue Aug 30 2016
! NVRAM config last updated at 16:36:23 UTC Tue Aug 30 2016
version 15.2
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname ART-RTR
!
boot-start-marker
boot-end-marker
!
!
enable secret 4 PHOZ1wqdBo94kCFjtQjAZ2rHNCXmSzY/NjXpnh7YWA2
!
no aaa new-model
!
ip cef
!
!
!
!


!
ip dhcp excluded-address 192.168.1.1 192.168.1.10
ip dhcp excluded-address 192.168.1.250 192.168.1.254
!
ip dhcp pool ARTRESOURCES
network 192.168.1.0 255.255.255.0
option 150 ip 192.168.1.2
default-router 192.168.1.1
!
!
!
ip name-server 209.18.47.61
ip name-server 209.18.47.62
no ipv6 cef
multilink bundle-name authenticated
!
!
!
!
!
!
!
voice-card 0
dspfarm
dsp services dspfarm
!
!
voice call send-alert
voice rtp send-recv
!
voice service voip
ip address trusted list
ipv4 216.89.76.113 255.255.255.255
ipv4 66.42.61.19 255.255.255.255
ipv4 162.242.149.36 255.255.255.255
ipv4 64.183.62.221 255.255.255.255
ipv4 64.183.62.222 255.255.255.255
ipv4 192.168.1.2 255.255.255.255
ipv4 192.168.30.2 255.255.255.255
ipv4 192.168.1.0 255.255.255.0
ipv4 192.168.30.0 255.255.255.0
ipv4 10.0.0.0 255.0.0.0
address-hiding
allow-connections h323 to h323
allow-connections h323 to sip
allow-connections sip to h323
allow-connections sip to sip
no supplementary-service sip refer
redirect ip2ip
fax protocol pass-through g711ulaw
sip
header-passing
error-passthru
asserted-id pai
no update-callerid
midcall-signaling passthru media-change
privacy-policy passthru
g729 annexb-all
sip-profiles 1
!
voice class media 1
!
voice class sip-profiles 1
request REINVITE sdp-header Audio-Connection-Info remove
response 200 sdp-header Audio-Connection-Info remove
!
voice class sip-profiles 2
request INVITE sdp-header Audio-Attribute modify "a=ptime:20" "a=ptime:30"
response ANY sdp-header Audio-Attribute modify "a=ptime:20" "a=ptime:30"
!
!
!
!
voice translation-rule 2
rule 1 /^5.$/ /13236589000/
rule 2 /^3.$/ /13236589000/
rule 3 /^2.$/ /13236589000/
rule 4 /^4.$/ /13236589000/
rule 5 /^6.$/ /13236589000/
rule 6 /^7.$/ /13236589000/
rule 7 /^1.$/ /13236589000/
!
voice translation-rule 3
rule 1 /^13103637053/ /10/
rule 2 /^13152458479/ /30/
rule 4 /^13236589000/ /30/
!
voice translation-rule 5
rule 1 /^91\(.*\)/ /1\1/
rule 2 /^9011\(.*\)/ /2271011\1/
!
!
voice translation-profile EPHONE
translate calling 2
!
voice translation-profile INBOUND
translate calling 3
translate called 3
!
voice translation-profile OUTGOING
translate called 5
!
!
!
license udi pid CISCO2911/K9 sn FTX1719AKYL
hw-module pvdm 0/0
!
!
!
username admin password 7 0305491F0506324F41
!
redundancy
!
!
!
class-map match-all voip-signal
match access-group 101
class-map match-all voip-rtp
match access-group 100
!
policy-map qos-policy
class voip-rtp
priority 4000 50000
class voip-signal
bandwidth 100
class class-default
fair-queue
!
!
!
!
!
interface Embedded-Service-Engine0/0
no ip address
shutdown
!
interface GigabitEthernet0/0
ip address 192.168.1.1 255.255.255.0
ip accounting output-packets
duplex auto
speed auto
!
interface GigabitEthernet0/1
ip address 10.1.1.2 255.255.255.0
duplex auto
speed auto
!
interface GigabitEthernet0/2
ip address 192.168.30.3 255.255.255.0
duplex auto
speed auto
service-policy output qos-policy
!
!
ip forward-protocol nd
!
no ip http server
no ip http secure-server
!
ip route 0.0.0.0 0.0.0.0 192.168.30.1
!
access-list 100 permit ip any any precedence critical
access-list 100 permit ip any any dscp ef
access-list 101 permit tcp any any
!
!
!
control-plane
!
!
voice-port 0/0/0
timing hookflash-out 50
timing guard-out 1000
!
voice-port 0/0/1
!
voice-port 0/0/2
!
voice-port 0/0/3
!
!
!
!
ccm-manager mgcp
no ccm-manager fax protocol cisco
ccm-manager music-on-hold
ccm-manager config server 192.168.1.2
ccm-manager config
!
mgcp
mgcp call-agent 192.168.1.2 2427 service-type mgcp version 0.1
mgcp rtp unreachable timeout 1000 action notify
mgcp modem passthrough voip mode nse
mgcp package-capability rtp-package
mgcp package-capability sst-package
mgcp package-capability pre-package
no mgcp package-capability res-package
no mgcp timer receive-rtcp
mgcp sdp simple
mgcp fax t38 inhibit
mgcp bind control source-interface GigabitEthernet0/0
mgcp bind media source-interface GigabitEthernet0/0
!
mgcp profile default
!
sccp local GigabitEthernet0/0
sccp ccm 192.168.1.2 identifier 1 version 7.0
sccp
!
sccp ccm group 1
associate ccm 1 priority 1
associate profile 1 register MTP4C4E35016FB0
associate profile 2 register TP4C4E35016FB0
associate profile 3 register CFB4C4E35016FB0
keepalive retries 5
switchover method immediate
switchback method immediate
switchback interval 15
!
dspfarm profile 1 transcode
codec g729abr8
codec g729ar8
codec g711alaw
codec g711ulaw
codec g729r8
codec ilbc
codec g722-64
maximum sessions 5
associate application SCCP
!
dspfarm profile 2 mtp
codec g711ulaw
maximum sessions software 200
associate application SCCP
!
dial-peer voice 50 voip
destination-pattern 30$
session protocol sipv2
session target ipv4:192.168.1.2
voice-class sip bind control source-interface GigabitEthernet0/0
voice-class sip bind media source-interface GigabitEthernet0/0
dtmf-relay rtp-nte
codec g711ulaw
no vad
!
dial-peer voice 60 voip
description *To CUCM TEST*
translation-profile incoming INBOUND
session protocol sipv2
incoming called-number .
voice-class sip bind control source-interface GigabitEthernet0/2
voice-class sip bind media source-interface GigabitEthernet0/2
dtmf-relay rtp-nte
codec g711ulaw
no vad
!
dial-peer voice 40 voip
destination-pattern 10$
session protocol sipv2
session target ipv4:192.168.1.2
voice-class sip bind media source-interface GigabitEthernet0/0
dtmf-relay rtp-nte
codec g711ulaw
no vad
!
dial-peer voice 3 voip
translation-profile outgoing OUTGOING
destination-pattern 9T
session protocol sipv2
session target ipv4:162.242.149.36
voice-class sip early-offer forced
voice-class sip profiles 1
voice-class sip bind control source-interface GigabitEthernet0/2
voice-class sip bind media source-interface GigabitEthernet0/2
dtmf-relay sip-notify rtp-nte
codec g711ulaw
no vad
!
dial-peer voice 999000 pots
service mgcpapp
port 0/0/0
!
!
sip-ua
!
!
!
gatekeeper
shutdown
!
!
!
line con 0
exec-timeout 0 0
logging synchronous
line aux 0
line 2
no activation-character
no exec
transport preferred none
transport input all
transport output lat pad telnet rlogin lapb-ta mop udptn v120 ssh
stopbits 1
line vty 0 4
exec-timeout 0 0
password 7 130405060805172924
logging synchronous
login local
transport input all
!
scheduler allocate 20000 1000
ntp master
ntp server 192.168.1.1
!
end

1 Reply 1

Jaime Valencia
Hall of Fame Cisco Employee Hall of Fame Cisco Employee
Hall of Fame Cisco Employee

You need to explain what troubleshooting have you done, and EXACTLY, what is not working????

Calls between phones??? to PSTN??? registration???

Your config doesn't even seem to be CME or SRST, which means that your phones are using something else to register to, and the ISR config would not provide any details, without knowing EXACTLY how it ties to the problem.

Just saying something "does not work" without any further details, is futile.

HTH

java

if this helps, please rate
Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Recognize Your Peers