cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1938
Views
0
Helpful
8
Replies

Prefix to missed call - > missed calls directory

Emmanuel Vilela
Level 1
Level 1

Hi guys,

When i call my desk phone, and I do not answer, the button "redial" works perfectly

But when i go to the missed calls directory, and that I take a missed call there is a day or two, the button redial don't work.

how is it possible ?

My phone : 7911

Regards,

Emmanuel



1 Accepted Solution

Accepted Solutions

Chris Deren
Hall of Fame
Hall of Fame

Emmanuel,

Redial calls the number you dialed last, missed calls shows inbound calls.

Is if your question is how to automatically prefix off-net access code to call logs this has been asked 100s of times here, so try searching the forum.  The answer depends on few things:

version of CUCM

what protocol is user to control the GW calls are coming from, SIP vs. H323 vs. MGCP

HTH,

Chris

View solution in original post

8 Replies 8

Chris Deren
Hall of Fame
Hall of Fame

Emmanuel,

Redial calls the number you dialed last, missed calls shows inbound calls.

Is if your question is how to automatically prefix off-net access code to call logs this has been asked 100s of times here, so try searching the forum.  The answer depends on few things:

version of CUCM

what protocol is user to control the GW calls are coming from, SIP vs. H323 vs. MGCP

HTH,

Chris

Hi Chris,

Thank you for ur help, but isn't how to add a prefix to misses calls, because i know that, but i want to know how is possible to redial a dial work from the main screen, but when i go to the missed call directory, the missed calls don't work

It's a H323 GW

8.5 CUCM

Thanks a lot.

Regards

Emmanuel

Please provide more infos:

- What happen when you try to dial?

- The call goes to the PSTN Gateway?

- Do you hear any error message?

- How the number appears at the "Missed calls" list?

- Did you add a prefix to it? Or do you have a route pattern for it?

There are a few ways you can do this..

Please look at this thread and you will see the options to configuring this here..

https://supportforums.cisco.com/message/3732599#3732599

Please rate all useful posts

"'Nature is too thin a screen, the glory of the omnipresent God bursts through it everywhere"-Ralph Waldo Emerson

Please rate all useful posts

Emmanuel Vilela
Level 1
Level 1

Hi guys,

Thanks for u help

I found a solution, service entrprise, ip cm, service cm, advanced and -> incoming calling party national number prefix - phone and i add 0.

Like it when the person receives a call on his phone he sees the number with a 0 in addition, and the redial will work perfectly

This idea has alot of negatives to it and its a bad way to do this

What happens if a user gets a missed call that is an international numnber...Then a "0" will be prefixed to it also and when the user tries to dial, it wont work.

What happens if its a long distance number that needs a different prefix, then this will fial again..

Dont just jump at what people say or tell you to do, think of the implications and have a broader view...

Please rate all useful posts

"'Nature is too thin a screen, the glory of the omnipresent God bursts through it everywhere"-Ralph Waldo Emerson

Please rate all useful posts

Emmanuel Vilela
Level 1
Level 1

Hi,

Okay i did not know this feature was so wrong.

Yes, I'll try to adjust it.

So, when I use the method  =

http://www.cisco.com/en/US/products/sw/voicesw/ps556/products_tech_note09186a00805b6f33.shtml

In order ;

Internally the number of my contact is 1385 is the phone partition is PT-INTERNATIONAL

I create a PT-MISSEDCALLS

I created a CSS-MISSEDCALLS

I create a translation pattern;

13XX, PT-MISSEDCALLS, CSS INTERNATIONAL, Route this pattern, i check the box "Using calling ..." and calling party transform mask i put: 0XXXXXXXXXX (I'm french, French number is for exmple 0145763498), so ten X

After that I go to the gtw and I change the css, which is the base CSS-LOCAL, I change with my CSS-MISSEDCALLS which contains ONLY the PT-MISSEDCALLS

And even as its does not work, what's wrong please?

Clarification, I am new to the world of Cisco VoIP, excuse my ignorance

Thanks

Emmanuel,

This method is similar to the previous method...

It is the second link on that thread I wanted you to use.. Here it is,,

Configure your ingress GW with 

"Incoming Calling Party Settings" to prefix appropriate digits for local/National/Intl/Unkown calls i.e. 91 for National calls in US assuming 9 is used as off-net access code, then I default the "Use Device Pool Calling Party Transformation CSS" and define proper Transformation CSS in DP, then I have corresponding calling transformation patterns such as 9.1[2-9]XX[2-9]XXXXXX for National routing that strips pre-dot, this way when call hits the phone it arrives without the 9 as it was routed via the calling transformation pattern, but calling party transformations do not affect call logs, so in call log you see the 9 and dialing works natively.

Here is the link to the SRND that explains it better...

http://www.cisco.com/en/US/docs/voice_ip_comm/cucm/srnd/8x/dialplan.html#wp1291610

Please rate all useful posts

"'Nature is too thin a screen, the glory of the omnipresent God bursts through it everywhere"-Ralph Waldo Emerson

Please rate all useful posts