Showing results for 
Search instead for 
Did you mean: 

PRI and SIP Trunk to UCM and Ringback


I have the following setup

PSTN (PRI) --> 2951 <---(SIP TRUNK)---> CUCM 7.1.5 <---(SCCP)---> VG224 --> Analog Device / phone

Call comes in to analog device on vg224.  Analog device performs a hookflash transfer.  The following is an example of what happens and outlines the issues.

I have the following setup and issue:

calling – 403 555 1111 (PSTN)

called – 403 555 2222 (3 digits passed to gateway from PRI ‘300’ and translated to internal hunt pilot 123 456 7890)

Hunt pilot --> Line Group (top down) and hits port 2/0 on VG224 (sccp gateway) with extension 123 456 0001

111 181 1300 (actually 111 181 6951) answers the call….

After user input (3 digit extension or says name) 123 456 0001 performs a hookflash transfer


- caller at PSTN MAY or MAY NOT hear MoH

- analog device dials dials transfer party extension YYY (which is translated to 123 456 0YYY which is the actual extension)

- analog device hangs up completing the transfer

123 456 0YYY is now ringing but the user at PSTN hears nothing

Call connects (if user stays on the line) or user hangs up as they assume it doesn’t work.

ANY help would be greatly appreciated.

2 Replies 2



So basically callers over the SIP trunk does not hear ringback. You can try this

Navigate to System>>service parameters>>Call Manager

Under Send H225UserInfoMessage parameter, select "Use ANN for ringback" and make sure that the SIP trunk has an MRGL with the access to an Annunciator. You can also try taking packet capture on the CUCM when the user has called in and is getting transferred. Check whether CUCM is generating ringback or not. This would help us isolate the issue further.




PS:Pl rate helpful posts

Thanks for the response!  That actually helped my isolate the problem...actually, problemS!

1.  Hit bug CSCtl21854.  Updated IOS and ring back on initial hold works.  After transfer initiator dropped off (blind transfer), still got the silence.

2.  Network locale set for WRONG country.  I am in Canada and the default locale was set to Canada BUT the Canada locale was not installed.  Installed Canada locale, rebooted cluster and all is well again.

Thanks for the response, led to the answer.


Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community: