cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

1205
Views
0
Helpful
8
Replies
Highlighted

PRI backup dial-peer "No matching dial-peer" problem

Hi guys. we have cisco 2911 with SIP trunk to CUCM and   PRi to PSTN, I was testing calls through it and  keep getting "No matching dial-peer"  . As you see below there are dial-peers ...  I've never had sip  gw with pri trunk I am not sure do I need to add this pri card on CUCM ?  will it resolve the issue or the cause is different ? 

Thank you

sho run | se dial-pe
dial-peer voice 11033 pots
destination-pattern 11033
port 0/2/0
dial-peer voice 11807 pots
destination-pattern 11807
port 0/2/2
dial-peer voice 11098 pots
destination-pattern 11098
port 0/2/1
dial-peer voice 9904 pots
description Incoming DP
incoming called-number .
port 0/0/0:23


dial-peer voice 911 pots
description 911 Emergency
translation-profile outgoing PSTN-OUT
destination-pattern 911
port 0/0/0:23
forward-digits 3


dial-peer voice 901 pots
description 11 Digit Long Distance
translation-profile outgoing PSTN-OUT
destination-pattern 91[2-9]..[2-9]......$
port 0/0/0:23
forward-digits 11


dial-peer voice 902 pots
description 10 Digit Local
destination-pattern 9[2-9]..[2-9]......$
port 0/0/0:23
forward-digits 10


dial-peer voice 903 pots
description International Dialing
translation-profile outgoing PSTN-OUT
destination-pattern 9011T
port 0/0/0:23
prefix 011


dial-peer voice 9911 pots
description 911 Emergency
destination-pattern 9911
port 0/0/0:23
forward-digits 3


dial-peer voice 101 pots
description INCOMING CALLS FROM PSTN
direct-inward-dial
port 0/0/0:23

dial-peer voice 102 voip
description Inbound DP from CUCM Cluster
session protocol sipv2
session transport udp
incoming called-number 9T
voice-class codec 100
voice-class sip bind control source-interface GigabitEthernet0/0
voice-class sip bind media source-interface GigabitEthernet0/0
dtmf-relay rtp-nte
fax-relay sg3-to-g3
fax protocol t38 version 0 ls-redundancy 0 hs-redundancy 0 fallback pass-through g711ulaw
ip qos dscp af41 signaling
no vad

debug ccsip messages: 

Received:
INVITE sip:93472380384@10.132.6.4:5060 SIP/2.0
Via: SIP/2.0/TCP 10.132.28.13:5060;branch=z9hG4bK241cc9570eae15
From: "John Dow" <sip:2122205273@10.132.28.13>;tag=41667233~42958033-5274-4a26-8d3d-befea4dfdd91-17527494
To: <sip:93472380384@10.132.6.4>
Date: Wed, 25 Jan 2017 16:22:30 GMT
Call-ID: 7695ac80-8881d0c6-17bf09-d1c840a@10.132.28.13
Supported: timer,resource-priority,replaces
Min-SE: 1800
User-Agent: Cisco-CUCM10.5
Allow: INVITE, OPTIONS, INFO, BYE, CANCEL, ACK, PRACK, UPDATE, REFER, SUBSCRIBE, NOTIFY
CSeq: 101 INVITE
Expires: 180
Allow-Events: presence, kpml
Supported: X-cisco-srtp-fallback,X-cisco-original-called
Call-Info: <sip:10.132.28.13:5060>;method="NOTIFY;Event=telephone-event;Duration=500"
Cisco-Guid: 1989520512-0000065536-0000004175-0219972618
Session-Expires: 1800
P-Asserted-Identity: "John Dow" <sip:2122205273@10.132.28.13>
Remote-Party-ID: "John Dow" <sip:2122205273@10.132.28.13>;party=calling;screen=yes;privacy=off
Contact: <sip:2122205273@10.132.28.13:5060;transport=tcp>;+u.sip!devicename.ccm.cisco.com="SEP5006AB8060D6"
Max-Forwards: 69
Content-Type: application/sdp
Content-Length: 203

v=0
o=CiscoSystemsCCM-SIP 41667233 1 IN IP4 10.132.28.13
s=SIP Call
c=IN IP4 10.132.27.4
t=0 0
m=audio 27020 RTP/AVP 0 101
a=rtpmap:0 PCMU/8000
a=rtpmap:101 telephone-event/8000
a=fmtp:101 0-15

Jan 25 16:22:30.188: //17790/7695AC800000/SIP/Msg/ccsipDisplayMsg:
Sent:
SIP/2.0 100 Trying
Via: SIP/2.0/TCP 10.132.28.13:5060;branch=z9hG4bK241cc9570eae15
From: "John Dow" <sip:2122205273@10.132.28.13>;tag=41667233~42958033-5274-4a26-8d3d-befea4dfdd91-17527494
To: <sip:93472380384@10.132.6.4>
Date: Wed, 25 Jan 2017 16:22:30 GMT
Call-ID: 7695ac80-8881d0c6-17bf09-d1c840a@10.132.28.13
CSeq: 101 INVITE
Allow-Events: telephone-event
Server: Cisco-SIPGateway/IOS-15.4.3.M2

Content-Length: 0


Jan 25 16:22:30.192: //17790/7695AC800000/SIP/Msg/ccsipDisplayMsg:
Sent:
SIP/2.0 404 Not Found
Via: SIP/2.0/TCP 10.132.28.13:5060;branch=z9hG4bK241cc9570eae15
From: "John Dow" <sip:2122205273@10.132.28.13>;tag=41667233~42958033-5274-4a26-8d3d-befea4dfdd91-17527494
To: <sip:93472380384@10.132.6.4>;tag=8C601BF8-45A
Date: Wed, 25 Jan 2017 16:22:30 GMT
Call-ID: 7695ac80-8881d0c6-17bf09-d1c840a@10.132.28.13
CSeq: 101 INVITE
Allow-Events: telephone-event
Warning: 399 10.132.6.4 "No matching outgoing dial-peer"
Server: Cisco-SIPGateway/IOS-15.4.3.M2
Reason: Q.850;cause=1
Content-Length: 0


Jan 25 16:22:30.212: //-1/xxxxxxxxxxxx/SIP/Msg/ccsipDisplayMsg:
Received:
ACK sip:93472380384@10.132.6.4:5060 SIP/2.0
Via: SIP/2.0/TCP 10.132.28.13:5060;branch=z9hG4bK241cc9570eae15
From: "John Dow" <sip:2122205273@10.132.28.13>;tag=41667233~42958033-5274-4a26-8d3d-befea4dfdd91-17527494
To: <sip:93472380384@10.132.6.4>;tag=8C601BF8-45A
Date: Wed, 25 Jan 2017 16:22:30 GMT
Call-ID: 7695ac80-8881d0c6-17bf09-d1c840a@10.132.28.13
User-Agent: Cisco-CUCM10.5
Max-Forwards: 70
CSeq: 101 ACK
Allow-Events: presence, kpml
Content-Length: 0

Everyone's tags (4)
1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
VIP Mentor

Your issue seems to be with

Your issue seems to be with your ISDN. The ISDN is not up hence the dial-peer associated with the D-channel most likely is down. 

NANYGTW01#sho isnd    dn status
Global ISDN Switchtype = primary-ni
ISDN Serial0/0/0:23 interface
	dsl 0, interface ISDN Switchtype = primary-ni
    Layer 1 Status:
	ACTIVE
    Layer 2 Status:
	TEI = 0, Ces = 1, SAPI = 0, State = AWAITING_ESTABLISHMEN

You can verify the status of dial-peers  by running the command

sh dial-p v summ

You need to fix your ISDN issue, then test again.

Please rate all useful posts

View solution in original post

8 REPLIES 8
Highlighted
Rising star

If you are sending the calls

If you are sending the calls to CUCM via SIP where is the VOIP dial-peer on gateway with session targert ipv4: CUCM IP address ?

Highlighted

u r right, its missing , i

u r right, its missing , i should have something like this :

destination-pattern [1,2][0,1,2,4]...$

session protocol sipv2
session target ipv4:10.132.28.13
voice-class codec 100

But I was testing from inside by dialing to PSTN number . Does voip-dial peer to CUCM involved in this case ? 

Highlighted
Rising star

Yes, for outbound it is not

Yes, for outbound it is not needed as you already have an incoming voip dial-peer.

Have you tried debug voip dialpeer and debug isdn to see if it is trying to go out.

I have had PRI ---SIP gateway-CUCM topology and it worked fine without any CUCM config needed.

Highlighted
VIP Mentor

No, If this is an outbound

No, If this is an outbound call as you are testing then your configuration looks correct.

Can you please do another test call and send us the following

sh isdn status

debug ccsip mess

debug isdn q931

can you also run this command

show dialplan number 93472380384

Please rate all useful posts
Highlighted

I attached debugs. Thank you

I attached debugs. Thank you guys for help. 

Highlighted
VIP Mentor

Your issue seems to be with

Your issue seems to be with your ISDN. The ISDN is not up hence the dial-peer associated with the D-channel most likely is down. 

NANYGTW01#sho isnd    dn status
Global ISDN Switchtype = primary-ni
ISDN Serial0/0/0:23 interface
	dsl 0, interface ISDN Switchtype = primary-ni
    Layer 1 Status:
	ACTIVE
    Layer 2 Status:
	TEI = 0, Ces = 1, SAPI = 0, State = AWAITING_ESTABLISHMEN

You can verify the status of dial-peers  by running the command

sh dial-p v summ

You need to fix your ISDN issue, then test again.

Please rate all useful posts

View solution in original post

Highlighted

u right, outgoing dial-peers

u right, outgoing dial-peers are down, debug isdn q921 and 931 shows 

Q931: Ux_DLRelInd: DL_REL_IND received from L2
Jan 26 14:41:37.029: ISDN Se0/0/0:23 Q921: L2_EstablishDataLink: sending SABME
Jan 26 14:41:37.029: ISDN Se0/0/0:23 Q921: User TX -> SABMEp sapi=0 tei=0
Jan 26 14:41:38.029: ISDN Se0/0/0:23 Q921: User TX -> SABMEp sapi=0 tei=0

we are not getting RX from SP and L2 is down. 

I put t1 controller to loopback local line and payload  => getting same messages NO RX and show isdn status just become TEI_ASSIGNED. 

on loopback debug with clock internal :

User TX -> SABMEp sapi=0 tei=0
Jan 26 20:35:10.670: ISDN Se0/0/0:23 Q921: User RX <- BAD FRAME(0x00017F)

Does this mean something wrong on my side ? if yes, what should I check ?

  do sho controller t1
T1 0/0/0 is up. (Local Payload Loopback, using line clock)
Applique type is Channelized T1
Cablelength is long 0db
Receiver has no alarms.
alarm-trigger is not set
Soaking time: 3, Clearance time: 10
AIS State:Clear LOS State:Clear LOF State:Clear
Version info FPGA Rev: 08121917, FPGA Type: PRK1
Framing is ESF, Line Code is B8ZS, Clock Source is Line.
CRC Threshold is 320. Reported from firmware is 320.
Data in current interval (831 seconds elapsed):
1 Line Code Violations, 8 Path Code Violations
104 Slip Secs, 2 Fr Loss Secs, 1 Line Err Secs, 0 Degraded Mins
105 Errored Secs, 0 Bursty Err Secs, 2 Severely Err Secs, 0 Unavail Secs
Total Data (last 24 hours)
0 Line Code Violations, 9 Path Code Violations,
10695 Slip Secs, 2 Fr Loss Secs, 0 Line Err Secs, 0 Degraded Mins,
10696 Errored Secs, 0 Bursty Err Secs, 2 Severely Err Secs, 0 Unavail Secs
 

Thank you 

Highlighted

As I found out it's normal

As I found out it's normal when u get Bad frame during loopback diagn, this is because gateway is getting back its own messages . Career bounced their side and D channel established ,L2  State MULTIPLE_FRAME_ESTABLISHED, L3 is active, calls goes trough. 

Thank you everyone for help. 

CreatePlease to create content
Content for Community-Ad

Cisco COVID-19 Survey