cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
Walkthrough Wednesdays
649
Views
0
Helpful
6
Replies
BEG_Tal
Enthusiast

PRI / DID Can not Call IP PHONE

Hello,

I have a PRI line and i want to cofnigıre  444 XXXX  DID  number IPT Line

When I called 444 XXXX ,calls ring one time and end.

Ex: if outbound  calls PRI line , it should be ring 8945

Here is my voice gateway config

redundancy

!

!

controller E1 0/0/0

pri-group timeslots 1-31 service mgcp

!

controller E1 0/0/1

shutdown

framing NO-CRC4

clock source internal

!

ip ftp username ftpdestekhiz

ip ftp password 7 01425F570C1F14

!

!

!

!

interface Embedded-Service-Engine0/0

no ip address

shutdown

!

interface GigabitEthernet0/0

ip address 192.168.5.201 255.255.255.0

duplex auto

speed auto

!

interface GigabitEthernet0/1

no ip address

shutdown

duplex auto

speed auto

!

interface GigabitEthernet0/2

no ip address

shutdown

duplex auto

speed auto

!

interface Serial0/0/0:15

no ip address

encapsulation hdlc

isdn switch-type primary-net5

isdn incoming-voice voice

isdn bind-l3 ccm-manager

isdn bchan-number-order ascending

isdn sending-complete

no cdp enable

!

interface BRI0/1/0

no ip address

isdn switch-type basic-net3

isdn point-to-point-setup

isdn bind-l3 ccm-manager service mgcp

!

interface BRI0/1/1

no ip address

isdn switch-type basic-net3

isdn point-to-point-setup

!

ip default-gateway 192.168.5.254

ip forward-protocol nd

!

no ip http server

no ip http secure-server

!

ip route 0.0.0.0 0.0.0.0 192.168.5.254

ip route 10.10.10.0 255.255.255.0 192.168.1.253

!

!

!

!

control-plane

!

!

voice-port 0/0/0:15

echo-cancel coverage 64

cptone TR

!

voice-port 0/1/0

disc_pi_off

echo-cancel coverage 64

cptone TR

timeouts call-disconnect 5

timeouts wait-release 1

!

voice-port 0/1/1

!

voice-port 0/2/0

supervisory disconnect anytone

echo-cancel coverage 64

no vad

cptone TR

timeouts call-disconnect 5

timeouts wait-release 1

timing hookflash-out 50

timing sup-disconnect 1000

connection plar 4000

description TT_Line

caller-id enable

!

voice-port 0/2/1

supervisory disconnect anytone

echo-cancel coverage 64

no vad

cptone TR

timeouts call-disconnect 5

timeouts wait-release 1

timing hookflash-out 50

timing sup-disconnect 1000

description TT_Line

caller-id enable

!

voice-port 0/2/2

supervisory disconnect anytone

echo-cancel coverage 64

no vad

cptone TR

timeouts call-disconnect 5

timeouts wait-release 1

timing hookflash-out 50

timing sup-disconnect 1000

description TT_Line

caller-id enable

!

voice-port 0/2/3

supervisory disconnect anytone

echo-cancel coverage 64

no vad

cptone TR

timeouts call-disconnect 5

timeouts wait-release 1

timing hookflash-out 50

timing sup-disconnect 1000

description TT_Line

caller-id enable

!

voice-port 0/3/0

echo-cancel coverage 64

no vad

cptone TR

timeouts call-disconnect 5

timeouts wait-release 1

caller-id enable

!

voice-port 0/3/1

echo-cancel coverage 64

no vad

cptone TR

timeouts call-disconnect 5

timeouts wait-release 1

caller-id enable

!

voice-port 0/3/2

echo-cancel coverage 64

no vad

compand-type a-law

cptone TR

timeouts call-disconnect 5

timeouts wait-release 1

caller-id enable

!

voice-port 0/3/3

echo-cancel coverage 64

no vad

cptone TR

timeouts call-disconnect 5

timeouts wait-release 1

caller-id enable

!

voice-port 1/0/0

supervisory disconnect anytone

echo-cancel coverage 64

no vad

cptone TR

timeouts call-disconnect 5

timeouts wait-release 1

timing hookflash-out 50

timing sup-disconnect 1000

description TT_Line

caller-id enable

voice-port 1/0/0

supervisory disconnect anytone

echo-cancel coverage 64

no vad

cptone TR

timeouts call-disconnect 5

timeouts wait-release 1

timing hookflash-out 50

timing sup-disconnect 1000

description TT_Line

caller-id enable

!

voice-port 1/0/1

supervisory disconnect anytone

echo-cancel coverage 64

no vad

cptone TR

timeouts call-disconnect 5

timeouts wait-release 1

timing hookflash-out 50

timing sup-disconnect 1000

connection plar opx 4061

description TT_Line

caller-id enable

!

voice-port 1/0/2

supervisory disconnect anytone

echo-cancel coverage 64

no vad

cptone TR

timeouts call-disconnect 5

timeouts wait-release 1

timing hookflash-out 50

timing sup-disconnect 1000

connection plar 4000

description TT_Line

caller-id enable

!

voice-port 1/0/3

supervisory disconnect anytone

echo-cancel coverage 64

no vad

cptone TR

timeouts call-disconnect 5

timeouts wait-release 1

timing hookflash-out 50

timing sup-disconnect 1000

connection plar opx 4061

description TT_Line

caller-id enable

!

voice-port 1/1/0

supervisory disconnect anytone

echo-cancel coverage 64

no vad

cptone TR

timeouts call-disconnect 5

timeouts wait-release 1

timing hookflash-out 50

timing sup-disconnect 1000

connection plar opx 4061

description TT_Line

caller-id enable

!

voice-port 1/1/1

supervisory disconnect anytone

echo-cancel coverage 64

no vad

cptone TR

timeouts call-disconnect 5

timeouts wait-release 1

timing hookflash-out 50

timing sup-disconnect 1000

connection plar opx 4061

description TT_Line

caller-id enable

!

voice-port 1/1/2

supervisory disconnect anytone

echo-cancel coverage 64

no vad

cptone TR

timeouts call-disconnect 5

timeouts wait-release 1

timing hookflash-out 50

timing sup-disconnect 1000

connection plar opx 4061

description TT_Line

caller-id enable

!

voice-port 1/1/3

supervisory disconnect anytone

echo-cancel coverage 64

no vad

cptone TR

timeouts call-disconnect 5

timeouts wait-release 1

timing hookflash-out 50

timing sup-disconnect 1000

connection plar 4061

description TT_Line

caller-id enable

!

!

!

!

ccm-manager mgcp

no ccm-manager fax protocol cisco

ccm-manager music-on-hold

ccm-manager config server 192.168.5.200

ccm-manager config

!

mgcp

mgcp call-agent 192.168.5.200 2427 service-type mgcp version 0.1

mgcp dtmf-relay voip codec all mode out-of-band

mgcp rtp unreachable timeout 1000 action notify

mgcp playout fixed 80

mgcp package-capability rtp-package

mgcp package-capability sst-package

mgcp package-capability pre-package

no mgcp package-capability res-package

no mgcp package-capability fxr-package

no mgcp timer receive-rtcp

mgcp sdp simple

mgcp fax t38 inhibit

no mgcp explicit hookstate

mgcp rtp payload-type g726r16 static

mgcp bind control source-interface GigabitEthernet0/0

!

mgcp profile default

!

!

dial-peer voice 999020 pots

service mgcpapp

port 0/2/0

!

dial-peer voice 999022 pots

service mgcpapp

port 0/2/2

!

dial-peer voice 999021 pots

service mgcpapp

port 0/2/1

!

dial-peer voice 999030 pots

service mgcpapp

port 0/3/0

!

dial-peer voice 999031 pots

service mgcpapp

port 0/3/1

!

dial-peer voice 999032 pots

service mgcpapp

port 0/3/2

!

dial-peer voice 999033 pots

service mgcpapp

port 0/3/3

!

dial-peer voice 999023 pots

service mgcpapp

port 0/2/3

!

dial-peer voice 999100 pots

service mgcpapp

port 1/0/0

!

dial-peer voice 999101 pots

service mgcpapp

port 1/0/1

!

dial-peer voice 999102 pots

service mgcpapp

port 1/0/2

!

dial-peer voice 999103 pots

service mgcpapp

port 1/0/3

!

dial-peer voice 999110 pots

service mgcpapp

port 1/1/0

!

dial-peer voice 999111 pots

service mgcpapp

port 1/1/1

!

dial-peer voice 999112 pots

service mgcpapp

port 1/1/2

!

dial-peer voice 999113 pots

service mgcpapp

port 1/1/3

!

dial-peer voice 1 pots

preference 1

service mgcpapp

incoming called-number .T

direct-inward-dial

port 0/3/0

forward-digits all

!

dial-peer voice 2 voip

destination-pattern 4...

session protocol sipv2

session target ipv4:192.168.1.230

dtmf-relay sip-notify h245-alphanumeric

codec g711ulaw

!

dial-peer voice 15 voip

destination-pattern 4000

session protocol sipv2

session target ipv4:192.168.5.200

dtmf-relay rtp-nte

codec g711ulaw

!

6 REPLIES 6
Chris Deren
Hall of Fame Master

Which PRI is the call arring on as your 0/0/0 is not configured with same framing as 0/0/1, and 0/0/1 is in shutdown mode.

Can you post "debug isdn q931" for the call?

Chris

Hello,

sorry for wrong info,  DID come  via anaolog   line and it plugged FXO port voice gateway,

Call is ringing one time and it end, i can not receive debug q931 any log when i called 444 XXX number

but also  called other number i can receive debug

show voice call

1/1/2 -          -  -                     vpm level 1 state = FXOLS_ONHOOK

vpm level 0 state = S_UP

calling number 05xxxxxxx, calling name , calling time 06/05 14:49

1/1/3 -          -  -                     vpm level 1 state = FXOLS_ONHOOK

vpm level 0 state = S_UP

calling number 77777 , calling name , calling time 05/30 13:52

Chris Deren
Hall of Fame Master

Are you sure the ports are loop start and not ground start?

Can you provide screen shot of port 1/1/2? Do you have attendant destination defined? What is it pointing to?

Does the CSS applied to this port lists partition assigned to the destination DN?

Chris

port 1/1/2

voice-port 1/1/2

supervisory disconnect anytone

echo-cancel coverage 64

no vad

cptone TR

timeouts call-disconnect 5

timeouts wait-release 1

timing hookflash-out 50

timing sup-disconnect 1000

description TT_Line

caller-id enable

This is my working call process output

VGW01(config-voiceport)#

Jun  6 16:57:39.871: ISDN Se0/0/0:15 Q931: RX <- SETUP pd = 8  callref = 0x1634

        Sending Complete

        Bearer Capability i = 0x8090A3

                Standard = CCITT

                Transfer Capability = Speech

                Transfer Mode = Circuit

                Transfer Rate = 64 kbit/s

        Channel ID i = 0xA98382

                Exclusive, Channel 2

        Calling Party Number i = 0x0081, '0555555555'

                Plan:Unknown, Type:Unknown

        Called Party Number i = 0xC1, '777777'

                Plan:ISDN, Type:Subscriber(local)

        High Layer Compat i = 0x9181

Jun  6 16:57:39.883: ISDN Se0/0/0:15 Q931: TX -> CALL_PROC pd = 8  callref = 0x9634

        Channel ID i = 0xA98382

                Exclusive, Channel 2

Jun  6 16:57:39.883: ISDN Se0/0/0:15 Q931: TX -> ALERTING pd = 8  callref = 0x9634

        Progress Ind i = 0x8088 - In-band info or appropriate now available

Jun  6 16:57:45.711: ISDN Se0/0/0:15 Q931: RX <- DISCONNECT pd = 8  callref = 0x1634

        Cause i = 0x8090 - Normal call clearing

Jun  6 16:57:45.727: ISDN Se0/0/0:15 Q931: TX -> RELEASE pd = 8  callref = 0x9634

Jun  6 16:57:45.743: ISDN Se0/0/0:15 Q931: RX <- RELEASE_COMP pd = 8  callref = 0x1634

But when i call 444 7777 number i can not receive any debuq output  with debug isdn q931

Not CSS and partion assigned any number,

because our local DN configure not assign CSS/Partition

When i called 444 7777 number one time call and called number connected bbut calling number end a few second lated disconnected

i think problem is  related FXO port because i did configure loopstart and groundstart FXO  port

When i configure loopstart,port  auto answer and call is is immidiately end, if i configure groundstart , i hear ring tone but DN is not ringing,

Chris Deren
Hall of Fame Master

Check your cable polarity, reverse the pair as ground start signaling is polarity sensitive.

Are you saying that in CallManager all DNs are in none partition?

Chris

Content for Community-Ad

Spotlight Awards 2021