cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
Walkthrough Wednesdays
645
Views
5
Helpful
8
Replies
Highlighted
Beginner

PRI Frame establishment

Odd problem here.  Trying to connect to our telco with a PRI on a 2911 h323 gateway. Pretty basic config and I'm no expert troubleshooting the voice side yet. 

Cannot get frame established.

    Layer 2 Status:

        TEI = 0, Ces = 1, SAPI = 0, State = TEI_ASSIGNED

Debug isdn q921

Mar  4 21:14:40.884: ISDN Se0/1/0:23 Q921: L2_EstablishDataLink: sending SABME

Mar  4 21:14:40.884: ISDN Se0/1/0:23 Q921: User TX -> SABMEp sapi=0 tei=0

Mar  4 21:14:41.884: ISDN Se0/1/0:23 Q921: User TX -> SABMEp sapi=0 tei=0

Mar  4 21:14:42.884: ISDN Se0/1/0:23 Q921: User TX -> SABMEp sapi=0 tei=0

Mar  4 21:14:43.884: ISDN Se0/1/0:23 Q921: User TX -> SABMEp sapi=0 tei=0

Mar  4 21:14:49.884: ISDN Se0/1/0:23 Q921: L2_EstablishDataLink: sending SABME

Mar  4 21:14:49.884: ISDN Se0/1/0:23 Q921: User TX -> SABMEp sapi=0 tei=0

Could this be a cabling issue?  Not sure where else to look.  Telco basically told me to fix it.

Any help would be appreciated.

8 REPLIES 8
Highlighted

Hi,

make sure the config is correct, the framing type and CRC, isdn switch type. also check the cable

HTH

Anas

please rate if it is helpful

Highlighted
Hall of Fame Master

You are not receiving anything from telco, can be cable, can be provisioning (i.e. switch type, framing, line code), can be that telco has not confifured the circuit. Switch cable, if that does not help, call telco and troubelshoot with them.

HTH,

Chris

Highlighted
Beginner

Thanks, that part is working now.  Thnk you can help me with the rest. I've always used mgcp and the h323 is a bit different.  Trying to get inbound calling working.  I have 5 digit extensions that are 7 then the last 4 of the incoming number.  Here is what I have so far.

Building configuration...

!

boot-start-marker

boot-end-marker

!

!

card type t1 0 0

card type t1 0 1

enable secret 4 qVmJrFcea5.ijlV9XAGG3CHoUtTtp7VJvv3N6SlmCzc

!

no aaa new-model

no network-clock-participate wic 0

network-clock-participate wic 1

network-clock-select 1 T1 0/1/0

!

no ipv6 cef

ip source-route

ip cef

!

!

!

!

multilink bundle-name authenticated

!

!

!

!

isdn switch-type primary-ni

!

crypto pki token default removal timeout 0

!        

!

voice-card 0

!

!

!

voice service voip

ip address trusted list

  ipv4 10.5.1.15

  ipv4 10.5.1.16

  ipv4 10.2.100.14

fax protocol t38 version 0 ls-redundancy 0 hs-redundancy 0 fallback none

h323

  no call service stop

!

voice class h323 1

  h225 timeout tcp establish 3

!

!

!

!

voice translation-rule 1

rule 1 /^xxxxxxx\(6...$\)/ /7\1/

!

!

voice translation-profile INCOMING

translate called 1

!

!

license udi pid CISCO2911/K9 sn FTX1706AKHA

hw-module pvdm 0/0

!

!

!

!

redundancy

!

!

controller T1 0/0/0

cablelength long 0db

channel-group 0 timeslots 1-24

!

controller T1 0/1/0

cablelength long 0db

pri-group timeslots 1-24

!

!

!

!        

!

interface Embedded-Service-Engine0/0

no ip address

shutdown

!

interface GigabitEthernet0/0

no ip address

duplex auto

speed auto

!

interface GigabitEthernet0/0.1

description ***Data***

encapsulation dot1Q 1 native

ip address 10.16.28.1 255.255.252.0

!

interface GigabitEthernet0/0.2

description ***Voice***

encapsulation dot1Q 2

ip address 10.24.8.1 255.255.252.0

h323-gateway voip interface

h323-gateway voip bind srcaddr 10.24.8.1

!

interface GigabitEthernet0/1

no ip address

shutdown

duplex auto

speed auto

!

interface GigabitEthernet0/2

ip address dhcp

duplex auto

speed auto

!

!

interface Serial0/1/0:23

no ip address

encapsulation hdlc

isdn switch-type primary-ni

isdn incoming-voice voice

no cdp enable

!

!

ip forward-protocol nd

!

no ip http server

no ip http secure-server

!

ip route 0.0.0.0 0.0.0.0 10.16.28.2

!

!

!

!

control-plane

!

!

voice-port 0/1/0:23

!

!

!

mgcp profile default

!

!

dial-peer voice 101 voip

description To callManager Subscriber

preference 1

destination-pattern 76...

progress_ind setup enable 3

session target ipv4:10.5.1.15

dtmf-relay h245-alphanumeric

codec g711ulaw

ip qos dscp cs5 media

ip qos dscp cs3 signaling

no vad

!

dial-peer voice 102 voip

description To callManager Publisher

preference 2

destination-pattern 76...

progress_ind setup enable 3

session target ipv4:10.5.1.16

dtmf-relay h245-alphanumeric

codec g711ulaw

ip qos dscp cs5 media

ip qos dscp cs3 signaling

no vad

!

dial-peer voice 999 pots

translation-profile incoming INCOMING

incoming called-number 7....

!

!

gateway  

timer receive-rtp 1200

!

!

Highlighted

How many digits is telco sending?

Can you post "debug isdn q931"?

Chris

Highlighted
Beginner

Thanks for the help Chris.  They are sending 10 digits. 

Nothing on the debug at the moment, guess telco is playing with it.

Highlighted
Beginner

Here is the debug.

Mar  4 22:18:41.520: ISDN Se0/1/0:23 Q931: RX <- SETUP pd = 8  callref = 0x0015

        Bearer Capability i = 0x8090A2

                Standard = CCITT

                Transfer Capability = Speech 

                Transfer Mode = Circuit

                Transfer Rate = 64 kbit/s

        Channel ID i = 0xA98397

                Exclusive, Channel 23

        Facility i = 0x9F8B0100A1080201010201008400

                Protocol Profile =  Networking Extensions

                0xA1080201010201008400

                Component = Invoke component

                        Invoke Id = 1

                        Operation = CallingName

                                Name not available

        Calling Party Number i = 0x2180, '6979'

                Plan:ISDN, Type:National

        Called Party Number i = 0xA1, '2108196640'

                Plan:ISDN, Type:National

Mar  4 22:18:41.520: ISDN Se0/1/0:23 Q931: Received SETUP  callref = 0x8015 callID = 0x002C switch = primary-ni interface = User

Mar  4 22:18:41.524: ISDN Se0/1/0:23 Q931: TX -> CALL_PROC pd = 8  callref = 0x8015

        Channel ID i = 0xA98397

                Exclusive, Channel 23

Mar  4 22:18:41.524: ISDN Se0/1/0:23 Q931: TX -> DISCONNECT pd = 8  callref = 0x8015

        Cause i = 0x8081 - Unallocated/unassigned number

Mar  4 22:18:41.576: ISDN Se0/1/0:23 Q931: RX <- RELEASE pd = 8  callref = 0x0015

Mar  4 22:18:41.576: ISDN Se0/1/0:23 Q931: TX -> RELEASE_COMP pd = 8  callref = 0x8015

Mar  4 22:18:41.596: ISDN Se0/1/0:23 Q931: RX <- RESTART pd = 8  callref = 0x0000

        Channel ID i = 0xA98397

                Exclusive, Channel 23

        Restart Indicator i = 0x80

Mar  4 22:18:41.596: ISDN Se0/1/0:23 Q931: TX -> RESTART_ACK pd = 8  callref = 0x8000

        Channel ID i = 0xA98397

                Exclusive, Channel 23

        Restart Indicator i = 0x80

Highlighted

I think I got that part now.  incoming dialed-number .

Highlighted

You have couple of choices here:

1. send all 10 digits to CUCM and let CUCM either translate those to internal extensions, or use sigDigits parameter on the GW to strip digits.

2. Use translation rule on GW to massge the digits final extension and then send to CUCM via dial peer.

Which method would you like to use?

HTH, please rate all useful posts!

Chris

Content for Community-Ad