cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

2195
Views
0
Helpful
4
Replies
shabeebmohammed
Beginner

PRI ISDN call flow problem

Dear All,

Weird issue.. I have a E1 PRI line on a 3925 MGCP gateway to a CUCM 8.0.3.

  • Outbound calls does not reach the gateway at all.
  • Inbound calls reached the gateway, rings for max 1 sec and then disconnects.
      • the ISDN Q931 debug shows the following -

*Dec  9 09:29:58.123: ISDN Se0/0/0:15 Q931: RX <- SETUP pd = 8  callref = 0x0055

        Sending Complete

        Bearer Capability i = 0x8090A3

                Standard = CCITT

                Transfer Capability = Speech

                Transfer Mode = Circuit

                Transfer Rate = 64 kbit/s

        Channel ID i = 0xA18381

                Preferred, Channel 1

        Calling Party Number i = 0x2183, '99262694'

                Plan:ISDN, Type:National

        Called Party Number i = 0xA1, '313'

                Plan:ISDN, Type:National

*Dec  9 09:29:59.143: ISDN Se0/0/0:15 Q931: TX -> RELEASE_COMP pd = 8  callref =

0x8055

        Cause i = 0x80A9 - Temporary failure

I escalated the issue to the Telco and still no response. Just to be on the safe side i used a spare router (cisco 2811) with the exact same config and it worked perfectly (both in and out was succesfull)

I suspect a IOS bug or something related to the IOS. I tired the following IOS and still the same issue -

c3900-universalk9-mz.SPA.150-1.M4

c3900-universalk9-mz.SPA.151-1.T

c3900-universalk9-mz.SPA.151-3.T2

c3900-universalk9-mz.SPA.151-4.M

NB: (the IOS on the 2811 router is advancedenterprise -124-22.YB8)

I also see form the above debug that the router is sending a release complete signal as soon as the inbound call comes in.

Any help will be appreciated.

Regards,

Shabeeb


4 REPLIES 4
shabeebmohammed
Beginner

i even tried the latest firmwares -

c3900-universalk9-mz.SPA.153-1.T.bin = STILL THE SAME

tried changing the slots, VWIC card, cables etc - STILL THE SAME

any suggestions.. anyone ???

Shabeeb

Probably the default security feature for toll fraud prevention that blocks the communication. See more at this URL, http://voiceonbits.com/2010/08/19/ios-15-1-toll-fraud-feature/

Please remember to rate all useful posts.

Sent from Cisco Technical Support iPhone App



Response Signature


Please try registering a phone directly to the gateway then transfer the incoming call to him. If the call complete maybe is as Roger said cause by Toll Fraud prevention.

Regards

_____________________________
MDGDP, CCNA, CCNA Voice certified

__________________________________________________
Please remember to rate useful posts clicking on the stars below.
LinkedIn Profile: do.linkedin.com/in/leosalcie

Guys..

It was the problem with the DSPs not being detected properly by the gateway. Removed and re-insterted the PVDM, rebooted the router - All working fine now.

Thanks a ton for your suggestions.

Regards,

Shabeeb

Create
Recognize Your Peers
Content for Community-Ad