cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1633
Views
0
Helpful
19
Replies
Thiago Cella
Beginner

Problem - Module FXO 4 Ports always up (busy)

Hi,

I have 2811 with CME and a VIC2-4FXO, when someone try call to CME, always the signal is busy, on this moment there is no calls incomming to router, but 3 ports are "OPER" "UP", just one is avaible to recept calls with status "OPER" "dorm"  :

PORT            CH   SIG-TYPE   ADMIN OPER STATUS   STATUS   EC
=============== == ============ ===== ==== ======== ======== ==
0/0/0           --  fxo-ls      up    up   idle     off-hook y
0/0/1           --  fxo-ls      up    up   idle     off-hook y
0/0/2           --  fxo-ls      up    up   idle     off-hook y
0/0/3           --  fxo-ls      up    dorm idle     on-hook  y

what can i do?


19 REPLIES 19
Daniele Giordano
Rising star

Are ports connected to FXS line?

Try to unplug the cable and check again the state.

If it changes, check the number of wires in the cable. 4 wire cable cause strange behaviors. You must use 2 wire cable (ring and tip) only.

If the problem remain try a different FXO module to check an hardware fault.

Regards.

Steven Griffin
Enthusiast

Thiago,

Sounds like you have a supervisory disconnect issue.   Post a config snippet of your voice-ports.

-Steven

Please help us make the communities better. Rate helpful posts!

Follow the config, sorry for the late :

voice-port 0/0/0
supervisory disconnect anytone
cptone BR
timeouts call-disconnect 1
timeouts wait-release 1
connection plar opx 3901
station-id name LINHA-EXT 01
caller-id enable

voice-port 0/0/1
supervisory disconnect anytone
cptone BR
timeouts call-disconnect 1
timeouts wait-release 1
connection plar opx 3901
station-id name LINHA-EXT 02
caller-id enable

voice-port 0/0/2
supervisory disconnect anytone
cptone BR
timeouts call-disconnect 1
timeouts wait-release 1
connection plar opx 3901
station-id name LINHA-EXT 03
caller-id enable

voice-port 0/0/3
supervisory disconnect anytone
cptone BR
timeouts call-disconnect 1
timeouts wait-release 1
connection plar opx 3901
station-id name LINHA-EXT 04
caller-id enable

Try using "supervisory disconnect dualtone mid-call"

Why are you using opx (Off Premise Extension)?  If it is not absolutely necessary, trt configuring "connection plar 3901".

plar opx

Specifies a PLAR off-premises extension (OPX) connection. Using this  option, the local voice port provides a local response before the remote  voice port receives an answer. On Foreign Exchange Office (FXO)  interfaces, the voice port does not answer until the remote side has  answered.

If you are still having ports remain off-hook post a file that contains the contents of a "debug vpm all"  command when calling into or out of a FXO port configured for 3901.

Please help us make the communities better. Rate helpful posts!

Can you post your sh verson of router ?

VIkrant

Thiago Cella
Beginner


uscitizen,


i tried the command "supervisory disconnect dualtone mid-call", but no sucess, sincerilly i dont know
why the opx  is enable;

oddly the router is rebooting , generating crash files, and when i active any debug , nothing happens

this router is strange

VIkrant,

follow the show ver :

Cisco IOS Software, 2801 Software (C2801-ADVENTERPRISEK9-M), Version 12.4(24)T3


Cisco 2801 (revision 7.0) with 240640K/21504K bytes of memory.
2 FastEthernet interfaces
1 Serial(sync/async) interface
1 terminal line
1 Virtual Private Network (VPN) Module
4 Voice FXO interfaces
2 Voice FXS interfaces
1 DSP, 8 Voice resources
1 cisco service engine(s)
DRAM configuration is 64 bits wide with parity disabled.
191K bytes of NVRAM.
125440K bytes of ATA CompactFlash (Read/Write)

Configuration register is 0x2102

12.4T in general has always been a bit buggy when it comes to voice.   Try the latest 12.4(15)T code and see if that works better.  In my experience I found Cisco put a lot more work into bug fixes and stability in that version for voice than they did for 12.4(24)T.   Alternatively, 15.0(1)M4 is a stable version for voice which I've had good success in using.  It may require more DRAM for your 2801 in order to utilize it.

Also, the 2801 platform doesn't have a lot of horsepower. Would you mind posting a sanitized version of your config?  It is possible you are overworking it.   Try running 'show proc cpu hist' and see how much you are taxing the CPU.

Please help us make the communities better. Rate helpful posts!

Hi Thiago Cella ,

Try below config, I hope it will work, if u need more help u can reach me vikrant.ambhore on skype or Gtalk

voice-port 0/0/0
supervisory disconnect dualtone mid-call
no battery-reversal
output attenuation -6
timeouts call-disconnect 3
timeouts wait-release 3
timing sup-disconnect 300
cptone BR
connection plar opx 3901
station-id name LINHA-EXT 01
impedance complex1
caller-id enable


voice-port 0/0/1
supervisory disconnect dualtone mid-call
no battery-reversal
output attenuation -6
timeouts call-disconnect 3
timeouts wait-release 3
timing sup-disconnect 300
cptone BR
connection plar opx 3901
station-id name LINHA-EXT 02
impedance complex1
caller-id enable


voice-port 0/0/2
supervisory disconnect dualtone mid-call
no battery-reversal
output attenuation -6
timeouts call-disconnect 3
timeouts wait-release 3
timing sup-disconnect 300
cptone BR
connection plar opx 3901
station-id name LINHA-EXT 03
impedance complex1
caller-id enable


voice-port 0/0/3
supervisory disconnect dualtone mid-call
no battery-reversal
output attenuation -6
timeouts call-disconnect 3
timeouts wait-release 3
timing sup-disconnect 300
cptone BR
connection plar opx 3901
station-id name LINHA-EXT 04
impedance complex1
caller-id enable

If won't work so we need take some debug output

Ming Yuan Chiu
Enthusiast

Is it always the same port that is available?  If so, I've also ran into that problem and just RMA the card back to the vendor.  If the status was on-hook rather than off-hook, I would presume it was more of a config issue.

nascoentr
Beginner

can you run the following command and paste the value of the voltage

term mon

test voice-port 0/0/0 si-reg-read 29 1

you will normally get either a 0X00 or 0XNN (where NN is some number other than zero).

Hi nascoentr

I went through as per suggestion but i am getting error

% Invalid input detected at '^' marker.

oops i added an extra "-"

try this

term mon

test voice port 0/0/0 si-reg-read 29 1

for all ports

test voice port 0/0/1 si-reg-read 29 1

test voice port 0/0/2 si-reg-read 29 1

test voice port 0/0/3 si-reg-read 29 1

you should get an output of 0X00 or 0XNN (where NN is some value, digits like 0X42 or something)

Hello nascoentr,

Can you please look on this


coinop-uc520#test voice port 0/1/0 si-reg-read 29 1
coinop-uc520#
013996: Mar  3 04:29:45.990:
Values read from SiLabs Codec connected to DSP 0, channel 4:
--------------------------------------------------------------
Register 29 = 0xD3

013997: Mar  3 04:29:45.990:
coinop-uc520#test voice port 0/1/1 si-reg-read 29 1
coinop-uc520#
coinop-uc520#
013998: Mar  3 04:30:29.864:
Values read from SiLabs Codec connected to DSP 0, channel 5:
--------------------------------------------------------------
Register 29 = 0x30

013999: Mar  3 04:30:29.864:

Thiago Cella
Beginner

uscitizen

Tks, i will upgrade the RAM of the router e install another IOS in the router

Vikrant Ambhore

Your suggestion that works!! I put the timetout commands and now the ports are available!  Tks

Content for Community-Ad

Spotlight Awards 2021