cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
3698
Views
0
Helpful
18
Replies
kuliyevnatik
Beginner

Problem with MGCP gateway

I am having an issue with an MCGP gateway and CUCM 8. The MGCP gateway status is shown as unregistered in CCM. Below is the config of the MGCP gateway and here as you can see it.

Voice>en

Voice#sh run

Building configuration...

Current configuration : 2858 bytes

!

! Last configuration change at 19:00:54 UTC Mon Oct 15 2012

! NVRAM config last updated at 18:33:33 UTC Mon Oct 15 2012

! NVRAM config last updated at 18:33:33 UTC Mon Oct 15 2012

version 15.1

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname Voice

!

boot-start-marker

boot-end-marker

!

!

card type e1 0 0

! card type command needed for slot/vwic-slot 0/1

!

no aaa new-model

network-clock-participate wic 0

!

no ipv6 cef

ip source-route

ip cef

!

!

!

!

!

ip domain name baltika.local

multilink bundle-name authenticated

!

!

!

!

isdn switch-type primary-net5

!

crypto pki token default removal timeout 0

!

!

voice-card 0

!

!

!

!

!

!

!

license udi pid CISCO2911/K9 sn FCZ163120XY

hw-module pvdm 0/0

!

hw-module pvdm 0/1

!

!

!

!

redundancy

!

!

controller E1 0/0/0

pri-group timeslots 1-31 service mgcp

!

controller E1 0/0/1

pri-group timeslots 1-31 service mgcp

!

!

!

!

!

interface Embedded-Service-Engine0/0

no ip address

shutdown

!

interface GigabitEthernet0/0

no ip address

duplex auto

speed auto

!

interface GigabitEthernet0/0.1

encapsulation dot1Q 5

ip address 10.80.2.2 255.255.255.0

!

interface GigabitEthernet0/1

no ip address

shutdown

duplex auto

speed auto

!

interface GigabitEthernet0/2

no ip address

shutdown

duplex auto

speed auto

!

interface Serial0/0/0:15

no ip address

encapsulation hdlc

isdn switch-type primary-net5

isdn incoming-voice voice

isdn bind-l3 ccm-manager

no cdp enable

!

interface Serial0/0/1:15

no ip address

encapsulation hdlc

isdn switch-type primary-net5

isdn incoming-voice voice

isdn bind-l3 ccm-manager

no cdp enable

!

ip forward-protocol nd

!

no ip http server

no ip http secure-server

!

ip route 0.0.0.0 0.0.0.0 10.80.2.1

!

!

!

!

control-plane

!

!

voice-port 0/0/0:15

echo-cancel coverage 64

!

voice-port 0/0/1:15

echo-cancel coverage 64

!

ccm-manager redundant-host 10.80.2.11

ccm-manager mgcp

no ccm-manager fax protocol cisco

ccm-manager music-on-hold

ccm-manager config server 10.80.2.10 10.80.2.11

ccm-manager config

!

mgcp

mgcp call-agent 10.80.2.10 2427 service-type mgcp version 0.1

mgcp rtp unreachable timeout 1000 action notify

mgcp modem passthrough voip mode nse

mgcp package-capability rtp-package

mgcp package-capability sst-package

mgcp package-capability pre-package

no mgcp package-capability res-package

no mgcp timer receive-rtcp

mgcp sdp simple

mgcp fax t38 inhibit

mgcp bind control source-interface GigabitEthernet0/0.1

mgcp bind media source-interface GigabitEthernet0/0.1

!

mgcp profile default

!

!

!

!

!

gatekeeper

shutdown

!

!

!

line con 0

line aux 0

line 2

no activation-character

no exec

transport preferred none

transport input all

transport output pad telnet rlogin lapb-ta mop udptn v120 ssh

stopbits 1

line vty 0 4

login

transport input all

!

scheduler allocate 20000 1000

end

**********************************************************************

Voice#

Voice#

Voice#sh ccm

MGCP Domain Name: Voice.baltika.local

Priority        Status                   Host

============================================================

Primary         Registered               10.80.2.10

First Backup    Backup Ready             10.80.2.11

Second Backup   None

Current active Call Manager:    10.80.2.10

Backhaul/Redundant link port:   2428

Failover Interval:              30 seconds

Keepalive Interval:             15 seconds

Last keepalive sent:            20:10:24 UTC Oct 15 2012 (elapsed time: 00:00:02)

Last MGCP traffic time:         20:10:24 UTC Oct 15 2012 (elapsed time: 00:00:02)

Last failover time:             18:58:39 UTC Oct 15 2012 from (10.80.2.10)

Last switchback time:           18:59:24 UTC Oct 15 2012 from (10.80.2.11)

Switchback mode:                Graceful

MGCP Fallback mode:             Not Selected

Last MGCP Fallback start time:  None

Last MGCP Fallback end time:    None

MGCP Download Tones:            Disabled

TFTP retry count to shut Ports: 2

Backhaul Link info:

    Link Protocol:      TCP

    Remote Port Number: 2428

    Remote IP Address:  10.80.2.10

    Current Link State: OPEN

    Statistics:

        Packets recvd:   2

        Recv failures:   0

        Packets xmitted: 2

        Xmit failures:   0

    PRI Ports being backhauled:

        Slot 0, VIC 0, port 1

        Slot 0, VIC 0, port 0

Configuration Auto-Download Information

=======================================

Current version-id: 1350325725-ad4502fa-0427-473b-9107-b4fc0fbac1ba

Last config-downloaded:00:00:00

Current state: Waiting for commands

Configuration Download statistics:

        Download Attempted             : 16

          Download Successful          : 16

          Download Failed              : 0

          TFTP Download Failed         : 0

        Configuration Attempted        : 1

          Configuration Successful     : 1

          Configuration Failed(Parsing): 0

          Configuration Failed(config) : 0

Last config download command: New Registration

FAX mode: disable

Configuration Error History:

no network-clock-participate wic 0

end

no network-clock-participate wic 0

end

Voice#

Hardware vwic slot and port is right with gateway mgcp config, but status is unregistered again

2 ACCEPTED SOLUTIONS

Accepted Solutions

Hi All,

I agree with Allan, AIS means problem on the far end:

http://www.cisco.com/en/US/customer/tech/tk713/tk628/technologies_tech_note09186a00801069ff.shtml

Receive Alarm Indication Signal (Blue)

A receive (Rx) alarm indication signal (AIS) means there is an alarm  occurring on the line upstream from the equipment that is connected to  the port. The AIS failure is declared when an AIS defect is detected at  the input and still exists after the Loss Of Frame failure is declared  (caused by the unframed nature of the "all-ones" signal). The AIS  failure is cleared when the Loss Of Frame failure is cleared.

You need to get in contact with your Telco.

To further test your E1, you can make a loopback test:

controller e1 0/0/0

loopback diag

Then you can issue "show controller e1 0/0/0"; interface showuld go UP.

The MGCP E1 will not register until the interface is UP.

--

Jorge Armijo

-- Jorge Armijo Please remember to rate helpful responses and identify helpful or correct answers.

View solution in original post

That's correct' it will not register unless physically connect to your carriers equipment.

Regards
Allan

View solution in original post

18 REPLIES 18

In cucm did you config the same domain for MGCP?

try this on the GW no mgcp / mgcp

try deleting and adding again the GW at CUCM

Regards
Leonardo Santana

*** Rate All Helpful Responses***
Jorge Armijo
Enthusiast

Hi,

Please make sure that the MGCP Domain name in CUCM is "Voice.baltika.local", this is the result from show ccm-manager.

--

Jorge Armijo

-- Jorge Armijo Please remember to rate helpful responses and identify helpful or correct answers.

Thnaks for replay but name is right

MGCP Domain Name: Voice.baltika.local

Can you post your CUCM config?

Regards
Leonardo Santana

*** Rate All Helpful Responses***
allan.thomas
Collaborator

Hi,

It appears that you have two E1 wics, one of which you have specified to the correct card type. Typically the interface fails to register due the protocol layer being down with the SP. can you confirm the "show isdn status", do you have multiple frame established?

Sent from Cisco Technical Support iPad App

Hi

Yes, i have 2 E1 card and no body not connected to SP

here

Voice>en

Voice#sh isdn status

Global ISDN Switchtype = primary-4ess

%Q.931 is backhauled to CCM MANAGER 0x0003 on DSL 0. Layer 3 output may not apply

ISDN Serial0/0/0:15 interface

        dsl 0, interface ISDN Switchtype = primary-net5

        L2 Protocol = Q.921 0x0000  L3 Protocol(s) = CCM MANAGER 0x0003

    Layer 1 Status:

        SHUTDOWN

    Layer 2 Status:

        TEI = 0, Ces = 1, SAPI = 0, State = TEI_ASSIGNED

    Layer 3 Status:

        0 Active Layer 3 Call(s)

    Active dsl 0 CCBs = 0

    The Free Channel Mask:  0x00000000

    Number of L2 Discards = 0, L2 Session ID = 1

%Q.931 is backhauled to CCM MANAGER 0x0003 on DSL 1. Layer 3 output may not apply

ISDN Serial0/0/1:15 interface

        dsl 1, interface ISDN Switchtype = primary-net5

        L2 Protocol = Q.921 0x0000  L3 Protocol(s) = CCM MANAGER 0x0003

    Layer 1 Status:

        SHUTDOWN

    Layer 2 Status:

        TEI = 0, Ces = 1, SAPI = 0, State = TEI_ASSIGNED

    Layer 3 Status:

        0 Active Layer 3 Call(s)

    Active dsl 1 CCBs = 0

    The Free Channel Mask:  0x00000000

    Number of L2 Discards = 0, L2 Session ID = 0

    Total Allocated ISDN CCBs = 0

Voice#

Hi,

Looks like you have no layer 1 status with your carrier. Can you post a " show controller e1", this will give us an idea why the interface is not connected.

Sent from Cisco Technical Support iPad App

Voice#sh controller e1

E1 0/0/0 is down.

  Applique type is Channelized E1 - balanced

  Transmitter is sending remote alarm.

  Receiver is getting AIS.

  alarm-trigger is not set

  Version info FPGA Rev: 08121917, FPGA Type: PRK4

  Framing is CRC4, Line Code is HDB3, Clock Source is Line.

  International Bit: 1, National Bits: 11111

  Data in current interval (200 seconds elapsed):

     1638200 Line Code Violations, 0 Path Code Violations

     0 Slip Secs, 200 Fr Loss Secs, 200 Line Err Secs, 0 Degraded Mins

     0 Errored Secs, 0 Bursty Err Secs, 0 Severely Err Secs, 200 Unavail Secs

  Total Data (last 1 15 minute intervals):

     7289507 Line Code Violations, 25 Path Code Violations,

     0 Slip Secs, 871 Fr Loss Secs, 894 Line Err Secs, 0 Degraded Mins,

     0 Errored Secs, 0 Bursty Err Secs, 0 Severely Err Secs, 900 Unavail Secs

E1 0/0/1 is administratively down.

Hi,

The receive ais indicates that you have an issue with the upstream equipment, there are error frames and violations. Have you raised this with your carrier?

Regards
Allan

that is, do you mean for that would changed the status changes to "register" to raise the full link? that is to be set up and plugged the cable from above standing equipment?

Hi All,

I agree with Allan, AIS means problem on the far end:

http://www.cisco.com/en/US/customer/tech/tk713/tk628/technologies_tech_note09186a00801069ff.shtml

Receive Alarm Indication Signal (Blue)

A receive (Rx) alarm indication signal (AIS) means there is an alarm  occurring on the line upstream from the equipment that is connected to  the port. The AIS failure is declared when an AIS defect is detected at  the input and still exists after the Loss Of Frame failure is declared  (caused by the unframed nature of the "all-ones" signal). The AIS  failure is cleared when the Loss Of Frame failure is cleared.

You need to get in contact with your Telco.

To further test your E1, you can make a loopback test:

controller e1 0/0/0

loopback diag

Then you can issue "show controller e1 0/0/0"; interface showuld go UP.

The MGCP E1 will not register until the interface is UP.

--

Jorge Armijo

-- Jorge Armijo Please remember to rate helpful responses and identify helpful or correct answers.

Yes !

loopback diag -- solv my problem

Thanks a lot

Incidentally, has your carrier advised on the framing and line coding they are using? The alarms and errors could be as a result of incorrect settings. Are they using non-crc framing?

Regards
Allan

Thanks`s Allan for your help

But i want to say you that now i don`t have a link from my SP or anyhere.

that is, until I plug the working link to the E1 port status will not change?

Create
Recognize Your Peers
Content for Community-Ad