Showing results for 
Search instead for 
Did you mean: 


Problems with calls H.323 / CCM 4.2


I'm having problems to call from an external number through an H.323 gateway to a CCM 4.2 extension. I performed a debug voip ccapi inout and I have a communications problem between the CCM and the GW, but I don't know what kind of problem. Please see the debug. I have drawn a line just where the problem starts, I think before of that everything's ok.

Anyone has an idea about what is failing? I'd really appreciate your help.


Your two call manager dial peers do not match in IP Address. Also, ensure that you are using the same address in Call Manager as you are binding the h323 traffic to on the router. Make sure that you have reset the gateway after configuring it in the system. Make sure that you have the correct CSS.

Jaime Valencia
Hall of Fame Cisco Employee

guess he has the 2 different IPs to point to a PUB and SUB so that should be fine

try configuring a pots DP with incoming called number . to match that one and not the default dial-peer for the incoming call leg

49 means Quality of service unavailable

also as noted, make sure the incoming CSS can reach the destination phone



if this helps, please rate



if this helps, please rate


You are right, the two IPs are pointing to the subscriber and publisher servers.

I don't know if the call is rejected because it has to go through the WAN (ADSL) to reach the CCM and because of this it returns a code 49. What do you think?

I have tried creating this dial-peer since all calls entering through the FXO ports have to be redirected to the operator's DN which is the 4511, but it does not work

dial-peer voice 150 voip

destination-pattern 4511

session-target ipv4:

The incoming dial-peer does not match the default, it matches the DP 1030 or 1031 depending the number you dial. (Both ports are conected to POTS lines)

I'm thinking about changing the IOS version because I have another gateway configured similarly and it does work, but with a different IOS version. The traffic of this gateway does not pass through the WAN to reach the CCM, so maybe it's related.

Any new ideas regarding this?

Ok, the problem has been solved. It was a physical problem with the ports. We tried with one free port using the same configuration and it worked, it was weird because outgoing calls were working right. We'll just start the RMA right away.

Thanks everybody for your help.

Content for Community-Ad