cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

Cisco Community Designated VIP Class of 2020

616
Views
0
Helpful
1
Replies
Beginner

QoS for CME Router Ehternet Port

Dear All,

I have a 2811 router with CME. 2 VLAN - Data VLAn is 1 and Voice VLAN is 10. The router is connected to 3750 switch as a trunk.

1. On Switch, I would like to use auto-qos. For Port to Cisco phone, i use "auto qos voip cisco-phone". For port to router, what command should i use? Is it ok to use "auto qos voip trust". Should I also need to use "mls qos trust dscp"

2. What qos command should i configured on router?

Thanks.

Hui

1 REPLY 1
Highlighted
Enthusiast

Re: QoS for CME Router Ehternet Port

Use the "auto qos voip trust" on the ethernet port of the ROUTER (see example below). You don't need to mark the trunk port on the switch that connects to the router, as all traffic headed to the voice vlan on the router (from phones, etc.,) will be prioritized as they come in their respective ports. If you prioritize the router (as I show below), all outbound traffic leaving the router will be prioritized properly as well.

To explain it another way, the router will do the prioritizing for you, so you don't need to have the switch prioritize traffic on the trunk.

---------------------------------------

!

interface FastEthernet0/0

description Trunk to switch

no ip address

duplex auto

speed auto

auto qos voip trust

service-policy output AutoQoS-Policy-Trust

!

interface FastEthernet0/0.10

description Data VLAN 10

encapsulation dot1Q 10

ip address 192.168.10.1 255.255.255.0

no snmp trap link-status

!

interface FastEthernet0/0.20

description Voice VLAN 20

encapsulation dot1Q 20

ip address 192.168.20.1 255.255.255.0

no snmp trap link-status

!

---------------------------------------

Later,

Go0se

CreatePlease to create content
Content for Community-Ad
FusionCharts will render here