cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
390
Views
0
Helpful
5
Replies

QoS help needed!!!!!!!!

Michael Durham
Enthusiast
Enthusiast

I work from home and have a GRE tunnel to my office.  At home I have just 1 Cisco 7970 IP phone that connects to the office's CME.  I do not kave ay QuS experience and need some help setting it up so that the IP phone gets priority.

My 7970 connects to a 3550 switch which connects to another 3550 switch then to my 2851 router and out to my HughesNet Internet provider.  My office connects to Comcase via a 2801 router that connects to a 3524 switch where a 2851 CME router handles our inbound and outbound calls via a SIP connection.

My 7970 is on the 192.168.3.x netowrk and is the only device on that network except for the sub-interface on my 2851 router at my home,

I have a dynamic GRE Tunnel between my home and office and is on the 172.30.1.x network  The office CME router is on the 192.168.2.x network.

On the 3550 switch that the 7970 is directly connected to I hvave these QoS settings:

description YELLOW - Phone 7970 connected to NetCertLabs
switchport access vlan 110
switchport mode access
switchport nonegotiate
switchport voice vlan 3
mls qos trust device cisco-phone
mls qos trust cos
auto qos voip cisco-phone
wrr-queue bandwidth 10 20 70 1
wrr-queue min-reserve 1 5
wrr-queue min-reserve 2 6
wrr-queue min-reserve 3 7
wrr-queue min-reserve 4 8
wrr-queue cos-map 1 0 1
wrr-queue cos-map 2 2 4
wrr-queue cos-map 3 3 6 7
wrr-queue cos-map 4 5
priority-queue out
spanning-tree portfast

And the Trunk port to the other 3550 has these settings for QoS:

description Switch - Server_Switch 192.168.100.101 port fa0/1, Access Point - South_AP 192.168.100.105 port Ethernet 0, Servers

switchport trunk encapsulation dot1q

switchport trunk native vlan 100

switchport trunk allowed vlan 1,3,69,100,110,125,200,900

switchport mode trunk

mls qos trust cos

auto qos voip trust

wrr-queue bandwidth 10 20 70 1

wrr-queue min-reserve 1 5

wrr-queue min-reserve 2 6

wrr-queue min-reserve 3 7

wrr-queue min-reserve 4 8

wrr-queue cos-map 1 0 1

wrr-queue cos-map 2 2 4

wrr-queue cos-map 3 3 6 7

wrr-queue cos-map 4 5

priority-queue out

spanning-tree portfast

The second 3550 has these QoS settings on the Trunk to the first 3550 switch:

description BLUE - Switch - Office_Switch 192.168.100.102 port fa0/21

switchport trunk encapsulation dot1q

switchport trunk native vlan 100

switchport trunk allowed vlan 1,3,69,100,110,125,200,900

switchport mode trunk

mls qos trust cos

auto qos voip trust

wrr-queue bandwidth 10 20 70 1

wrr-queue min-reserve 1 5

wrr-queue min-reserve 2 6

wrr-queue min-reserve 3 7

wrr-queue min-reserve 4 8

wrr-queue cos-map 1 0 1

wrr-queue cos-map 2 2 4

wrr-queue cos-map 3 3 6 7

wrr-queue cos-map 4 5

priority-queue out

spanning-tree portfast

     And the port on the second 3550 to my 2851 edge router is set to;

description Router - Boarder Router 192.168.30.5 & Call Manager Express router 10.110.0.1

switchport trunk encapsulation dot1q

switchport mode trunk

switchport nonegotiate

mls qos trust cos

auto qos voip trust

wrr-queue bandwidth 10 20 70 1

wrr-queue min-reserve 1 5

wrr-queue min-reserve 2 6

wrr-queue min-reserve 3 7

wrr-queue min-reserve 4 8

wrr-queue cos-map 1 0 1

wrr-queue cos-map 2 2 4

wrr-queue cos-map 3 3 6 7

wrr-queue cos-map 4 5

priority-queue out

spanning-tree portfast

So from what I can tell the switches are set correctly.

I have no QoS on any of the routers or the 3524 switch at the office.

Can someone please advise me as to what to set and where to set it so that my VoIP calls from home one the 192.168.3.x network get priority over the VPN to the office and Also so that the VoIP calls back from the office to my 7970 get priority too.

Thank You,

Michael

5 REPLIES 5

paolo bevilacqua
Hall of Fame Master Hall of Fame Master
Hall of Fame Master

QoS on the switches doesn't matter at all, except when is there, it's likely to cause unexpected drop as it mess up the default optimal buffer allocation.,

QoS would be to be applied to the point of congestion, that often is not even under your control, there are some workaround configurations that can be made, but are not even effective all the time.

Then on the Internet, there is no QoS of course.

All in all, in most cases is better to leave things as they are, avoid loosing time for little or no tangible results.


yahsiel2004
Rising star
Rising star

You need to create a class-map and a policy-map to give your VoIP traffic priority. As Paolo stated, setting QoS may not be too much help for your scenario, since your are tying to QoS traffic out the router from your home and office, which the main issue is the ISP in between.

HTH

Regards,

Yosh

HTH Regards, Yosh

I need help writing and applying the configuration that you recomend.  Below is a drawing of my network.

I know that there is not QoS over the Internet but what I need to set up is for ANY packets destin to the CME (192.168.2.1) router at the office have top priority leaving my home router over any other packet. 

Can someonw help write the correct ACL, class-map and ploicy-map and tell me where to apply them.  Also, do I need to place any on the office's router too? The tunnel is a GRE dynamic tunnel.

If you need any other information, I can provide it too.

Hi Michael,

            As paolo said, two points are clear, first point it is not under your control, from my understanding, 3560 or 3550 uses auto qos, only 3750 or later uses manual qos, second point is anyway you are using internet which doesn't have qos.  For knowledge info, please see following link

http://www.cisco.com/en/US/docs/switches/lan/catalyst3560/software/release/12.2_25_see/configuration/guide/swqos.html

Please rate if this helps.

thanks 

I know that I do not have control over the Internet and yes the 3550 switches have auto QoS/ 

What I want to do is make sure that ANY VoIP traffic leaving my home goes our first.  What happens beyond that I connot control.  I understand that I need to use class-map and policy-map to do this.  Can someone help me creste those mappings please?

In other words, I want VoIP to have 75-100% of my available bandwidth when I am on a VoIP call.  Those calls go THROUGH the VPN tunnel to my office's CME router then out their network.

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community: